Welcome, Guest
Username: Password: Remember me

TOPIC: Error 324 (net::ERR_EMPTY_RESPONSE)

Error 324 (net::ERR_EMPTY_RESPONSE) 2 years 7 months ago #78727

  • gagakitam
  • gagakitam's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Hi everyone.

I've experienced problems with LS after upgrading it to the latest version (1.87 to 1.92 build 120412).

I have two copy of the 1.87. One in a development server which can only accessed internally among developers. The second is a production server accessed by public. Both server have the same PHP, Mysql and apache version.

My LS upgrading activity in Dev server was a success. Everything running good. the admin page and also the surveys were okay.

But after I've upgraded the version inside the production server, problem occurred. Every survey with multiple question type such array, list, radio button were not appeared accordingly in the browser. admin page was ok. When i try to test one whole survey from production server, especially survey with array type questions, it show error/blank page.

lime1.JPG

when I click test survey button, this is the url look like.


lime2.JPG

In the welcome page, I click the NEXT button. The url will change to only index.php and remove all others extra variable.

lime3.JPG

The survey questions should appear after I click the NEXT button but only surveys from development server appear accordingly, not the surveys from production server. This is the error page appeared from surveys in production server. (chrome browser error: Error 324 (net::ERR_EMPTY_RESPONSE))

Can anyone help me to repair the LS in production server?

Thank you in advance!
The administrator has disabled public write access.

Re: Error 324 (net::ERR_EMPTY_RESPONSE) 2 years 7 months ago #78732

  • c_schmitz
  • c_schmitz's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 823
  • Thank you received: 116
  • Karma: 93
Hello!

Looks like there is an error in config.php
Open it in a text editor and correct the $rooturl. (where the unnecessary limetest needs to removed).
Support us, too. Donate to the LimeSurvey project and help keep us going!
The administrator has disabled public write access.

Re: Error 324 (net::ERR_EMPTY_RESPONSE) 2 years 7 months ago #78743

  • gagakitam
  • gagakitam's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Hi Mr c_schimtz.

Sorry that my previous image was not perfectly cropped.


lime4.JPG

This is the actually URL for my problem. The "limetest" in the $rooturl is actually the LS folder name.

Sorry for the mistake. Please help me. TQVM!
The administrator has disabled public write access.

Re: Error 324 (net::ERR_EMPTY_RESPONSE) 2 years 7 months ago #78749

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5423
  • Thank you received: 307
  • Karma: 252
1. Are both systems really using the exact same configuration?

2. Did you try exporting the working survey and importing it at the system where it was not working?

3. Please switch on debug mode by adding the following line to your config.php file:
$debug = '1';

Are there any additional errors reported on top of the page?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Error 324 (net::ERR_EMPTY_RESPONSE) 2 years 7 months ago #78753

  • gagakitam
  • gagakitam's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Dear Mazi,

1. Yes both systems are using the same configuration.

2. I've tried it but still showing the same error.

3. $debug has been inserted but no additional error appear.

FYI, I've pointed both system to the same database server. The dev server running ok but the prod server still with same problem.

TQ.
The administrator has disabled public write access.

Re: Error 324 (net::ERR_EMPTY_RESPONSE) 2 years 7 months ago #78761

  • gagakitam
  • gagakitam's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Dear all,

I've check with the error_logs and found this log:
PHP Fatal error: Allowed memory size of 16777216 bytes exhausted

After that I changed my production server memory_limit in php.ini and glad that the LS in the prod server finally appear correctly.

Thank you guys! Limesurvey is one of the best!
The administrator has disabled public write access.

Re: Error 324 (net::ERR_EMPTY_RESPONSE) 2 years 7 months ago #78777

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5423
  • Thank you received: 307
  • Karma: 252
gagakitam wrote:
Thank you guys! Limesurvey is one of the best!
You're welcome :-)

If our hints have been helpful and you enjoy limesurvey please consider a donation to give Limesurvey a future .
We do all this in our free time and you don't have to pay a penny for this software.

Without your help we can't keep this project alive.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.152 seconds
Donation Image