Welcome, Guest
Username: Password: Remember me

TOPIC: [Solved] Session Timeout ( one possible solution)

[Solved] Session Timeout ( one possible solution) 2 years 6 months ago #78119

  • muellers
  • muellers's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 18
  • Karma: 0
Hi,

here is one possible solution if you get the message

"ERROR
We are sorry but your session has expired.
Either you have be been inactive ..."

while running your survey.

The problem is not always the session timeout you can specify in the global settings (default 3600 sec seems pretty enough) nor a cookie nor a connection problem.

This solution is especialy for surveys with many questions in a group that cause this behaviour.

The point is a default value set by the PHP version since 5.3.9.

The value "max_input_vars" is set to 1000 by default.
To increase the value you have to add a line in the [PHP] section in your php.ini on your server.

max_input_vars integer
 
How many input variables may be accepted. Use of this directive mitigates the possibility of denial of service attacks which use hash collisions. If there are more input variables than specified by this directive, an E_WARNING is issued, and further input variables are truncated from the request. This limit applies only to each nesting level of a multi-dimensional input array.
more information about the key
php.net/manual/en/ini.core.php


eg. add in your php.ini
max_input_vars = 2000

you can verify your settings by examining your phpinfo() output.

Hope this helps

greetings
steve
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.183 seconds
Donation Image