Welcome, Guest
Username: Password: Remember me

TOPIC: LimeSurvey behind Proxy

LimeSurvey behind Proxy 2 years 3 months ago #77916

  • dreier
  • dreier's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 24
  • Thank you received: 2
  • Karma: 3
Hello Community,

I have actually planned to get LimeSurvey productive in our company. Actually i am restricted to install LimeSurvey 1.92+ Build 120319 on a machine in a local network. Now i got a configuration of a reverse proxy server which is directing on my local server.
Now the proxy redirects to my server without any problem. I can login (via Webserver login) and get into LimeSurvey. But now i am unable to do anything:
If I try to make something, I get on a new Site which tells me "Reloading screen. Please wait." and I get on this site again and again - it loads - done -loads - done...but never get anywhere else.
If I try to use the normal login, I can't even login, I just get redirected to the login site without any information.
So my question is: Is there anything wrong with our proxy server, or do we have to be patient about any configuration in LimeSurvey to use it behind a proxy?

Regards
dreier
Last Edit: 2 years 3 months ago by dreier.
The administrator has disabled public write access.

Aw: LimeSurvey behind Proxy 2 years 3 months ago #77929

  • dreier
  • dreier's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 24
  • Thank you received: 2
  • Karma: 3
Update:
After changin the "rooturl" in the config to the proxy-url and deleting the browsercache (which i did for sure just after 1hour testing..) the Admin-Site is working fine!
But there is still a problem left: I cannot answer a survey - I can reach the Welcome-Site but by clicking the next button I get to the survey overview site.

Actually I redirect from https to http - could that be the problem? This configuration was not my idea, it was recommended by the proxy admin.

Regards,
dreier
The administrator has disabled public write access.

Re: Aw: LimeSurvey behind Proxy 2 years 3 months ago #77937

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5300
  • Thank you received: 291
  • Karma: 247
This probably is caused by your weird configuration. Another source of trouble might be the server configuration. If there are too strict security settings, e.g. for the "suhosin" module, this might cause problems as well.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: LimeSurvey behind Proxy 2 years 3 months ago #77940

  • dreier
  • dreier's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 24
  • Thank you received: 2
  • Karma: 3
Hey,

okay solved it by myself - was my mistake:
Have used the proxy as rooturl via http - after changing to https it worked.

Topic can be closed. Sorry for bothering your time.

Cheers
dreier
The administrator has disabled public write access.

Aw: LimeSurvey behind Proxy 1 year 4 months ago #93571

Which config file you are referring to? It is not in conf/config.php nor conf/limesurvey.conf.

I can't specify the URL when I create the survey….

Please tell me.
The administrator has disabled public write access.

Aw: LimeSurvey behind Proxy 1 year 4 months ago #93573

I got it.

In config-defaults.php, change $config
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.120 seconds
Donation Image