Welcome, Guest
Username: Password: Remember me

TOPIC: Email not working with Amazon SES via SMTP/TLS

Email not working with Amazon SES via SMTP/TLS 2 years 3 months ago #77381

  • Fred
  • Fred's Avatar
  • OFFLINE
  • Gold Lime
  • Posts: 163
  • Thank you received: 5
  • Karma: 3
Hi, has anybody had success using Amazon SES for email? I have Limesurvey running on an Amazon EC2 instance and don't want to rely on local sendmail.

I tested Limesurvey smtp using my gmail account and SSL and it's fine. But when I switch to Amazon SES and use TLS I get the following error:

Notice: fputs(): send of 24 bytes failed with errno=32 Broken pipe in /apache2/htdocs/limesurvey/classes/phpmailer/class.smtp.php on line 498

I wrote a simple PHP script to test sending through the PHPmailer class in Limesurvey for another app on the same machine and it works fine, so I know the Amazon settings are correct and there's nothing wrong with PHPmailer. It just won't send from Limesurvey.
The administrator has disabled public write access.

Re: Email not working with Amazon SES via SMTP/TLS 2 years 3 months ago #77608

  • Fred
  • Fred's Avatar
  • OFFLINE
  • Gold Lime
  • Posts: 163
  • Thank you received: 5
  • Karma: 3
Nevermind, I fixed it. Had to select SSL rather than TLS.
The administrator has disabled public write access.

Re: Email not working with Amazon SES via SMTP/TLS 2 years 3 months ago #77619

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6205
  • Thank you received: 787
  • Karma: 238
Thank you ,

Maybe you can put this information on the documentation:
docs.limesurvey.org/Global+settings#Email_settings
Some clean example can be a good idea (think og gmail/amazon/ other 'give us our data but not your money' services )

Denis
The administrator has disabled public write access.
The following user(s) said Thank You: Fred

Re: Email not working with Amazon SES via SMTP/TLS 2 years 3 months ago #77867

  • Fred
  • Fred's Avatar
  • OFFLINE
  • Gold Lime
  • Posts: 163
  • Thank you received: 5
  • Karma: 3
Ok I put a note on the bottom of the documentation page.
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.102 seconds
Donation Image