Welcome, Guest
Username: Password: Remember me

TOPIC: The token you have provided is either not valid, or has already been used

The token you have provided is either not valid, or has already been used 2 years 7 months ago #77175

  • elena_sai
  • elena_sai's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 11
  • Karma: 0
When I try to use the surveygives me the following error:
The ID entered is not valid or is already used by another user

I state that in the past, other survey worked well with the logic of the tokens.

I performed the following activities:
0) I made a new survey
1) I canceled the tokens from the survey(outcome = OK)
2) I imported the list of users that send a csv (outcome = OK)
3) I generated the token ((result = OK))
4) I have reactivated the survey

5) All people have the message in teh object:

This is a controlled survey. You need a valid token to participate.
The token you have provided is either not valid, or has already been used.


BUT:
If I add manually a new identifier and after i recreate a new Token,
this works!


I expected that, when I create a new survey, I can import the list of persons from a csv file (like template) to recreate the Token and then activate the survey.

What am I doing wrong?
The administrator has disabled public write access.

Re: The token you have provided is either not valid, or has already been used 2 years 7 months ago #77239

  • elena_sai
  • elena_sai's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 11
  • Karma: 0
This morning i have made those actions:
1) Backup all survey
2) bACKUP db
3) delete all survey
4) load une survey
5) import user from csv
6) generate token
7) test the survey
8) I have the same ERROR!!

Please HELP ME!!
The administrator has disabled public write access.

Re: The token you have provided is either not valid, or has already been used 2 years 7 months ago #77248

I think I know how to help you.

Edit the file with exported tokens (in *.csv file) in MS Excel (or another program), having left only columns tid, firstname, lastname, email. For it (in MS Excel 2007):

1) Open file *.csv
2)On tab "Data" select "Text to columns". In wizard select step by step:
- with delimiters
- only comma (maybe tail, I work in non-English ver. of Excel)
- The general format
Ready!

3)Save this file (after corrections) in such format: *.csv (delimiters - tails). "Save as" in MS Excel
4)Maybe you need to change the coding of file(it's in rare instances, when language of tokens differs from English)
5)Now import to your test (survey) *.csv , select delimiter(separator) as symbol (;)
Coding: "Automatic"
Last Edit: 2 years 7 months ago by Moebiusloop.
The administrator has disabled public write access.

Re: The token you have provided is either not valid, or has already been used 2 years 7 months ago #77348

  • elena_sai
  • elena_sai's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 11
  • Karma: 0
Thanks for the suggestion!!!
in the file I found some strange characters, only with the program "UltraEdit-32" i was able to see them.
After I canceled those characters, the program worked fine.
:cheer:
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.109 seconds
Donation Image