Welcome, Guest
Username: Password: Remember me

TOPIC: Errors with Windows IIS & MS SQL

Errors with Windows IIS & MS SQL 2 years 4 weeks ago #76920

  • maver
  • maver's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
Hello, we have a test Version 1.92+ Build 120314 environment with Win2008 R2 IIS box with PHP installed. Another box that is running SQL2008. I have gotten to where I can at least login to the admin.php page.

1st issue: Whenever i goto the Global Settings wizard and click "Save Settings" on any page, I get Internet Explorer cannot display this webpage." If I click Back, the settings are actually saved.

2nd issue: When I goto create a Question Group, i get this error:
SQLState: 42000 Error Code: 421 Message: [Microsoft][SQL Server Native Client 10.0][SQL Server]The text data type cannot be selected as DISTINCT because it is not comparable. :select distinct a.qid, a.attribute, a.value from [lime_question_attributes] as a, [lime_questions] as b where a.qid=b.qid and b.sid=12559 and a.language='en' and b.language='en' order by a.qid, a.attribute

The group gets populated in the dropdown, but I cannot edit them.

Since there is little to no info on using MSSQL, I managed to get my db populated by using this SQL script: bugs.limesurvey.org/view.php?id=5913

any help is greatly appreciated!
The administrator has disabled public write access.

Re: Errors with Windows IIS & MS SQL 2 years 4 weeks ago #76931

  • MPIDR
  • MPIDR's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 17
  • Karma: 0
There are a number of traps you can step into when using Windows and MS SQL.

1) You need to create your database using the script provided here: bugs.limesurvey.org/view.php?id=5913

2) Make sure the /tmp folder is set to write access for your anonymous user. On Windows 2008 R2, this is most likely a Windows group called IIS_IUSRS.

3) Create a temp folder for PHP and allow your IIS anonymous user write access. Search for upload_tmp_dir, session.save_path and error_log and change the settings to the new temp folder.

Regards
MPIDR
The administrator has disabled public write access.

Re: Errors with Windows IIS & MS SQL 2 years 4 weeks ago #76932

  • MPIDR
  • MPIDR's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 17
  • Karma: 0
Just forgot this one:

4) Create an SQL user on the SQL server and assign it the dbo role for your LimeSurvey database. Configure the config.php on your LimeSurvey server accordingly. The $databasetype should be set to mssqlnative.

Regards
MPIDR
The administrator has disabled public write access.

Re: Errors with Windows IIS & MS SQL 2 years 4 weeks ago #77010

  • maver
  • maver's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
MPIDR wrote:
There are a number of traps you can step into when using Windows and MS SQL.

1) You need to create your database using the script provided here: bugs.limesurvey.org/view.php?id=5913

2) Make sure the /tmp folder is set to write access for your anonymous user. On Windows 2008 R2, this is most likely a Windows group called IIS_IUSRS.

3) Create a temp folder for PHP and allow your IIS anonymous user write access. Search for upload_tmp_dir, session.save_path and error_log and change the settings to the new temp folder.

Regards
MPIDR

Thank you for taking the time to respond!

1) The link you provided is the same i posted. The create-mssqlnative.sql file that is posted is the same as in the latest Limesurvey download...and it did not work. Something about column names were not unique. Instead, i used the .sql file the bug reporter supplied as that appeared to have worked.

2) Thanks, this was not set.

3) This was set as I used this whitepaper (www.bfcnetworks.com/whitepapers/installi...2008-r2-x64-sql-iis/) This server already runs Moodle with no issues.

4) My SQL user, DB and config.php are all configured.

After making the change outlined in 2), I am still experiencing same issues.
The administrator has disabled public write access.

Re: Errors with Windows IIS & MS SQL 2 years 4 weeks ago #77013

  • MPIDR
  • MPIDR's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 17
  • Karma: 0
I've seen this error during my installation last week but cannot exactly remember what was causing this and how I solved it.

Anyway, here is something else to try. Go back to LimeSurvey 1.91. It seems to work better with Windows and MS SQL. Then you can upgrade to 1.92. However, the update scripts that come with 1.92 do not work. This has been fixed already and I can provide you with the latest version.

So please try 1.91 and let me know if this is working for you.

Regards
MPIDR
The administrator has disabled public write access.

Re: Errors with Windows IIS & MS SQL 2 years 4 weeks ago #77015

  • maver
  • maver's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
Thanks but I was able to modify the script that comes with the latest version and take out some syntax errors. I created a bug report here: bugs.limesurvey.org/view.php?id=5935

I seem to be able to create my question groups now. Still having an issue with #1.

I will muddle on...thanks!
The administrator has disabled public write access.

Re: Errors with Windows IIS & MS SQL 2 years 4 weeks ago #77017

  • MPIDR
  • MPIDR's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 17
  • Karma: 0
I am glad you solved it.

You are right, #1 isn't working here too. I just hit F5 ;-)
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.105 seconds
Donation Image