Welcome, Guest
Username: Password: Remember me

TOPIC: Buttons missing in IE since upgrade - no "Next" or "Exit etc"

Buttons missing in IE since upgrade - no "Next" or "Exit etc" 2 years 7 months ago #76428

  • pksupport
  • pksupport's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 34
  • Thank you received: 1
  • Karma: 0
Hello, I am running Version 1.92 Build 120303 on OS X Server 10.6.8. Either the LS upgrade or upgrading the server to PHP 10.8, or an old template, has caused a bug which means no "Next" or "Exit and clear survey" buttons in Internet Explorer when users arrive at the survey after clicking on the email registration. Firefox 10 on Windows works. I test on XP/IE8.

The template is a variation on eirenicon. It's fairly old now - is there a way to fix this or do I need to scrap the template? For the moment I have put a warning to use Firefox but I need to fix this ASAP as the poor students are freaking out - thanks for your time - it's much appreciated.
The administrator has disabled public write access.

Re: Buttons missing in IE since upgrade - no "Next" or "Exit etc" 2 years 7 months ago #76448

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6471
  • Thank you received: 854
  • Karma: 254
Hello,

Did it work with default template ? Did it work with the included version of eirenicon ?

Denis
The administrator has disabled public write access.

Re: Buttons missing in IE since upgrade - no "Next" or "Exit etc" 2 years 7 months ago #76455

  • pksupport
  • pksupport's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 34
  • Thank you received: 1
  • Karma: 0
I have just been going through all my surveys. It does work with the default eirenicon. It doesn't work with any of the versions of eirenicon which I altered (and there are about 6) So it's my template, not LS or PHP. I didn't really hack them a lot per se; but I made a lot of changes to the text. So it could be anything. The update must have exposed some errors I made, I guess. It's a lot of work to redo them all but that's the way it goes sometimes. It's a fantastic application and I rarely have issues with it. Plus the latest update fixed a a small but very annoying bug, where on a Mac if you spent more than a minute editing a question, it wouldn't save. That's been fixed so I'm happy about that. Just have to fix all the templates now.
The administrator has disabled public write access.

Re: Buttons missing in IE since upgrade - no "Next" or "Exit etc" 2 years 7 months ago #76458

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6471
  • Thank you received: 854
  • Karma: 254
pksupport wrote:
It doesn't work with any of the versions of eirenicon which I altered (and there are about 6) So it's my template, not LS or PHP.
Maybe if you give acces to a "survey with template" test we can have a look.

Like you say, the error can be from a lot of think, we can't tell you where are the error without seeing in real.

Denis
The administrator has disabled public write access.

Re: Buttons missing in IE since upgrade - no "Next" or "Exit etc" 2 years 7 months ago #76535

  • pksupport
  • pksupport's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 34
  • Thank you received: 1
  • Karma: 0
Thanks for the offer, but I really have to get the most important form fixed right now. I'm just looking for the place to edit REGISTERMESSAGE1 - the docs say it's a .po file, but that can't be right. I have replaced locale many times. Where is REGISTERMESSAGE1 generated from please?
The administrator has disabled public write access.

Re: Buttons missing in IE since upgrade - no "Next" or "Exit etc" 2 years 7 months ago #76536

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6471
  • Thank you received: 854
  • Karma: 254
Hello,

You don't have to edit translation for register message.

Just go in template, register, register.pstpl and remove {REGISTERMESSAGE1} and replace by what you want.
It's the best for a monolingual survey. And for multilingual, ther are too some possibility.

Denis
The administrator has disabled public write access.

Re: Buttons missing in IE since upgrade - no "Next" or "Exit etc" 2 years 7 months ago #76537

  • pksupport
  • pksupport's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 34
  • Thank you received: 1
  • Karma: 0
Got it thanks very much. On course now. I really appreciate the help Denis.

Just as a matter of interest, where does the source of {REGISTERMESSAGE1} come from? It's in the locale files somewhere?
The administrator has disabled public write access.

Re: Buttons missing in IE since upgrade - no "Next" or "Exit etc" 2 years 7 months ago #76547

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6471
  • Thank you received: 854
  • Karma: 254
pksupport wrote:
Just as a matter of interest, where does the source of {REGISTERMESSAGE1} come from? It's in the locale files somewhere?
REGISTERMESSAGE1|2 are replaced by a string, with poedit you search this string, not REGISTERMESSAGE :) .

Allways use some po/mo editor for translation, and send the po AND the mo file.
But when you update LS and your langage file are updated in LS core too.

Denis
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.159 seconds
Donation Image