Welcome, Guest
Username: Password: Remember me

TOPIC: Error Message When Conducting Survey Pilot

Error Message When Conducting Survey Pilot 2 years 7 months ago #71292

  • in7551a
  • in7551a's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 1
  • Karma: 0
I recently activated my two surveys, but whenever I try to go past the 1st page of each survey I get an error message.

"ERROR
We are sorry but your session has expired.
Either you have been inactive for too long, you have cookies disabled for your browser, or there were problems with your connection."

I have tried switching browsers but I have the same issue. Not sure what to do, but I need the surveys to be sent out in the next few days.

PLEASE HELP!
The administrator has disabled public write access.

Aw: Error Message When Conducting Survey Pilot 2 years 7 months ago #71304

  • Steve
  • Steve's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 494
  • Thank you received: 46
  • Karma: 17
Hello,

there's an option called "Session lifetime (seconds)" in the "Global settings" -> "General" tab. Did you check the value of this option, if it is too low there might be these session expired errors.

It could also be a problem with your used server though I don't know how to help you if I don't know which server, LimeSurvey version, database and php version you are using.

We (in our company) had also some problems because in the used browser cookies where deactivated, blocked or blocked for third party applications. So you could try to check if anything of this could be the problem and try activating cookies or removing the "block third party ..." option. If you're a web developer or have tools for web development you might also check if you deactivated cookies in this/these tools.
Mit freundlichen Grüßen/Best regards,

Stefan Gohlke
LimeSurvey Team
The administrator has disabled public write access.

Re: Aw: Error Message When Conducting Survey Pilot 2 years 7 months ago #71313

  • BAPU
  • BAPU's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 1
  • Karma: 0
Dear Stefan,

Thanks for the reply on the Error Message. The Sessions lifetime (second) is set for 3600 which seems reasonable -- the survey is only 23 questions. I did some further research in the Installation FAQs and found a description our problem.

The Installation FAQs points to the suhosin package used by the server. If I'm reading it correctly, we would need reconfigure elements of the PHP file to make is compatible with LimeSurvey. I'm hesitant to do that but if there is no other options ...... Would you have any other suggestions?

Thanks

TEXT FOLLOWS FROM LIMESURVEY FAQ:

LimeSurvey and suhosin ("Session has expired")

You might, at one point, get a message like :

ERROR

We are sorry but your session has expired.

Either you have been inactive for too long, you have cookies disabled for your browser, or there were problems with your connection.


And if you have Suhosin activated on your server, that's might be the reason why you get this in the middle of a survey.
NB : when your survey is not active, the behaviour might be different, you could be redirected in the middle of a survey to the public list of surveys. The solution is the same.

Suhosin is an advanced protection system for PHP installations. Suhosin default configuration can make trouble to LimeSurvey installation.
First think to test with suhosin log, set suhosin.log.sapi = 511 and suhosin.simulation = on according with suhosin documentation(external link).

The configuration file is usually located in /etc/php5/apache2/conf.d/suhosin.ini but to be sure you can check your phpinfo (Limesurvey administration > Global Settings > Button Show phpinfo > Line : "Additional .ini files parsed") to get the correct path.

Don't forget to restart your Apache server for the parameters to be taken into account (service apache2 restart).

When the simulation is on, Suhosin is not blocking anything and the errors are reported into the logs (usually in your syslog : /var/log/syslog). If you appear to get error messages such as "ALERT-SIMULATION - configured POST variable limit exceeded" that's Suhosin alerting...

This configuration seems to work well with Limesurvey:

suhosin.memory_limit = 128
suhosin.post.max_value_length = 5000000
suhosin.post.max_vars = 5000
suhosin.request.max_value_length = 5000000
suhosin.request.max_vars = 5000


With those parameters, you should be able to put the suhosin.simulation back at the "off" value (so that the serveur is protected and limesurvey still works).
The default values of suhosin are not working well with limesurvey. If you really want to secure your serveur tightly you might want to use the simulation mode to tune the setting and find the good values between 1000 and 5000 for the vars and 1000000 and 5000000 for the value_lenghts.

END OF TEXT
The administrator has disabled public write access.

Aw: Error Message When Conducting Survey Pilot 2 years 6 months ago #71322

  • Steve
  • Steve's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 494
  • Thank you received: 46
  • Karma: 17
Hello,

I'm no expert for security/php protection but as far as I understand it would be the best solution if you don't want to move your LimeSurvey installation to another server without suhosin.
Mit freundlichen Grüßen/Best regards,

Stefan Gohlke
LimeSurvey Team
The administrator has disabled public write access.

Re: Aw: Error Message When Conducting Survey Pilot 2 years 6 months ago #71622

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5302
  • Thank you received: 291
  • Karma: 247
Suhosin is known to cause such problems when being configured too strictly. The above suhosin settings have worked fine for other users so it's worth a try.

If you can't slve the problem, maybe www.LimeService.com is an alternative.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.137 seconds
Donation Image