Welcome, Guest
Username: Password: Remember me

TOPIC: Session Timeout...again

Session Timeout...again 2 years 9 months ago #70739

Hey everyone. I searched the forums and found a lot of this topic, but nothing that explained my exact issue. I apologize in advance if I missed it.

All my surveys worked fine until today. Now my students are complaining of session expired issues when it's a really fast quiz. It will work fine if you speed through all the questions, but if you take more than a minute or so, it will expire.

The global settings were set to the default 3600, but I raised that to 23600 to test if that was the issue. It's not.

Since then I have updated to the most recent version and it's still an issue.

I am comfortable with php code, but if that is suggested, please give exact locations of where to find what to change. I have not done any updating or modifications.

thechakrahouse.com/surveys/index.php?sid=38936&lang=en

Thank you.
The administrator has disabled public write access.

Re: Session Timeout...again 2 years 7 months ago #74051

  • jesterfett
  • jesterfett's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 1
  • Karma: 0
grishnoff2323,

Have you found a solution to your timeout issue? I am having a similar issue using version 1.81+

The sessions will timeout after 45-60 minutes even though I have increased the time in the config.php file.


Thanks,

jesterfett
The administrator has disabled public write access.

Re: Session Timeout...again 2 years 7 months ago #74095

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6334
  • Thank you received: 817
  • Karma: 243
jesterfett wrote:
The sessions will timeout after 45-60 minutes even though I have increased the time in the config.php file.
There are certainly a server limitation.

Ask to your server admin :).

Denis
PS: 45-60 minutes for a session : you really need this ?
The administrator has disabled public write access.

Re: Session Timeout...again 2 years 7 months ago #74105

  • Steve
  • Steve's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 494
  • Thank you received: 46
  • Karma: 17
Shnoulle wrote:
PS: 45-60 minutes for a session : you really need this ?

You don't really want to know how much comments and prosa people can write, that people think they will just continue the survey after lunch, ... .:laugh:
And yes, these things occured in our company.:laugh:
Mit freundlichen Grüßen/Best regards,

Stefan Gohlke
LimeSurvey Team
Last Edit: 2 years 7 months ago by Steve.
The administrator has disabled public write access.

Re: Session Timeout...again 2 years 7 months ago #74114

  • mdekker
  • mdekker's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 341
  • Thank you received: 68
  • Karma: 38
Session timeout is a complex thing, and depends on many factors. Most servers have a shared session space that will be purged by the application that uses it with the shortest timeout. Difficult to get right. I once did something with a keep alive script that contacts the server via ajax call to keep the session alive. Works like a charm. If you are interested I can dig up the change you need to make to the template.
---
Menno Dekker
The administrator has disabled public write access.

Re: Session Timeout...again 2 years 7 months ago #74117

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5325
  • Thank you received: 296
  • Karma: 249
@jesterfett, such local settings done by an application are often overwritten by the webserver settings which might explain why changing the setting at Limesurvey sometimes has no effect.
mdekker wrote:
I once did something with a keep alive script that contacts the server via ajax call to keep the session alive. Works like a charm. If you are interested I can dig up the change you need to make to the template.
That sounds very interesting, especially for users who can't change server settings to raise session time out.
Can you link the script here and add some instructions on how to use it?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Session Timeout...again 2 years 7 months ago #74249

  • mdekker
  • mdekker's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 341
  • Thank you received: 68
  • Karma: 38
Was almost sure I already shared the script but couldn't find it anywhere. Haven't used it for a while myself but it should all still be working.

The zipfile contains two files that should be put in the folder of the template you would like to use and the readme contains the lines that you should put in the template, just before the closing </head> tag.

File Attachment:

File Name: limesurvey_heartbeat.zip
File Size: 2 KB
---
Menno Dekker
The administrator has disabled public write access.
The following user(s) said Thank You: azoret
Moderators: ITEd
Time to create page: 0.167 seconds
Donation Image