Welcome, Guest
Username: Password: Remember me

TOPIC: Swap language on main survey screen fails

Swap language on main survey screen fails 2 years 11 months ago #69345

  • paulalford
  • paulalford's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 13
  • Karma: 1
Hi,

I've just done a clean install of 1.91 (stable, downloaded from SourceForge last night). Everything went beautifully, as always - but I can't swap languages on the main survey screen. Every time I try the browser returns "Unable to serve this request. The website is temporarily unavailable". Hitting the back button brings back the main survey page.

I've checked the permissions for the locale dir on the server and they look ok at 755.

Also, when in a survey (admin backend) and I add a new language, the same thing happens, the web server returns an error. Yet, when I click the back button in the browser, the languages are installed :unsure:

Any ideas where I might start looking?

TIA
Paul
Last Edit: 2 years 11 months ago by paulalford.
The administrator has disabled public write access.

Re: Swap language on main survey screen fails 2 years 11 months ago #69347

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5331
  • Thank you received: 296
  • Karma: 249
Hmm, strange error which I didn't read about before.

Please try re-uploading all files in binary mode of your browser, maybe some files were broken during upload or are missing.

Please also switch on debug mode by adding the following line to your config.php file:
$debug = '1';

Are there any additional errors reported on top of the page?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Swap language on main survey screen fails 2 years 11 months ago #69351

  • paulalford
  • paulalford's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 13
  • Karma: 1
Hi Mazi,

No additional errors showing up. I've just tried to make some other changes in the back end. I changed the cookie setting to prevent repeated survey completion to Yes and I get the same problem. Clicking back in the browser then shows the option correctly changed.

I'll add the the debug = 1 and run it again to see what comes up.
The administrator has disabled public write access.

Re: Swap language on main survey screen fails 2 years 11 months ago #69355

  • paulalford
  • paulalford's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 13
  • Karma: 1
Debug setting isn't helping as the browser throws the error and doesn't display Lime. On returning via back button, all looks like it should.

Next, I'll do a fresh upload of the files and give that a go.

Cheers
Paul
The administrator has disabled public write access.

Re: Swap language on main survey screen fails 2 years 11 months ago #69356

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5331
  • Thank you received: 296
  • Karma: 249
Please also have a look at the server's error log and copy-paste anything suspicious.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Swap language on main survey screen fails 2 years 11 months ago #69357

  • paulalford
  • paulalford's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 13
  • Karma: 1
Will do. Do you want a copy of the config.php file? Don't want to post it here, but still have you on Skype. Send it there?
The administrator has disabled public write access.

Re: Swap language on main survey screen fails 2 years 11 months ago #69358

  • paulalford
  • paulalford's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 13
  • Karma: 1
Ah, OK - debug just threw this at me.
Warning: array_map() [function.array-map]: Argument #2 should be an array in /path-to-server/surveys/admin/editsurveytextelements.php on line 46

Warning: array_map() [function.array-map]: Argument #2 should be an array in /path-2-server/surveys/admin/editsurveytextelements.php on line 46
The administrator has disabled public write access.

Re: Swap language on main survey screen fails 2 years 11 months ago #69360

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5331
  • Thank you received: 296
  • Karma: 249
I don't think it's a setting issue.

The error message also indicates that something with the languages is wrong.
Did you already re-upload the files?

Maybe another installation from scratch might to th trick?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

[SOLVED] Swap language on main survey screen fails 2 years 11 months ago #69362

  • paulalford
  • paulalford's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 13
  • Karma: 1
The binary upload resolved the issue Mazi. Working beautifully now.

Cheers
Paul
The administrator has disabled public write access.

Re: [SOLVED] Swap language on main survey screen fails 2 years 11 months ago #69367

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5331
  • Thank you received: 296
  • Karma: 249
You're welcome!

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.213 seconds
Donation Image