Welcome, Guest
Username: Password: Remember me

TOPIC: ERROR > Session has expired !

Re: [SOLVED] Re: ERROR > Session has expired ! - Suhosin configuration 3 years 1 week ago #69044

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6551
  • Thank you received: 869
  • Karma: 257
Mazi wrote:
Guys, can you please add these helpful instructions at the <a href='www.docs.limesurvey.org/tiki-index.php?p...tions+for+LimeSurvey'>installation</a> FAQ so other will benefit from your findings as well!?

Thanks!
Shnoulle wrote: :P
The administrator has disabled public write access.

Re: [SOLVED] Re: ERROR > Session has expired ! - Suhosin configuration 3 years 1 week ago #69047

  • Maximilien
  • Maximilien's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 12
  • Karma: 0
Wow, that was fast ! And it explains why I didn't see anything before my initial question and discovered that when Mazi told about explaining it in the FAQ :)

Well done Shnoulle ;-)
The administrator has disabled public write access.

Re: [SOLVED] Re: ERROR > Session has expired ! - Suhosin configuration 3 years 1 week ago #69049

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6551
  • Thank you received: 869
  • Karma: 257
Maximilien wrote:
Wow, that was fast ! And it explains why I didn't see anything before my initial question and discovered that when Mazi told about explaining it in the FAQ :)

Well done Shnoulle ;-)
Thanks to you, you corrected before Mazi ask too !!

:)
The administrator has disabled public write access.

Re: ERROR > Session has expired ! 2 years 7 months ago #78839

  • deeringa
  • deeringa's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 10
  • Karma: 0
Hi all! I am also experiencing this same problem. I am not running Suhosin. I've searched the phpinfo() output for the word, and it's not there. Are there any other known solutions for this? Any other server settings I could try? If absolutely necessary, I can post the phpinfo(), but I'd rather not as I am very wary of posting server settings to a public forum :)
The administrator has disabled public write access.

Re: ERROR > Session has expired ! 2 years 7 months ago #78840

  • holch
  • holch's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 2952
  • Thank you received: 378
  • Karma: 124
As long as no one knows which server it is for, I don't see much of a problem.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re: ERROR > Session has expired ! 2 years 7 months ago #78860

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5423
  • Thank you received: 307
  • Karma: 252
Please also check the server's error log for further hints. Sometimes some settings like MAX_POST_VARS or MEMORY_LIMIT cause similar problems.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: ERROR > Session has expired ! 2 years 6 months ago #79623

  • deeringa
  • deeringa's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 10
  • Karma: 0
Thank you for your prompt responses, and I appologize for the delay in mine. I didn't get notified of the responses for some reason. Perhaps they got sent to junk. Anyway, I tail -f'd a couple of the server's logs while attempting to access a newly created survey, and nothing came up. Specifically the error and access logs. I'm attaching the phpinfo() saved as a .htm page. Please forgive my paranoia, as I have removed anything even resembling identifiable information. I don't think you need IP addresses or usernames to help make a diagnosis. :) I've done some digging, and I can't find the recommended MAX_POST_VARS or MEMORY_LIMIT. I don't see a MAX_POST_VARS, but I do see MAX_INPUT_VARS of 1000, and a MEMORY_LIMIT of 128MB. Obviously, I can up these as necessary. Could you post the recommended values here so I can give that a try? Would anything be showing up in the logs if either of those were the problem? Thank you SO much in advance for your help!

PLEASE NOTE: I didn't see the attached .htm file. So I'm hoping if I change the extension to .txt it will be attached. Please remove the .txt from the end to view the file.
Attachments:
Last Edit: 2 years 6 months ago by deeringa. Reason: I did not see the attached .htm file on my post. Re-trying after renaming to .txt
The administrator has disabled public write access.

Re: ERROR > Session has expired ! 2 years 6 months ago #79822

  • deeringa
  • deeringa's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 10
  • Karma: 0
Any update on this?
The administrator has disabled public write access.

Re: ERROR > Session has expired ! 2 years 6 months ago #79831

  • deeringa
  • deeringa's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 10
  • Karma: 0
I am beginning to get a bit desperate. This project is scheduled to go live in a couple days, and I'm still getting this Sessions has expired message for every created survey! I've checked the MAX_POST_VARS and MEMORY_LIMIT. MPV = 1000 and ML = 128M. I found in the documentation that 128M should be perfectly acceptable. I can't find anything for MPV. Please help!!
The administrator has disabled public write access.

Re: ERROR > Session has expired ! 2 years 6 months ago #79834

  • lex
  • lex's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 10
  • Karma: 0
it helped me to set max_input_vars to 5000
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.133 seconds
Donation Image