Welcome, Guest
Username: Password: Remember me

TOPIC: ERROR > Session has expired !

ERROR > Session has expired ! 3 years 2 weeks ago #68686

  • Maximilien
  • Maximilien's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 12
  • Karma: 0
Hi Guys,

I have just migrated limesurvey from one server to another. Same configuration for both servers but a big issue with my survey.

When executing the survey after passing 2 groups of question I get a wonderful :
ERROR

We are sorry but your session has expired.

Either you have been inactive for too long, you have cookies disabled for your browser, or there were problems with your connection.

Please contact Geengo Surveys ( This email address is being protected from spambots. You need JavaScript enabled to view it. ) for further assistance.

So that's when the survey is activated. Now when I test the survey while not activated, I pass through 4 of the 5 groups of questions, and when clicking on the "Next" button of the 4th group... I get redirected to the surveys listing (the public index of surveys) while I should go to the last group of questions. Weird, isn't it ?

I spent a couple of hours searching the web and the forum for solutions (I found some bugs that looked quite similar but the proposed solutions would never work), checked several times my php.ini, upgraded to the very last built of limesurvey (Version 1.91+ Build 11343) but it simply won't work ! And I really have no clue why...

Any idea that could help me ?

Thanks in advance,

Kind regards,
Maximilien
The administrator has disabled public write access.

Re: ERROR > Session has expired ! 3 years 2 weeks ago #68891

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5425
  • Thank you received: 307
  • Karma: 252
I'm pretty sure that there are differences at the server configuration because the session problems are mainly caused by certain server settings.

Please upload a phpinfo file so we can take a look at your server configuration. Just put the following code into a file named phpinfo.php and upload it to your webserver:
< ?php phpinfo(); ? >
(Delete the spaces next to </> when copying the code.)
After uploading please post the link to the file.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
The following user(s) said Thank You: Maximilien

Re: ERROR > Session has expired ! 3 years 2 weeks ago #68982

  • Maximilien
  • Maximilien's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 12
  • Karma: 0
The administrator has disabled public write access.

Re: ERROR > Session has expired ! 3 years 2 weeks ago #68986

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6551
  • Thank you received: 869
  • Karma: 257
Hello,

You have suhosin, starting to test without ( suhosin.simulation ) to see if it that.

Here is may suhosin configuration:
suhosin.apc_bug_workaround	Off	Off
suhosin.cookie.checkraddr	0	0
suhosin.cookie.cryptdocroot	On	On
suhosin.cookie.cryptkey	[ protected ]	[ protected ]
suhosin.cookie.cryptlist	no value	no value
suhosin.cookie.cryptraddr	0	0
suhosin.cookie.cryptua	On	On
suhosin.cookie.disallow_nul	1	1
suhosin.cookie.disallow_ws	1	1
suhosin.cookie.encrypt	Off	Off
suhosin.cookie.max_array_depth	50	50
suhosin.cookie.max_array_index_length	64	64
suhosin.cookie.max_name_length	64	64
suhosin.cookie.max_totalname_length	256	256
suhosin.cookie.max_value_length	10000	10000
suhosin.cookie.max_vars	100	100
suhosin.cookie.plainlist	no value	no value
suhosin.coredump	Off	Off
suhosin.disable.display_errors	Off	Off
suhosin.executor.allow_symlink	Off	Off
suhosin.executor.disable_emodifier	Off	Off
suhosin.executor.disable_eval	Off	Off
suhosin.executor.eval.blacklist	no value	no value
suhosin.executor.eval.whitelist	no value	no value
suhosin.executor.func.blacklist	no value	no value
suhosin.executor.func.whitelist	no value	no value
suhosin.executor.include.allow_writable_files	On	On
suhosin.executor.include.blacklist	no value	no value
suhosin.executor.include.max_traversal	4	4
suhosin.executor.include.whitelist	no value	no value
suhosin.executor.max_depth	0	0
suhosin.filter.action	no value	no value
suhosin.get.disallow_nul	1	1
suhosin.get.disallow_ws	0	0
suhosin.get.max_array_depth	50	50
suhosin.get.max_array_index_length	64	64
suhosin.get.max_name_length	64	64
suhosin.get.max_totalname_length	256	256
suhosin.get.max_value_length	512	512
suhosin.get.max_vars	100	100
suhosin.log.file	0	0
suhosin.log.file.name	no value	no value
suhosin.log.phpscript	0	0
suhosin.log.phpscript.is_safe	Off	Off
suhosin.log.phpscript.name	no value	no value
suhosin.log.sapi	0	0
suhosin.log.script	0	0
suhosin.log.script.name	no value	no value
suhosin.log.syslog	479	479
suhosin.log.syslog.facility	no value	no value
suhosin.log.syslog.priority	no value	no value
suhosin.log.use-x-forwarded-for	Off	Off
suhosin.mail.protect	2	2
suhosin.memory_limit	256M	256M
suhosin.mt_srand.ignore	On	On
suhosin.multiheader	Off	Off
suhosin.perdir	0	0
suhosin.post.disallow_nul	1	1
suhosin.post.disallow_ws	0	0
suhosin.post.max_array_depth	8048	8048
suhosin.post.max_array_index_length	1024	1024
suhosin.post.max_name_length	2048	2048
suhosin.post.max_totalname_length	8048	8048
suhosin.post.max_value_length	1000000	1000000
suhosin.post.max_vars	4096	4096
suhosin.protectkey	On	On
suhosin.request.disallow_nul	1	1
suhosin.request.disallow_ws	0	0
suhosin.request.max_array_depth	4096	4096
suhosin.request.max_array_index_length	2048	2048
suhosin.request.max_totalname_length	256	256
suhosin.request.max_value_length	650000	650000
suhosin.request.max_varname_length	64	64
suhosin.request.max_vars	4096	4096
suhosin.server.encode	On	On
suhosin.server.strip	On	On
suhosin.session.checkraddr	0	0
suhosin.session.cryptdocroot	On	On
suhosin.session.cryptkey	[ protected ]	[ protected ]
suhosin.session.cryptraddr	0	0
suhosin.session.cryptua	Off	Off
suhosin.session.encrypt	On	On
suhosin.session.max_id_length	128	128
suhosin.simulation	Off	Off
suhosin.sql.bailout_on_error	Off	Off
suhosin.sql.comment	0	0
suhosin.sql.multiselect	0	0
suhosin.sql.opencomment	0	0
suhosin.sql.union	0	0
suhosin.sql.user_postfix	no value	no value
suhosin.sql.user_prefix	no value	no value
suhosin.srand.ignore	On	On
suhosin.stealth	On	On
suhosin.upload.disallow_binary	0	0
suhosin.upload.disallow_elf	1	1
suhosin.upload.max_uploads	30	30
suhosin.upload.remove_binary	0	0
suhosin.upload.verification_script	no value	no value
Last Edit: 3 years 2 weeks ago by DenisChenu. Reason: quote to code
The administrator has disabled public write access.
The following user(s) said Thank You: Maximilien

[SOLVED] Re: ERROR > Session has expired ! - Suhosin configuration 3 years 2 weeks ago #69012

  • Maximilien
  • Maximilien's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 12
  • Karma: 0
A damn good answer !

So I set up the simulation mode on suhosin, activated the logs via the /etc/php5/apache2/conf.d/suhosin.ini file :
suhosin.log.sapi = 511
suhosin.simulation = off

(of course you need to reload apache2 for the configuration to be taken into account)

I did the survey, it worked and I checked my syslog. It had several errors on the max number of post variables (ALERT-SIMULATION - configured POST variable limit exceeded). So I took a configuration suitable for Magento's product :
suhosin.mail.protect = 0
suhosin.memory_limit = 128
suhosin.post.max_value_length = 5000000
suhosin.post.max_vars = 5000
suhosin.request.max_value_length = 5000000
suhosin.request.max_vars = 5000

Which basically means that it allows 5 times more post variables and requests. I switched off the simulation mode and it's clean and working !

Thank you so much Shnoulle.
Last Edit: 3 years 2 weeks ago by Maximilien. Reason: Changing subject of the post (Solved)
The administrator has disabled public write access.

Re: ERROR > Session has expired ! 3 years 2 weeks ago #69014

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5425
  • Thank you received: 307
  • Karma: 252
suhosin is known for causing such problems. Try switching it off for testing or adjust those settings according th shnoulle's examples.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: [SOLVED] Re: ERROR > Session has expired ! - Suhosin configuration 3 years 2 weeks ago #69021

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6551
  • Thank you received: 869
  • Karma: 257
Maximilien wrote:
Thank you so much Shnoulle.
Thank's to you,

I have already some problem with max post and get, i use a cms ( Spip ) with a lot of ajax function.

And Ajax function need a lot of GET parameters.

I have 2 configuration for suhosin : one for protected project like LS/Spip etc ... and another one for no preotected projetc ( personal draft, old open source project etc ...)

I think we found the solution for suhosin with LimeSurvey:
suhosin.post.max_value_length = 5000000
suhosin.post.max_vars = 5000
suhosin.request.max_value_length = 5000000
suhosin.request.max_vars = 5000
But maybe less is good too :).

Denis

PS: wikified : docs.limesurvey.org/Installation+FAQ#Lim...on_has_expired_quot_ before Mazi asking :P
Last Edit: 3 years 2 weeks ago by DenisChenu.
The administrator has disabled public write access.

Re: [SOLVED] Re: ERROR > Session has expired ! - Suhosin configuration 3 years 2 weeks ago #69026

  • Maximilien
  • Maximilien's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 12
  • Karma: 0
Yep, it looks good with those values, the correct value must be somewhere between 1 and 5 but I think 5 (5000 and 5000000) is still protective and keeps Limesurvey working fine...

I will stay on 5 for the moment :p
The administrator has disabled public write access.

Re: [SOLVED] Re: ERROR > Session has expired ! - Suhosin configuration 3 years 2 weeks ago #69037

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5425
  • Thank you received: 307
  • Karma: 252
Guys, can you please add these helpful instructions at the installation FAQ so other will benefit from your findings as well!?

Thanks!

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: [SOLVED] Re: ERROR > Session has expired ! - Suhosin configuration 3 years 2 weeks ago #69040

  • Maximilien
  • Maximilien's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 12
  • Karma: 0
There was already something, but I completed to that anyone should understand and search robots should index it so that's it's easier to find.
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.236 seconds
Donation Image