Welcome, Guest
Username: Password: Remember me

TOPIC: SMTP Email not working after upgrade to 1.91 (11232)

SMTP Email not working after upgrade to 1.91 (11232) 2 years 8 months ago #68209

  • dbrinston
  • dbrinston's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
Hi there,

Last week i upgraded our version of LimeSurvey to version 1.91 build 11232 and ever since then the email notification hasn't been working. We're using SMTP as the email method (same one that worked all along) and i'm using smtp.gmail.com:587 as the SMTP host. Our LimeSurvey server is not a member of our domain so we can't use our Exchange Server....however the gmail smtp was working all along. I didn't change ANY of the email settings, so they're still how i left them: SMTP SSL/TLS is set to TLS. SMTP debug mode is off and email batch size is 50. I have the SMTP username and password entered for a gmail account that i set up for this survey. I even changed the password on that account to make sure there was no issues there. To verify, I logged into gmail.com with the new password and then i entered it in the SMTP Password field in LimeSurvey.

Again, the email notification was working perfectly fine up until i completed the upgrade. Any ideas?

Thanks for your time!
Dave
The administrator has disabled public write access.

Re: SMTP Email not working after upgrade to 1.91 (11232) 2 years 8 months ago #68225

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5300
  • Thank you received: 291
  • Karma: 247
Is it possible that there have been some changes at gmail, e.g they might have switched to a different port?

Can you enable SMTP debug, send an email and copy-paste the errors that are given?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: SMTP Email not working after upgrade to 1.91 (11232) 2 years 8 months ago #68228

  • dbrinston
  • dbrinston's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
Thanks for the quick response!

I just enabled the SMTP Debug mode and ran through a survey, there were no errors. That's the strange thing about it, i haven't been receiving any errors. Just no emails coming thru and it's been this way since the upgrade which seems strange but i guess gmail could have changed something. I can't find anything online that suggests such a change, but its quite possible. I just find it strange that this issue started happening after the upgrade and not before?

Thanks for your help, any comments or suggestions are greatly appreciated!
Dave
The administrator has disabled public write access.

Re: SMTP Email not working after upgrade to 1.91 (11232) 2 years 8 months ago #68234

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5300
  • Thank you received: 291
  • Karma: 247
1. Did you check the spam folder?

2. Try creating a new Limesurvey user, maybe this email with the registration data is send to the user?

3. Try switching to a different email method.

4. Try a different SMTP account if possible.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: SMTP Email not working after upgrade to 1.91 (11232) 2 years 8 months ago #68241

  • dbrinston
  • dbrinston's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
ok, so i created a new user and used my email address and that actually worked. It sent the email out with the login info in it.

so what could be wrong with the surveys now tho i wonder? like, how come they aren't sending emails anymore? They always did!

Thanks so much!
Dave
The administrator has disabled public write access.

Re: SMTP Email not working after upgrade to 1.91 (11232) 2 years 8 months ago #68245

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5300
  • Thank you received: 291
  • Karma: 247
So if the email for a new user account is sent, the email settings seem to be correct.

Did you try switching to a different email method?

You can also try sending text emails (I think it's located at the survey settings) and/or change the email text because spam might still be an issue, especially if no error messages are shown when sending emails by SMTP.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: SMTP Email not working after upgrade to 1.91 (11232) 2 years 8 months ago #68249

  • dbrinston
  • dbrinston's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
Wow, i finally figured it out. Under the email templates section there was nothing there for Basic admin notification nor Detailed admin notification. I clicked the "use default" buttons to populate the email template, saved it and tried the survey again....then i got the email!

I've never had to do this before and i don't even remember seeing the Email Template section in the previous release, so perhaps that's new. Either way, problem solved. Thanks so much for your help!

Dave
The administrator has disabled public write access.

Re: SMTP Email not working after upgrade to 1.91 (11232) 2 years 8 months ago #68307

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5300
  • Thank you received: 291
  • Karma: 247
Can you check if the empty email fields show up at everay survey?

If so please open a ticket at the bugtracker and...
  1. Give as much information as possible
  2. Attach your survey. You can mark your ticket "private" so that only the developers will be able to take a look at it.
  3. Provide step-by-step instructions how to reproduce the problem.
  4. If possible/helpful please provide screenshots

Afterwards please post the link to the bugtracker so we can follow the progress.

Thanks!

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: SMTP Email not working after upgrade to 1.91 (11232) 2 years 8 months ago #68372

  • dbrinston
  • dbrinston's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
Thanks! Here's the link to the ticket:

bugs.limesurvey.org/view.php?id=5557

and yes all existing surveys are missing the Basic and Detailed admin notification data in the Email Templates section.

Thanks,
Dave
The administrator has disabled public write access.

Re: SMTP Email not working after upgrade to 1.91 (11232) 2 years 8 months ago #68400

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5300
  • Thank you received: 291
  • Karma: 247
Thanks for reporting bugs. We'll have a look at it.

Can you provide some further feedback as requested by our developer at the bugtracker?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.128 seconds
Donation Image