Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: General Backup question

Re: General Backup question 3 years 1 week ago #67550

File Attachment:

File Name: config.php.txt
File Size: 4 KB

I've exported/dumped the DB as follows:

1) Via the Full DB export in LimeSurvey
2) via the standard mysql dump

Results for both are the same.

When I import, I've tried a new schema or using an existing schema, I've successfully connected via the command line using the credentials in the attached config.php

Set debug to 1, but that doesn't seem to log to any of the obvious places.


Thanks
Last Edit: 3 years 1 week ago by c_schmitz.
The administrator has disabled public write access.

Re: General Backup question 3 years 1 week ago #67558

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5351
  • Thank you received: 299
  • Karma: 250
No attachment :-(

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: General Backup question 3 years 1 week ago #67573

Sorry, with time difference I'm not at work anymore

BTW, I don't think the upload accepts php file, so renamed it to .txt file and then edited the message. Not sure if that's the problem.

Will paste the whole file in the message.
Cheers
The administrator has disabled public write access.

Re: General Backup question 3 years 1 week ago #67586

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5351
  • Thank you received: 299
  • Karma: 250
You are right, .php files are not allowed (for security reasons).
Simply copy-paste those settings.

In general the settings should match at both systems, otherwise the system will be looking at the wriong DB/tables.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: General Backup question 3 years 1 week ago #67661

As usual, the problem is in the chair:-)

I had the wrong database in the config file

I've now connected to the restored DB, but cannot see the Survey.

After dropping the schema and re-importing the full database dump generated from within Limesurvey I now get the message that
The LimeSurvey database does exist but it seems to be empty. Please run the install script to create the necessary tables.


So decided to start from scratch

1) Installed new instance : OK
2) Imported full dump exported from Limesurvey : OK
3) Cannot see the survey as the full export only contains the attached; no survey table as far as I can see; everything is prefixed by v1_


Screenshot.png
Last Edit: 3 years 1 week ago by lister171254. Reason: more info
The administrator has disabled public write access.

Re: General Backup question 3 years 1 week ago #67662

Well, there is an explanation for that as well.

The person that set this up in the live site changed the prefix to V1.

Sorry to have wasted your time.

Cheers
The administrator has disabled public write access.

Re: General Backup question 3 years 1 week ago #67671

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5351
  • Thank you received: 299
  • Karma: 250
You're welcome!

If our hints have been helpful and you enjoy limesurvey please consider a donation to the team .
We do all this in our free time and you don't have to pay a penny for this software.

Without your help we can't keep this project alive.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.125 seconds
Donation Image