Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Postgresql not conect

Postgresql not conect 2 years 9 months ago #66852

Sorry for my english.

I hava this error during then installs: Can't connect to LimeSurvey database. Reason: Database connection failed.

My config.php is:


$databasetype = 'postgres';
$databaselocation = 'localhost';
$databasename = 'limesurvey';
$databaseuser = 'postgres';
$databasepass = 'Navamediana1';
$dbprefix = 'lime_';

pass Navamediana1 is a superuser of postgresql.

I don´t undrestand, postgreqsl 8.3 and limesurvey191plus-build11110-20111005.zip.

Thanks
The administrator has disabled public write access.

Re: Postgresql not conect 2 years 9 months ago #66853

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5300
  • Thank you received: 291
  • Karma: 247
I think this is a settings problem but I'm no postgres expert.

Do you use these settings for any other applications?

Check our forum and the manual for any further postgres tips.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
The following user(s) said Thank You: alfredoleganes

Re: Postgresql not conect 2 years 9 months ago #66922

Someone has limesurvey on Postgradesql, i need postgradesql because the bbdd has 7378 question. I read at your forum that if i change the block size in postgradesql i have 1600*4 os space.
The administrator has disabled public write access.

Re: Postgresql not conect 2 years 9 months ago #66924

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6207
  • Thank you received: 788
  • Karma: 238
Hello,

Did you try to create the postgre database before <a href='www.docs.limesurvey.org/tiki-index.php?p...tions+for+LimeSurvey'>installation</a> of LS ?

my config:
[code type=php-brief]$databasetype = 'postgres';
$databaselocation = 'localhost';
$databasename = 'limesurvey';
$databaseuser = 'limesurvey';
$databasepass = 'XXXXX';
$dbprefix = 'lime_'; [/code]

PostgreSQL 8.4.8 on i486-pc-linux-gnu, compiled by GCC gcc-4.4.real (Debian 4.4.5-8) 4.4.5, 32-bit
Last Edit: 2 years 9 months ago by DenisChenu.
The administrator has disabled public write access.
The following user(s) said Thank You: alfredoleganes

Re: Postgresql not conect 2 years 9 months ago #66927

Thanks Shnoulle. I make this suvery on mysql and limesurey and when i publish the survey, limesuvery said too many columns. At your forum said that tire to install postgradre.
The administrator has disabled public write access.

Re: Postgresql not conect 2 years 9 months ago #66931

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5300
  • Thank you received: 291
  • Karma: 247
Instead of using postgres I'd better split up your questions into 1-n surveys.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
The following user(s) said Thank You: alfredoleganes

Re: Postgresql not conect 2 years 9 months ago #66932

Is it possible?. Sorry i don´t know, can i split suvery in three sub-surveys and only send one email???.
The administrator has disabled public write access.

Re: Postgresql not conect 2 years 9 months ago #66934

  • Eddie_V
  • Eddie_V's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 42
  • Thank you received: 2
  • Karma: 1
it is if you use the same tokens for all three surveys.

set the END URL of survey 1 to go to survey 2, you can use {token} here to build the right URL for each participant. and set the END URL for survey 2 to go to survey 3.

also do not forget to set "Automatically load URL when survey complete" to Yes.

the only thing that a user might notice is that at the end of survey 1 and 2 the "Next" button will be a "submit" button.
The administrator has disabled public write access.
The following user(s) said Thank You: alfredoleganes

Re: Postgresql not conect 2 years 9 months ago #66937

Thans Eddie_v, but how use {token} to build the right URL for each participant. if i have one person at suvery 1 with token 100, i need this person pass to survey 2 with token 100 . How i make???, where i find same help.
The administrator has disabled public write access.

Re: Postgresql not conect 2 years 9 months ago #66938

  • Eddie_V
  • Eddie_V's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 42
  • Thank you received: 2
  • Karma: 1
well first make sure that that all three token tables are the same, that person 1 who has token 100 in survey 1 also has token 100 in survey 2

then for the END URL set it: <limesurvey_url>/index.php?sid=<the_ID_of_survey_#2>&token={TOKEN}

and replace <limesurvey_url> with your url eg. www.limesurvey.org
and replace <the_ID_of_survey_#2> with the ID of the second survey eg. 87453
Last Edit: 2 years 9 months ago by Eddie_V.
The administrator has disabled public write access.
The following user(s) said Thank You: alfredoleganes
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.140 seconds
Donation Image