Welcome, Guest
Username: Password: Remember me

TOPIC: After upgrade from 1.71 to 1.91+ Survey/Group or Question Export does not work

After upgrade from 1.71 to 1.91+ Survey/Group or Question Export does not work 2 years 8 months ago #64647

  • PeterDr1
  • PeterDr1's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Thank you received: 1
  • Karma: 0
Can someone provide some guidance on this pleeeeeease?

After recent upgrade from 1.71 to 1.91 (done by the administrator not me) Surveys from a 1.90 install on another server imported OK but when I try to export any survey or question or group from the new 1.91 upgrade on this server I get an LSS file of 79 bytes with this message only in its contents


"XMLWriter class not compiled into PHP, please contact your system administrator"

Server is a Linux server with Apache 2.0 handler
PHP version 5.2.11

I notice that the Configure command in the PHP Info data includes the commands '--disable-xmlreader' '--disable-xmlwriter' - is this likely to be the problem? Other causes?


PHPInfo.png
Last Edit: 2 years 8 months ago by PeterDr1.
The administrator has disabled public write access.

Re: After upgrade from 1.71 to 1.91+ Survey/Group or Question Export does not work 2 years 8 months ago #64649

  • holch
  • holch's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 2446
  • Thank you received: 254
  • Karma: 94
Well, the error message says it all, the XMLWriter class is missing on your machine. As the administrator of the server to install it on the server.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.
The following user(s) said Thank You: PeterDr1
Moderators: ITEd
Time to create page: 0.127 seconds
Donation Image