Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Admin login

Admin login 3 years 5 months ago #62302

  • gvangass
  • gvangass's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
When I try to login as admin, the app keeps on redirecting me back to the login screen.
The administrator has disabled public write access.

Re: Admin login 3 years 5 months ago #62315

  • gvangass
  • gvangass's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
In the phpinfo(), I can see that the session.save_path was not set. I don't have access to the php.ini file(shared hosting).
Is there maybe a workaround for this ?
The administrator has disabled public write access.

Re: Admin login 3 years 5 months ago #62383

  • gvangass
  • gvangass's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
Any update ?

I'm desperate, I would even considering change source code to bypass this problem.
The administrator has disabled public write access.

Re: Admin login 3 years 5 months ago #62386

  • greg_d
  • greg_d's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 47
  • Thank you received: 7
  • Karma: 4
Hi,

If changes in php.ini are not possible you can try using DB session handler. In order to do so add following line to your config.php:
$sessionhandler = 'db';
The administrator has disabled public write access.

Re: Admin login 3 years 5 months ago #62393

  • gvangass
  • gvangass's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
Hi
Does this mean anything to you:
Warning: session_module_name() [function.session-module-name]: A session is active. You cannot change the session module's ini settings at this time in /data01/webs/virtual/l/le/les/lese/lesed/lesedi/www.lesedilm.gov.za/web/survey/classes/adodb/session/adodb-session2.php on line 465

This is what happens when I add that setting to config.
The administrator has disabled public write access.

Re: Admin login 3 years 5 months ago #62461

  • xubaoguo
  • xubaoguo's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
Hi, i have also this problem, do you have solve this problem? tell me ok?
The administrator has disabled public write access.

Re: Admin login 3 years 5 months ago #62464

  • gvangass
  • gvangass's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
No answer as yet.
May be some one out there that can help ??
The administrator has disabled public write access.

Re: Admin login 3 years 5 months ago #62467

  • greg_d
  • greg_d's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 47
  • Thank you received: 7
  • Karma: 4
gvangass, I am not able to reproduce your problem. Could you please, attach results of phpinfo? Maybe it will give us a hint.
The administrator has disabled public write access.

Re: Admin login 3 years 5 months ago #62477

  • greg_d
  • greg_d's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 47
  • Thank you received: 7
  • Karma: 4
It looks like session.auto_start On is a problem - you server starts session every page load while limesurvey doesn't need it, the session is started by the application when necessary.

Try modyfing php.ini or try to add following to .htaccess file:
<IfModule mod_php5.c>
  php_value session.auto_start 0
</IfModule>
Last Edit: 3 years 5 months ago by greg_d.
The administrator has disabled public write access.

Re: Admin login 3 years 5 months ago #62479

  • gvangass
  • gvangass's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
Thanks it's working
Note: php_value session.auto_start 1
should read: php_value session.auto_start 0

I've previously tried set this value in the config.php file
ini_set("session.auto_start", "0");
But it did't work ?
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.215 seconds
Donation Image