Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: CK Editor does not load after upgrade to 1.91

CK Editor does not load after upgrade to 1.91 3 years 2 months ago #62017

  • lachmac
  • lachmac's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
After upgrading to version 1.91 the inline editor (CKEditor?) does not load, and so I have to edit the various text elements, and emails in an external HTML editor.

How can I get back to being able to use the inline editor, again?
The administrator has disabled public write access.

Re: CK Editor does not load after upgrade to 1.91 3 years 2 months ago #62021

  • gabriel
  • gabriel's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 45
  • Thank you received: 4
  • Karma: 2
I had this problem but with my French user interface
I solved the problem by modifying the file
admin/scripts/ckeditor.36/plugins/limereplacementfields/lang/fr.js
I replace
CKEDITOR.plugins.setLang ('limereplacementfields', 'en', by
CKEDITOR.plugins.setLang ('limereplacementfields', 'fr',

I hope it helps
Regards

See www.limesurvey.org/fr/forum/french-forum...on?limit=10&start=10
Last Edit: 3 years 2 months ago by gabriel.
The administrator has disabled public write access.
The following user(s) said Thank You: lachmac

Re: CK Editor does not load after upgrade to 1.91 3 years 2 months ago #62025

  • lachmac
  • lachmac's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
Merci, maybe I am missing a file, I do not seem to have any sw.js file, that would be corresponding to the fr.js.

Thanks for input.
The administrator has disabled public write access.

Re: CK Editor does not load after upgrade to 1.91 3 years 2 months ago #62055

  • wrenchpilot
  • wrenchpilot's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Thank you received: 1
  • Karma: 0
-EDIT-
Another case of a variable being referenced that wasn't properly defined in the config-defaults.php

This has happened the last 3 or 4 times I've updated LimeSurvey. Not cool.

Add the $sCKEditorURL to config-defaults.php to fix.
$sCKEditorURL = "$homeurl/scripts/ckeditor.36"
Last Edit: 3 years 2 months ago by wrenchpilot.
The administrator has disabled public write access.
The following user(s) said Thank You: lachmac

Re: CK Editor does not load after upgrade to 1.91 3 years 2 months ago #62152

  • lachmac
  • lachmac's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
Thanks for the respons. I checked the config-defaults.php and the line you mention was already there. Strange. I really wonder how to solve this, it is a bit of a block.
The administrator has disabled public write access.

Re: CK Editor does not load after upgrade to 1.91 3 years 2 months ago #62153

  • lachmac
  • lachmac's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
PROBLEM SOLVED - the "s" was missing from $sCK.....Now it works!

Great thanks to all!
The administrator has disabled public write access.

Aw: Re: CK Editor does not load after upgrade to 1.91 3 years 2 months ago #62569

  • rocknrole
  • rocknrole's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
CKEditor does not load in Chrome!
Did anybody do a Cross Browsertest before releasing this version with a new Editor?
Why switching from FCK when it does not work in all Browsers - thats frustrating - each new release has new problems and we read the announcements "hopefully it is stable".
My question - if you are not sure it is stable - why do you release it?
It seems like each build gets at least a RC....
I am not happy with that.

UPDATE:
The whole jquer UI seems to have a problem in Chrome. The Tabs do not render and I get the followig errors:

Uncaught Range Error: Maximum call stack size exceeded

and

Uncaught Type Error: Cannot read property "regional" of undefined (admin_core.js:12)
Last Edit: 3 years 2 months ago by rocknrole.
The administrator has disabled public write access.

Re: Aw: Re: CK Editor does not load after upgrade to 1.91 3 years 2 months ago #62571

  • c_schmitz
  • c_schmitz's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 755
  • Thank you received: 104
  • Karma: 88
rocknrole,

CKEditor loads just fine here in the latest version of Chrome. Maybe you need just to clear your browser cache once in Chrome.
Support us, too. Donate to the LimeSurvey project and help keep us going!
The administrator has disabled public write access.

Aw: Re: Aw: Re: CK Editor does not load after upgrade to 1.91 3 years 2 months ago #62575

  • rocknrole
  • rocknrole's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
Sorry for this - indeed after clearing the cache, it worked......
thx
The administrator has disabled public write access.

Aw: CK Editor does not load after upgrade to 1.91 2 years 6 months ago #74373

  • simulator
  • simulator's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 16
  • Karma: 0
this may also be caused by apache2 .htaccess setting.

We had a .htaccess restriction for the /admin/ area which is above the
/admin/scripts/ckeditor.36/.htaccess file.

the latter one calls AddType
AddType application/x-javascript .js
AddType text/css .css
AddType text/xml .xml
But according to apache2 doc you need
AllowOverride FileInfo to allow AddType in a .htaccess file.

As AllowOverride can only have 1 argument I used "AllowOverride All", so I solved the problem, by replycing the
AllowOverride AuthConfig
with
AllowOverride All
in my apache or vhost.conf, which looks like this
...
       DocumentRoot /var/www/limesurvey/latest
       <Directory /var/www/limesurvey/latest>
                Options -Indexes +FollowSymLinks -MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
                DirectoryIndex index.php index.html index.htm
        </Directory>
...
/ SIMULATOR / WIEN
Last Edit: 2 years 6 months ago by simulator. Reason: fehler
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.407 seconds
Donation Image