Welcome, Guest
Username: Password: Remember me

TOPIC: 1.91 upgrade problem

1.91 upgrade problem 3 years 6 months ago #61252

  • stitcho
  • stitcho's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 13
  • Karma: 0
I have upgraded using the Comfort updater and when I try to get to the amdin page I get this:

Illegal mix of collations (utf8_general_ci,IMPLICIT) and (utf8_unicode_ci,IMPLICIT) for operation '=': SELECT a.*, surveyls_title, surveyls_description, surveyls_welcometext, surveyls_url FROM `lime_surveys` AS a INNER JOIN `lime_surveys_languagesettings` on (surveyls_survey_id=a.sid and surveyls_language=a.language) order by active DESC, surveyls_title

If I try to go to the front end page I just get this:

Could not connect to database. If you try to install LimeSurvey please refer to the installation docs and/or contact the system administrator of this webpage.

Anyone know how to fix or roll this upgrade back?
The administrator has disabled public write access.

Re: 1.91 upgrade problem 3 years 6 months ago #61271

  • bigrossco
  • bigrossco's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 1
  • Karma: 0
I also have the same issue
The administrator has disabled public write access.

Re: 1.91 upgrade problem 3 years 5 months ago #61624

  • PMarkowski
  • PMarkowski's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
Also experiencing this problem.
The administrator has disabled public write access.

Re: 1.91 upgrade problem 3 years 5 months ago #61712

  • tobyrhodes
  • tobyrhodes's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 20
  • Thank you received: 1
  • Karma: 0
Hi - I am having the same problem ... completed the comfort upgrade, now cant access the admin pages at all. This has completely disabled LimeSurvey ... anyone know how to fix this or revert to the previous version?

Here is what I now get on my admin page:

Illegal mix of collations (utf8_general_ci,IMPLICIT) and (utf8_unicode_ci,IMPLICIT) for operation '=': SELECT a.*, surveyls_title, surveyls_description, surveyls_welcometext, surveyls_url FROM `lime_surveys` AS a INNER JOIN `lime_surveys_languagesettings` on (surveyls_survey_id=a.sid and surveyls_language=a.language) order by active DESC, surveyls_title

Cheers
Toby
The administrator has disabled public write access.

Aw: Re: 1.91 upgrade problem 3 years 5 months ago #61721

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5423
  • Thank you received: 307
  • Karma: 252
Please search the bugtracker (bugs.limesurvey.org) for update related tickets, I think there have been some fixes recently.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Aw: Re: 1.91 upgrade problem 3 years 5 months ago #61731

  • tobyrhodes
  • tobyrhodes's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 20
  • Thank you received: 1
  • Karma: 0
Hi Mazi

Thanks for your reply.

I have looked through the bug fixes, but none of them seem to relate to this problem as far as I can see (I may be wrong about this, so please forgive me if I have overlooked one).

Any further thoughts?
Cheers
Toby
The administrator has disabled public write access.

Re: 1.91 upgrade problem 3 years 5 months ago #61750

  • PMarkowski
  • PMarkowski's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
Hi Mazi,

I too have gone through the bugtracker, and couldn't find anything that relates to this. Can you point us in the right direction?

Thanks!
The administrator has disabled public write access.

Re: 1.91 upgrade problem 3 years 5 months ago #61781

  • tobyrhodes
  • tobyrhodes's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 20
  • Thank you received: 1
  • Karma: 0
Hi All

I have found the problem ... it is to do with the collation of individual fields and some tables of the MySQL database ... these all need setting to utf8_unicode_ci (using PHPMyAdmin)

I had a feeling I had seen this problem before ... here is a link to an earlier bug report (the trigger was different, but the cause and solution are the same) bugs.limesurvey.org/view.php?id=4725

I have gone through every field that was set to utf8_general_ci and set it to utf8_unicode_ci. Although a bit laborious, this has worked, and I can now access the system.

cheers
Toby
The administrator has disabled public write access.

Re: 1.91 upgrade problem 3 years 5 months ago #62403

  • ljarbeau
  • ljarbeau's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 12
  • Karma: 0
I have tried the fix mentioned at the bug report site --- but phpmyadmin is not allowing for me to change all the general to unicode --- I don't have a BROWSE option on all of them

my error
Illegal mix of collations (utf8_general_ci,IMPLICIT) and (utf8_unicode_ci,IMPLICIT) for operation '=': SELECT a.*, surveyls_title, surveyls_description, surveyls_welcometext, surveyls_url FROM `lime_surveys` AS a INNER JOIN `lime_surveys_languagesettings` on (surveyls_survey_id=a.sid and surveyls_language=a.language) order by active DESC, surveyls_title
The administrator has disabled public write access.

Re: 1.91 upgrade problem 3 years 5 months ago #62418

  • tobyrhodes
  • tobyrhodes's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 20
  • Thank you received: 1
  • Karma: 0
Hi ljarbeau
I found I had to go into every field individually and change each one. If you try to change at the table level, then the individual fields do not seem to change.
hope this helps
Toby
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.127 seconds
Donation Image