Welcome, Guest
Username: Password: Remember me

TOPIC: Fatal error: Cannot redeclare class limesurvey_lang

Fatal error: Cannot redeclare class limesurvey_lang 3 years 9 months ago #56925

Hi there,

I was wondering if someone could help me. I just installed LimeSurvey onto my Mac OS X Server and after a bit of configuration and head scratching i have been able to get the Admin side of LimeServer up and running. I then created a test survey, but the problem came when i went to try the test survey. All i got was a total blank page. After enabling the debug in the config i then got my error.

Fatal error: Cannot redeclare class limesurvey_lang in /library/WebServer/Documents/Files/limesurvey/classes/core/language.php on line 29

I tried to trace line 29 but to be honest my PHP scripting/reading isn't so great.

The server I'm running is Mac OS X 10.6.6
PHP Version 5.3.3
MYSQL 5.0.7

Any help would be greatly appreciated.

Scott
The administrator has disabled public write access.

Re: Fatal error: Cannot redeclare class limesurvey_lang 3 years 9 months ago #56926

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5426
  • Thank you received: 307
  • Karma: 252
1. Which Limesurvey version did you install?

2. Which URL did you call to login at the admin screen?

3. What did you set as $rooturl and $rootdir in config.php?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
Last Edit: 3 years 9 months ago by Mazi.
The administrator has disabled public write access.
The following user(s) said Thank You: scottwatkins

Re: Fatal error: Cannot redeclare class limesurvey_lang 3 years 9 months ago #56951

Hi Mazi,

I am using the latest version 1.90+

I was also using a local domain broadcast by my server. Phoenix.Local/Limesurvey/Admin/Admin.php

And your third question lead me to the resolution. I specified the full path to the directory for the $rootdir when the Phoenix.Local only pointed to the Files directory. I simple corrected the file path and everything was working fine. Thanks for the help!
The administrator has disabled public write access.

Re: Fatal error: Cannot redeclare class limesurvey_lang 3 years 9 months ago #56974

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5426
  • Thank you received: 307
  • Karma: 252
scottwatkins wrote:
And your third question lead me to the resolution. I specified the full path to the directory for the $rootdir when the Phoenix.Local only pointed to the Files directory. I simple corrected the file path and everything was working fine. Thanks for the help!
You're welcome!

If our hints have been helpful and you enjoy limesurvey please consider a donation to the team .
We do all this in our free time and you don't have to pay a penny for this software.

Without your help we can't keep this project alive.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Fatal error: Cannot redeclare class limesurvey_lang 1 year 10 months ago #90562

  • kmccann
  • kmccann's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 1
  • Karma: 0
Windows, IIS 6, PHP 5.3

I tried upgrading to 2.00 but encountered the previously-reported looping issue, so backtracked to 1.92 (replaced old files, reloaded old database).

Now I am getting:

Fatal error: Cannot redeclare class limesurvey_lang in C:\Inetpub\wwwroot\membersurveys\classes\core\language.php on line 29

My $rootdir and $rooturl in config.php are fine, they have not changed at all over the years. I have also tried reverting back to 1.91 code and am getting the same error.

If I comment the code out in classes/core/languages.php I get the error that the class does not exist, which makes sense, and if I put it back as it was, I get the re-declare error, so somehow language.php is being re-required or included somewhere?

My permissions seem to be fine. I'm at a loss.

-Kevin
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.100 seconds
Donation Image