Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Cannot import survey that is earlier imported from 1.87

Cannot import survey that is earlier imported from 1.87 3 years 8 months ago #56679

  • joop
  • joop's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 8
  • Karma: 0
Hi All,

I've got the following message when importing a survey:

An error occurred uploading your file. This may be caused by incorrect permissions in your /var/www/html/limesurvey/tmp folder.

I normally can import surveys that which I create in my current limesurvey version. Problems only show up when I try to export and import a survey that I earlier created in Limesurvey 1.87.

My /tmp /upload and /templates and subfolders have all 777 permissions.
The strange part is that I can import this survey in the Demo installation of limesurvey.org.

Is something fixed in the version of the demo installation or is something wrong with my installation? (version 1.90 build 9642)
Part of the message is hidden for the guests. Please log in or register to see it.

any help would be appreciated,

Joop
The administrator has disabled public write access.

Re: Cannot import survey that is earlier imported from 1.87 3 years 8 months ago #56698

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5333
  • Thank you received: 296
  • Karma: 249
I can't access the phpinfo file, can you check or export it as PDF and upload the information here?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Cannot import survey that is earlier imported from 1.87 3 years 8 months ago #56708

  • joop
  • joop's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 8
  • Karma: 0

File Attachment:

File Name: phpinfo.pdf
File Size: 147 KB


I attached phpinfo in a pdf-file. Furthermore it maybe interesting to now that I use SQL server 2005 as DB.
The administrator has disabled public write access.

Re: Cannot import survey that is earlier imported from 1.87 3 years 8 months ago #56718

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5333
  • Thank you received: 296
  • Karma: 249
The config looks fine. Can you also attach the survey that fails to import?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Cannot import survey that is earlier imported from 1.87 3 years 8 months ago #56735

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5333
  • Thank you received: 296
  • Karma: 249
I could import the survey without any problems. I'm pretty sure this is still a right problem. Even if your folders are set to 777 the webserver might prevent scripts from writing to them or creating new files if the security settings are too strict.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Cannot import survey that is earlier imported from 1.87 3 years 8 months ago #56763

  • joop
  • joop's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 8
  • Karma: 0
My problem is that I can import surveys that I newly create in my installation without any problems. Just this one, which I earlier imported from 1.87 causes problems. I also can't find any interesting entries in the Apache log. I already tried to set the debug parameter to 1 (and even 3).
I'm afraid that it has something to do with my irregular configuration of Linux (Redhat el5) and MS SQL server 2005. (I installed php-mssql and use the mssql_n driver)

If I try to copy this survey it looses all conditions. Also pretty strange...
Another strange behaviour is that some question types (e.g. gender or radio-list) will not validate mandatory questions anymore after activation of the survey. This is not reproducible on the (mysql) limesurvey demo-site.

Help! I'm getting confused here. :blink:
The administrator has disabled public write access.

Re: Cannot import survey that is earlier imported from 1.87 3 years 8 months ago #56768

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5333
  • Thank you received: 296
  • Karma: 249
Can you set up an 1.90 system on MS SQL and import try to import the survey there?
Maybe this problem is MS SQL related, I have heard of similar topics recently but it seems to be very hard to track the error. Maybe you can help by testing as described above.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Cannot import survey that is earlier imported from 1.87 3 years 8 months ago #56769

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5333
  • Thank you received: 296
  • Karma: 249
The problem might be connected to this bug: bugs.limesurvey.org/view.php?id=4939

Try switching the driver to mssql_odbc at config.php if possible.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Cannot import survey that is earlier imported from 1.87 3 years 8 months ago #57038

  • joop
  • joop's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 8
  • Karma: 0
Hi Mazi,

I switched from driver 'mssql_n' to 'odbc_mssql'. Bottomline is that it still not solved (all) my problems or that it introduced new errors.

Installation of an odbc driver on Linux is quite an experience. I use Freetds and the php-odbc module. I installed a system DSN by configure freetds.conf, odbc.ini and odbcinst.ini.
To get Limesurvey recognize the system DSN on Linux, you need to adapt common.php as is written somewhere else on this forum. (line 160 should be
case "odbc_mssql": $dbhost="$databaselocation";
)

Directly after login in limesurvey admin section, you get a blank page. After completely debugging limesurvey till the specific query that gave problems, I noticed in the freetds logging that the query/action somehow was canceled. Some searching on the Internet learned me that I needed to upgrade my freetds driver from version 0.64 to 0.82. After this I was able to login and do the same stuff as with the mssql_n driver.

One point seems to be solved now; mandatory questions are validated again after survey activation.

While importing the specific survey I still get the same error that my tmp folder has not enough permissions. I think I do a complete debugging of limesurvey for this problem too.

When copying the specific survey I got a different error now:
Warning: simplexml_load_string() [function.simplexml-load-string]: Entity: line 11209: parser error : Input is not proper UTF-8, indicate encoding ! Bytes: 0xC4 0x3F 0x64 0x65 in /var/www/html/limesurvey/admin/importsurvey.php  on line 1232
 
Warning: simplexml_load_string() [function.simplexml-load-string]: <answer><![CDATA[Ni�?de]]></answer> in /var/www/html/limesurvey/admin/importsurvey.php on line 1232
 
Warning: simplexml_load_string() [function.simplexml-load-string]: ^ in /var/www/html/limesurvey/admin/importsurvey.php on line 1232
 
Notice: Trying to get property of non-object in /var/www/html/limesurvey/admin/importsurvey.php on line 1235
This is not a valid LimeSurvey survey structure XML file.
This seems to be a charset problem now with the current driver.

Any advise?
The administrator has disabled public write access.

Re: Cannot import survey that is earlier imported from 1.87 3 years 8 months ago #57044

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5333
  • Thank you received: 296
  • Karma: 249
I'm not a server expert so I have to admit that I can't help much. Most user use Apache/MySQL and don't have such problems.
I'm pretty sure that it's not a Limesurvey problem but a server configuration issue. Maybe asking at some sysadmin forum will lead to some more hints.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.233 seconds
Donation Image