Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Installations & Configuration on Server 2008 with IIS7

Installations & Configuration on Server 2008 with IIS7 3 years 5 months ago #56219

  • thiru06
  • thiru06's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Have anyone successfully install limesurvey 1.90+ on Windows Server 2008 with IIS7? Please help me out with a tutorial if you can....


Thank you in advance.
Last Edit: 3 years 5 months ago by thiru06.
The administrator has disabled public write access.

Re: Installations & Configuration on Server 2008 with IIS7 3 years 5 months ago #56223

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2549
  • Thank you received: 285
  • Karma: 102
What did you try so far? Did you have any trouble? Where did you run into trouble?

Did you check the chapters about installation in the documentation already? e.g. docs.limesurvey.org/Installation+FAQ#Som..._errors_IIS_focused_
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.
The following user(s) said Thank You: thiru06

Re: Installations & Configuration on Server 2008 with IIS7 3 years 5 months ago #56224

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5300
  • Thank you received: 291
  • Karma: 247
We need a little more input:

1. At which step of the installtion do you run into problems?

2. Are there any error messages?

3. What did you set in your config.php file?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Installations & Configuration on Server 2008 with IIS7 3 years 5 months ago #56292

  • pholcomb
  • pholcomb's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
I'm having problems getting Limesurvey to run on Windows 2008 and IIS 7 as well. I have successfully:
(1) installed fastCGI and php (both of which I already use for a Wiki -- and this works fine) as well as MySQL.
(2) unpacked Limesurvery into a folder under IIS wwwroot.
(3) created a database in MySQL using settings recommended at: learn.iis.net/page.aspx/313/limesurvey-on-iis/
(4) modified the config.php file as recommended.

When I try to access http://localhost/limesurvey/admin/install
I get a the following error:

HTTP Error 500.0 - Internal Server Error
The page cannot be displayed because an internal server error has occurred. Detailed Error Information
Module FastCgiModule
Notification ExecuteRequestHandler
Handler PHP_via_FastCGI
Error Code 0x00000000
Requested URL http://localhost:80/limesurvey/admin/install/index.php
Physical Path C:\inetpub\wwwroot\limesurvey\admin\install\index.php
Logon Method Anonymous
Logon User Anonymous


Any ideas?

Thanks
The administrator has disabled public write access.

Re: Installations & Configuration on Server 2008 with IIS7 3 years 5 months ago #56293

  • thiru06
  • thiru06's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
@holch & Mazi I really appropriate your initiative to help me.. however I ended up figuring it out. Mostly my errors were on the IIS7.
The administrator has disabled public write access.

Re: Installations & Configuration on Server 2008 with IIS7 3 years 5 months ago #56294

  • thiru06
  • thiru06's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
@pholcomb I will guide you through this but in series of steps so try the first step and post if any error occur just like your first post.... let's get started!

> right click limesurvey from IIS7 Sites and click "edit permissions.." and go to "Security" tab and add "IUSR" and "NETWORK SERVICES" allow read & execute and allow write for both.

restart iis and let me know.
Last Edit: 3 years 5 months ago by thiru06. Reason: typeo
The administrator has disabled public write access.

Re: Installations & Configuration on Server 2008 with IIS7 3 years 5 months ago #56295

  • pholcomb
  • pholcomb's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
OK, I was able to add IUSR and change permissions to "write", but I do not seem to have a "NETWORK SERVICES" user. When I tried to add it, as I did with IUSR, the permissions dialog complains that the "NETWORK SERVICES" user does not exist. With just the IUSR permissions changed I am still getting the HTTP Error 500.0 Any ideas?

Thanks
The administrator has disabled public write access.

Re: Installations & Configuration on Server 2008 with IIS7 3 years 5 months ago #56297

  • pholcomb
  • pholcomb's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
Check that -- I just found the "NETWORK SERVICE" user and changed permissions as instructed. So now both IUSR and NETWORK SERVICE are added and "write" enabled. After restarting IIS, still getting 500 error...
The administrator has disabled public write access.

Re: Installations & Configuration on Server 2008 with IIS7 3 years 5 months ago #56313

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2549
  • Thank you received: 285
  • Karma: 102
This seems to be a server configuration issue and to help on those issues remotely is always quite difficult and only possible to a certain extend, as no one can really look into the configurations.

I think it is best to ask your server administrator to have a look into this. Probably solves the problem much faster than the guess work that can be done via the forum.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re: Installations & Configuration on Server 2008 with IIS7 3 years 5 months ago #56328

  • pholcomb
  • pholcomb's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
Well, unfortunately I am the server administrator! Anybody have any other ideas?
I did notice that someone, some time ago, went into excruciating detail about how to get limesurvey to work on Windows XP with IIS (www.limesurvey.org/es/forum/installation...survey-on-iis-for-xp). Those instructions were quite complicated and involved numerous tweaks suggesting that configuration on any Windows OS with IIS is not as straight forward as the limesurvey instructions suggest. Has no one written up a similar step-by-step description for Windows Server 2008 and IIS7?
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.152 seconds
Donation Image