Welcome, Guest
Username: Password: Remember me

TOPIC: Admin login goes to "fatal error" but database set up

Admin login goes to "fatal error" but database set up 3 years 2 months ago #55977

  • krsanna
  • krsanna's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
I installed 1.90 last night and the database sets up fine and admin page comes up, but everytime I try to login it goes to a blank page and fatal error. Help! I do not get the message about characters, like (). It just gives me the 404 fatal error. Thank you.
The administrator has disabled public write access.

Re: Admin login goes to "fatal error" but database set up 3 years 2 months ago #55982

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2452
  • Thank you received: 256
  • Karma: 94
What did you set as root_url in the config.php?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re: Admin login goes to "fatal error" but database set up 3 years 2 months ago #55984

  • krsanna
  • krsanna's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
The administrator has disabled public write access.

Re: Admin login goes to "fatal error" but database set up 3 years 2 months ago #55989

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2452
  • Thank you received: 256
  • Karma: 94
Looks like there is something wrong with the root_url.

Leave it as it is (don't put the domain), limesurvey will find it's way.

So I have seen that you have installed Limesurvey under www.timestar.org/limesurvey

I can see there, that the images and CSS is missing. That shows me, that the path is not correct.

This is what you should put into your $roolurl, if your limesurvey files are located under www.timestar.org/limesurvey:
$rooturl = "http://{$_SERVER['HTTP_HOST']}/limesurvey";

Try it with the exact term above, leaving {$_SERVER} as it is. This should work.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re: Admin login goes to "fatal error" but database set up 3 years 2 months ago #56003

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5279
  • Thank you received: 289
  • Karma: 246
Problem solved?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Admin login goes to "fatal error" but database set up 3 years 2 months ago #56062

  • krsanna
  • krsanna's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
Yes, thank you. The root url that ended up working was: "timestar.org/public_html/limesurvey"

I'm happily working away on the survey now. Thanks, again.
The administrator has disabled public write access.

Re: Admin login goes to "fatal error" but database set up 3 years 2 months ago #56063

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5279
  • Thank you received: 289
  • Karma: 246
That is a very strange rooturl, but as long as it works fine...

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Admin login goes to "fatal error" but database set up 3 years 2 months ago #56088

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 5875
  • Thank you received: 722
  • Karma: 223
Mazi wrote:
That is a very strange rooturl, but as long as it works fine...
Actually
timestar.org/limesurvey/admin/admin.php seems OK :dry:
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.168 seconds
Donation Image