Welcome, Guest
Username: Password: Remember me

TOPIC: How to setup the security question

How to setup the security question 3 years 5 months ago #55968

  • georgios
  • georgios's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
Hi folks,

This should be a quickie. I just setup a 1.90+ build 9642 ls server. Everything appears to work, have setup 3 surveys, my token tables are fine, but I cannot figure out how to setup the security question, when one needs to resume entering data to the survey.

I have a test open survey (public access) and want users to be able to resume data. Where do I set the security question in the last field (see attached screenshot)
secquestionresume.png


Thanks for any quick answers!

George
The administrator has disabled public write access.

Re: How to setup the security question 3 years 5 months ago #56016

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5300
  • Thank you received: 291
  • Karma: 247
There seems to be a problem with the captcha feature. Usually there should be a simple picture diaplyed like [8+5=] and the users have to answer that security questions.
Maybe there is a library missing at your server so the picture can't be created.

Please switch on debug mode by adding the following line to your config.php file:
$debug = '1';

Are there any additional errors reported on top of the page?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: How to setup the security question 3 years 5 months ago #56042

  • georgios
  • georgios's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
Hi,

I see. I suspected that PHP was not compiled with libgd, but it has been, my PHP env states:


GD Support enabled
GD Version bundled (2.0.34 compatible)
GIF Read Support enabled
GIF Create Support enabled
PNG Support enabled
WBMP Support enabled
XBM Support enabled

So, thumbs up there.

No error messages at the top of the page and debug='1' is enabled in the config.php.

In the Apache error_log, I do not see anything that draws my attention. What else do I look to debug the failed captcha module...

GM
The administrator has disabled public write access.

Re: How to setup the security question 3 years 5 months ago #56071

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5300
  • Thank you received: 291
  • Karma: 247
1. Another guess is a PHP module that might cause problems such as "suhosin" or "mod_security". If you find something like that try to disable the module and test.

2. Please upload a phpinfo file so we can take a look at your server configuration. Just put the following code into a file named phpinfo.php and upload it to your webserver:
< ?php phpinfo(); ? >
(Delete the spaces next to </> when copying the code.)
After uploading please post the link to the file.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: How to setup the security question 3 years 3 months ago #59726

  • aghigi
  • aghigi's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 1
  • Karma: 0
Same problem here.

I found out that ImageTTFText() function in verification.php needs both GD and FreeType support.

If FreeType is enabled in GD library, you see it listed in the GD section from phpinfo()
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.235 seconds
Donation Image