Welcome, Guest
Username: Password: Remember me

TOPIC: [ver. 1.90+ Build 9642] All conditional questions showing up in custom templates

[ver. 1.90+ Build 9642] All conditional questions showing up in custom templates 3 years 6 months ago #55537

  • Paul
  • Paul's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
We recently upgraded from 1.82 to 1.90+. Following the upgrade directions, I moved our custom templates from limesurvey/templates to limesurvey/upload/templates and set the permissions for limesurvey/tmp, limesurvey/templates, and limesurvey/upload/templates to 777. No files inside the template directories were altered by us during the upgrade and subsequent moving of the templates. The templates show up in the admin panel and can be selected and applied to surveys.

The problem is that all of the questions - including those that should be hidden unless a question is answered a certain way - are being displayed in the surveys.

This was not a problem with these templates in the 1.82 version.

Any help or advice on where to look for the source of this error is greatly appreciated. Thank you.
The administrator has disabled public write access.

Re: [ver. 1.90+ Build 9642] All conditional questions showing up in custom templates 3 years 6 months ago #55538

  • c_schmitz
  • c_schmitz's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 748
  • Thank you received: 103
  • Karma: 87
Templates have changed a big deal since 1.82 so your custom templates won't work anymore (as you already noticed).

I suggest to re-modify an existing standard template. In most cases it is easier than trying to prop up your existing one.
Support us, too. Donate to the LimeSurvey project and help keep us going!
The administrator has disabled public write access.

Re: [ver. 1.90+ Build 9642] All conditional questions showing up in custom templates 3 years 6 months ago #55570

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5302
  • Thank you received: 291
  • Karma: 247
As part of our advanced (paid) support we offer help in modifying customized templates to work with the latest 1.90 Limesurvey version. You can ping me at This email address is being protected from spambots. You need JavaScript enabled to view it. if you are interested.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: [ver. 1.90+ Build 9642] All conditional questions showing up in custom templates 3 years 6 months ago #55676

  • Paul
  • Paul's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
I appreciate the replies.

What changes need to be made to get older (1.82) custom templates working in 1.90+? They show up in the editor, but nothing appears to be flagged as being in error (of course, I'm still learning so I may have missed it)
The administrator has disabled public write access.

Re: [ver. 1.90+ Build 9642] All conditional questions showing up in custom templates 3 years 6 months ago #55677

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2569
  • Thank you received: 292
  • Karma: 106
The structure of the templates has changed and there are new files and other attributes, that are necessary.

The best way is, as Carsten has said already, to take one of the templates that come with Limesurvey and modify them accordingly.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re: [ver. 1.90+ Build 9642] All conditional questions showing up in custom templates 3 years 6 months ago #55678

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5302
  • Thank you received: 291
  • Karma: 247
holch wrote:
The best way is, as Carsten has said already, to take one of the templates that come with Limesurvey and modify them accordingly.
I'd also like to add that it depends on the template. If you just added a customized logo and changed some colors by CSS, it might be easier to adjust the structure so that the template works fine with the latest version.
If you overworked the whole structure of a template, re-setting it up from scratch would be the way to go.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: [ver. 1.90+ Build 9642] All conditional questions showing up in custom templates 3 years 6 months ago #55724

  • Paul
  • Paul's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
For those interested, the conditional questions were fixed by the addition of this (see the note below the chart) div tag to the question.pstpl file.

I am currently working to get the progress bar to render correctly. I've been referencing the javascript located on the workaround page
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.125 seconds
Donation Image