Welcome, Guest
Username: Password: Remember me

TOPIC: Converting surveys from phpSurveyor

Converting surveys from phpSurveyor 3 years 3 months ago #55514

  • macanics
  • macanics's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 8
  • Karma: 0
Hi,
I'm trying to convert surveys from an old phpSurveyor 0.98 install, by exporting them (as .sql files, and .zip files for the templates) and then importing them to a temp install of LS 1.5. Then exporting as .csv files and finally importing into LS

A few surveys work, but a lot partially import, but stop with this error message:
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'and language='en'' at line 1:select * from `labels` where lid= and language='en'

Is there a step I've missed out, or something I can do to fix this? I've looked at the csv files and can't see anything obviously wrong...

Running Version 1.90+ Build 9642 on Mac OS X 10.6 Server

cheers,
---john---
Last Edit: 3 years 3 months ago by macanics.
The administrator has disabled public write access.

Re: Converting surveys from phpSurveyor 3 years 3 months ago #55607

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5279
  • Thank you received: 289
  • Karma: 246
phpSurveyor 0.98 is stone old and lots of changes to the DB were made up to version 1.90. Porting from phpSurveyor 0.98 to 1.53 and then to 1.90 is the right approach but this might not work for all surveys.
I fear you have to rebuild these.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.093 seconds
Donation Image