Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: First time login gets a 404 at admin/admin.php

First time login gets a 404 at admin/admin.php 3 years 9 months ago #55351

  • cpcp
  • cpcp's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
Hi,

I have searched this problem but can't find anything similar -suggests I guess I am overlooking something rather basic :blush:


I have re-uploaded the software twice to my server but get the same problem when logging in for the first time (following the delete/renaming of the install directory).

After login I get redirected to admin/admin.php which shows as a 404.

I have tried logging in using $defaultuser and $defaultpass and also using $databaseuser and $databasepass but the same thing happens.

Given I got to this point with no trouble I am assuming that leaving $rootdir at the default is just fine.

Thanks for any ideas :)
The administrator has disabled public write access.

Re: First time login gets a 404 at admin/admin.php 3 years 9 months ago #55352

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5348
  • Thank you received: 298
  • Karma: 250
1. Which Limesurvey version are we talking about?

2. Which URL do you use to cal the login screen?

3. What did you set as $rooturl in config.php?

4. Did you touch the file config-defaults.php or copy any settings from there to config.php?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: First time login gets a 404 at admin/admin.php 3 years 9 months ago #55358

  • cpcp
  • cpcp's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
1. Which Limesurvey version are we talking about?
190plus-build9642-20101214

2. Which URL do you use to cal the login screen?

limesurcey/admin/install/index.php (populate the db)
limesurcey/admin/install/createdb.php
limesurcey/admin/install/admin.php (requests change/delete of "install")
limesurcey/admin/install/admin.php (request user and pass)
then when I hit the login button I get a 404 at
admin/admin.php (note it looks for admin above limesurvey)

3. What did you set as $rooturl in config.php?

$rooturl = "http://{$_SERVER}"


4. Did you touch the file config-defaults.php or copy any settings from there to config.php?

No.


Thanks :)
Last Edit: 3 years 9 months ago by cpcp.
The administrator has disabled public write access.

Re: First time login gets a 404 at admin/admin.php 3 years 9 months ago #55362

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5348
  • Thank you received: 298
  • Karma: 250
Can you post the real link you are using when trying to log in at your Limesurvey system?

If that is not possible my first guess would be to change $rooturl to:
$rooturl = "http://{$_SERVER}/limesurvey"

...assumed that you installed Limesurvey into a folder called "limesurvey" so it is available at www .yourdomain.org/limesurvey

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: First time login gets a 404 at admin/admin.php 3 years 9 months ago #55365

  • cpcp
  • cpcp's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
Thanks Mazi, that did it!

I'm still a bit confused though about how the program managed to find the correct directory up until that point but anyway "all's well that ends well"!
Last Edit: 3 years 9 months ago by cpcp.
The administrator has disabled public write access.

Re: First time login gets a 404 at admin/admin.php 3 years 9 months ago #55399

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5348
  • Thank you received: 298
  • Karma: 250
You're welcome!

If our hints have been helpful and you enjoy limesurvey please consider a donation to the team .
We do all this in our free time and you don't have to pay a penny for this software.

Without your help we can't keep this project alive.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: First time login gets a 404 at admin/admin.php 2 years 11 months ago #69104

  • Heisen
  • Heisen's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
Hi,

I just downloaded limesurvey 1.91+ and installed it locally using xampp. Now I´m having the same problem executing admin.php.

This is my root url as defined in my config.php

$rooturl = "http://{$_SERVER}/limesurvey";

My files are in a sub-directory http://localhost/username/limesurvey . I already tried to change the $rooturl to "http://{$_SERVER}/username/limesurvey", but still I get the same error.

Can anyone help me?

Thanks a lot!
The administrator has disabled public write access.

Re: First time login gets a 404 at admin/admin.php 2 years 11 months ago #69105

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2853
  • Thank you received: 360
  • Karma: 125
What is the structure within the folder "limesurvey"?

Because there must be something wrong with your path. But you installed it sucesfully??
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re: First time login gets a 404 at admin/admin.php 2 years 11 months ago #69106

  • Heisen
  • Heisen's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
Yes, i installed it successfully and i did not change the structure within the limesurvey folder (except changing the name of the install folder after completing the <a href='www.docs.limesurvey.org/tiki-index.php?p...tions+for+LimeSurvey'>installation</a>, as requested by the program).

I noticed a difference between my $rooturl and cpcp´s:

cpcp´s
$rooturl = "http://{$_SERVERSERVER_NAME[/color]']}/limesurvey"

mine:
$rooturl = "http://{$_SERVERHTTP_HOST[/color]']}/limesurvey";

Why is this? Because I installed on a local host?
Last Edit: 2 years 11 months ago by Heisen.
The administrator has disabled public write access.

Re: First time login gets a 404 at admin/admin.php 2 years 11 months ago #69108

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2853
  • Thank you received: 360
  • Karma: 125
So the folder "admin" can be found directly within the folder "limesurevey"? Like this: "/limesurvey/admin/"?

Sounds fairly strange.

Mine for example ist
$rooturl = "http://{$_SERVER['HTTP_HOST']}/091SL";

So your's should be fine. Were exactly on your computer is the admin folder? Copy the path here. It might be actually a typo somewhere.

What does happen when you call http://localhost/limesurvey ?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.189 seconds
Donation Image