Welcome, Guest
Username: Password: Remember me

TOPIC: Responses not visible in old surveys after upgrade

Responses not visible in old surveys after upgrade 3 years 4 months ago #53249

  • jobrien
  • jobrien's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 1
  • Karma: 0
I just upgraded from Version 1.72 (5737) to 1.90+ Build 9487. Also changed from MySql to SQL Server Express 2005 at the same time. No responses are visible in old surveys. I can see responses to a new survey created after upgrade. There were a few orphan responses without questions in the consistency check, which I fixed, and the data check is clean now, but still no responses.

I noticed that the survey_xxxxx tables are different between the old and new surveys: the new tables include columns datestamp and startdate. When browsing survey responses in old surveys, only columns before these new ones are included.

Do I need to just start over with the upgrade, or is there something I can tweak to get it going?

Also, in 1.72, I was using survey attribute 1 to hold an external reference to an event associated with the survey. This field is gone in 1.90; any suggestions on how to store an external reference for a survey?
The administrator has disabled public write access.

Re:Responses not visible in old surveys after upgrade 3 years 4 months ago #53273

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5275
  • Thank you received: 289
  • Karma: 246
1.72 is a pretty old version. This might be a bug but it's hard to tell.

If you have a complete database backup of your 1.72 system it would be helpful to open a new ticket at our bugtracker, describe the problem there and add your .sql file so we can test of the upgrade from 1.72 to 1.90 works fine.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Responses not visible in old surveys after upgrade 2 years 9 months ago #62638

  • rockster
  • rockster's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 1
  • Karma: 0
We are experiencing this issue. We have upgraded to the most recent update 1.91+ and it still occurs. Is there a fix for this?
Thanks
The administrator has disabled public write access.

Re: Responses not visible in old surveys after upgrade 2 years 9 months ago #62639

  • c_schmitz
  • c_schmitz's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 718
  • Thank you received: 91
  • Karma: 83
Mazi's response still applies.
Support us, too. Donate to the LimeSurvey project and help keep us going!
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.112 seconds
Donation Image