Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: "No in put file specified"

"No in put file specified" 3 years 10 months ago #52736

  • macultra20
  • macultra20's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
After having to change to another hosting company, I am in the process of installing Limesurvey once again. I have successfully created the database and connected to it. I can access the admin login page and after logging in I receive the message "No input file specified". I have no idea what file the program is trying to access after I log in. I've read several posts and the documentation where the root url in config.php was the culprit...is this the case here?
Thanks in advance...
The administrator has disabled public write access.

Re:"No in put file specified" 3 years 10 months ago #52816

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5331
  • Thank you received: 296
  • Karma: 249
I have never heard of this problem before.

1. Please switch on debug mode by adding the following line to your config.php file:
$debug = '1';

Are there any additional errors reported on top of the page?

2. Re-upload all files in binary mode of your browser, maybe a file was broken during upload.

3. If all this doesn't help, try re-installing Limesurvey.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re:"No in put file specified" 3 years 10 months ago #53089

  • macultra20
  • macultra20's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
I finally figured it out. I re-uploaded the files as suggested and still got the same error message. The culprit was the $rooturl in the config.php file. My installation required that I type in the full server url. This was stated in the installation instructions as a last resort if the normal method does not work. I was confused by the error message that stated no input file...but the problem was the admin script needed to be pointed to the correct url. Thanks for the help.
The administrator has disabled public write access.

Re:"No in put file specified" 3 years 10 months ago #53167

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5331
  • Thank you received: 296
  • Karma: 249
You're welcome!

If our hints have been helpful and you enjoy limesurvey please consider a donation to the team .
We do all this in our free time and you don't have to pay a penny for this software.

Without your help we can't keep this project alive.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re:"No in put file specified" 2 years 2 months ago #83761

  • abita1
  • abita1's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 44
  • Thank you received: 1
  • Karma: 0
I have the same problem, except in 2.0 RC7. Unlike the 1.8/1.9 variants, it seems that there is no config.php to amend, which might cure the identified problem. I've tooled through the various index.php files, in the admin, installer, and other directories, and haven't found a decipherable clue of what change I might make which duplicates the solution identified by the original report.

Any suggestions?

There appear to be several [including mine] folks who report this problem in the last 6months, some of which, like mine, arising in the 2.0RC arena.
The administrator has disabled public write access.

Re:"No in put file specified" 2 years 2 months ago #83764

  • holch
  • holch's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 2839
  • Thank you received: 356
  • Karma: 123
Are you sure that all files are uploaded and accessible under the URL that you start when trying to install?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re:"No in put file specified" 2 years 2 months ago #83767

  • abita1
  • abita1's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 44
  • Thank you received: 1
  • Karma: 0
Yes....see my own initiated post on the current error, at:

http://www.limesurvey.org/en/forum/installation-a-update-issues/83729-ver-2-rc-7--install-attempt-returns-qno-input-file-specified-q#83731

sorry...it seems the url reference coding slithers a little...I can't get it to display correctly, but it looks like the first part of the link actually points to the correct place
Last Edit: 2 years 2 months ago by abita1. Reason: another attempt....
The administrator has disabled public write access.

Re:"No in put file specified" 2 years 2 weeks ago #86530

  • dweisser
  • dweisser's Avatar
  • OFFLINE
  • Bronze Donor
  • Posts: 205
  • Thank you received: 5
  • Karma: 5
I am having this very issue even now trying to install 2.0 on a GoDaddy server.

I have checked the uploaded files (seem complete), changed the .php script on my GoDaddy Server from 5.3 to 5.2, (suggested in posts to cure install problems with 1.X) and I am still stuck.

The installer won't run.

when I enter the url "springboltconsulting.com/survey/admin", I seem to get redirected to: "springboltconsulting.com/survey/index.php/installer" but I see the error: "No input file specified". ("survey" is my LS install directory).

Should I change all directory permissions to 777? I'm out of my element. In posts on this subject, I have yet to see a sure fire solution.

If anyone has any further information that can cure my install woes, please help. Oh comfort updater....I miss you so.

Thanks all,
David
SpringBolt Consulting
The administrator has disabled public write access.

Re:"No in put file specified" 2 years 2 weeks ago #86531

  • holch
  • holch's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 2839
  • Thank you received: 356
  • Karma: 123
For me, springboltconsulting.com doesn't work at all...
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re:"No in put file specified" 2 years 2 weeks ago #86532

  • dweisser
  • dweisser's Avatar
  • OFFLINE
  • Bronze Donor
  • Posts: 205
  • Thank you received: 5
  • Karma: 5
www.springboltconsulting.com/
i'm looking at it...and running surveys from 1.92 on it...

Thanks for your interest. I'm still wrestling.
David
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.214 seconds
Donation Image