Welcome, Guest
Username: Password: Remember me

TOPIC: Upgrade to 1.90 - issues

Upgrade to 1.90 - issues 3 years 9 months ago #51436

  • gavlar
  • gavlar's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
hi there

I am running on Suse Linux Enterprise Server 10 with Apache - linking to a MySQL database.

I have been running Version 1.82+ (6825) for some time now with very happy users :)

But we spotted an issue in IE7 where the answers for a numerical ranking question were not being displayed - so I tried upgrading to the latest version 1.90 to see if it fixed the issue.

It does - but introduces some other issues which I'd appreciate your help with.

The main thing is when I click template editor, I get Failed to copy template-rtl.css to new template directory, and another same message for template.js. It is probably permissions somewhere on my Linux server?

In the upgrade notes it says at step 10. Copy back all your customized templates to /upload/templates. I wasn't sure what this means as in my old version there was no /upload/templates. Should I copy the templates from {root}/templates to here? (I did try that but it made no difference)

I may have some other questions - I am just getting the users to retest some bits

thanks in advance for your help
The administrator has disabled public write access.

Re:Upgrade to 1.90 - issues 3 years 9 months ago #51437

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2558
  • Thank you received: 290
  • Karma: 105
gavlar wrote:
But we spotted an issue in IE7 where the answers for a numerical ranking question were not being displayed - so I tried upgrading to the latest version 1.90 to see if it fixed the issue.

Congratulations. Limesurvey has improved a lot since 1.82. ;-)
The main thing is when I click template editor, I get Failed to copy template-rtl.css to new template directory, and another same message for template.js. It is probably permissions somewhere on my Linux server?

Since 1.9x you can't edit the standard templates that come with LS within the template editor, but need to create a copy. What is new in LS that all additional templates and copies of standard templates are not in the templates folder, but in the upload folder. You need to give LS permission to be able to write there. I think once you have done that, the error will disappear.
In the upgrade notes it says at step 10. Copy back all your customized templates to /upload/templates. I wasn't sure what this means as in my old version there was no /upload/templates. Should I copy the templates from {root}/templates to here? (I did try that but it made no difference)

See above. Only the standard templates that come with LS should reside in the templates folder. All modified and custom teplates should go into /upload/templates/
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re:Upgrade to 1.90 - issues 3 years 9 months ago #51438

  • gavlar
  • gavlar's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
thanks for the quick response!

ok - confession time! my users didn't want to see all the templates - so back at 1.82 I deleted all but the default template and added 2 custom templates - this was both in the {root}/templates folder and in the database ;-)

I have already copied the default and my two custom templates into /upload/templates - and LS has permissions (owner=root, group=www, 775) - as per elsewhere in the install.

Is LS unhappy that the other templates have disappeared?
The administrator has disabled public write access.

Re:Upgrade to 1.90 - issues 3 years 9 months ago #51439

  • gavlar
  • gavlar's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
hi

ok - your post was the hint I needed :-)

I used the default template that came with 1.90 - copied to {root}/templates and /upload/templates - and problem solved

thanks
The administrator has disabled public write access.

Re:Upgrade to 1.90 - issues 3 years 9 months ago #51446

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2558
  • Thank you received: 290
  • Karma: 105
Yeah, the default template is required for the backend of Limesurvey I think. So you should leave at least the default template in the template folder. But seems like you figured this out on your own.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re:Upgrade to 1.90 - issues 3 years 9 months ago #51469

  • DenisChenu
  • DenisChenu's Avatar
  • NOW ONLINE
  • Moderator Lime
  • Posts: 6222
  • Thank you received: 791
  • Karma: 238
You can open only one/X template for your user.

See the user right template panel.

Then you can have all the default template in your limesurvey/template installation, and open only your stable persoanl template.
The administrator has disabled public write access.

Re:Upgrade to 1.90 - issues 3 years 8 months ago #51479

  • gavlar
  • gavlar's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
hi

thanks for the replies.

I do have 3 other issues - can they be logged here?

1) Routing aka Conditioning does not appear to be working in 1.90. Where u have a question whose answer may require you to answer more questions due to your answer, those questions appear regardless of the answer you give. What's more - you don't seem to be able to progress past the routing question

2) The percentage bar, which says how far through the survey you are does not always fully appear on the screen. Sometimes it is there on the first screen - but then the next screen shows 0% and 100% but with no percentage bar in between.

3) When you create a new survey, in Firefox, in the Surveys drop-down list - your new survey appears in bold so u can easily see it. In IE it is not in bold. More of an annoyance really.

Any help appreciated

cheers
The administrator has disabled public write access.

Re:Upgrade to 1.90 - issues 3 years 8 months ago #51564

  • Mazi
  • Mazi's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 5301
  • Thank you received: 291
  • Karma: 247
1. There are no known condition problems at 1.90. Please create a simpe survey which can be used to reproduce the problem and attach the exported file here.

2. Can you reproduce the problem when using the shipped default template?

3. Please open a ticket at the bugtracker and...

1. Give as much information as possible

2. Attach your survey. You can mark your ticket "private" so that only the developers will be able to take a look at it.

3. Provide step-by-step instructions how to reproduce the problem.

4. If possible/helpful please provide screenshots

Afterwards please post the link to the bugtracker so we can follow the progress.

Thanks!

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.125 seconds
Donation Image