Welcome, Guest
Username: Password: Remember me

TOPIC: Newbie question creating survey problems with IE 7

Newbie question creating survey problems with IE 7 3 years 11 months ago #50959

  • pebster
  • pebster's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
I am trying to create my first survey - I click on the button new survey button and add the text for the title etc

The problem is that the Save survey buttons do not seem to be working correctly


The source of the form at the top shows this

<form class='form30' name='addnewsurvey' id='addnewsurvey' action='admin.php' method='post' onsubmit="alert('hi');return isEmpty(document.getElementById('surveyls_title'), 'Error: You have to enter a title for this survey.');" >

the source for the button is

<p><input type='button' onclick="if (isEmpty(document.getElementById('surveyls_title'), 'Error: You have to enter a title for this survey.')) { document.getElementById('addnewsurvey').submit(); }; return false;" value='Save survey' /></p>

though I'm not sure about the nesting of the html

when I hover above the save button I would expect to see admin.php in the status bar - nothing is viewed

and when I click I get an Error on page message in the status bar regadles of the state of the title input box.

The code for the import and copy suvey buttons appears to work.

Has anyone else had this issue - how do I solve it?

I am using Build 9284

Thanks

pebster
The administrator has disabled public write access.

Re:Newbie question creating survey problems with IE 7 3 years 11 months ago #50964

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5325
  • Thank you received: 296
  • Karma: 249
1. Try using Firefox, does that solve the problem?

2. Please switch on debug mode by adding the following line to your config.php file:
$debug = '1';

Are there any additional errors reported on top of the page?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re:Newbie question creating survey problems with IE 7 3 years 11 months ago #50985

  • pebster
  • pebster's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
Will try firefox on another machine tonight

Tried the debug and nothing came up - it looks like my version of IE doesn't like the form.... strange!
The administrator has disabled public write access.

Re:Newbie question creating survey problems with IE 7 3 years 11 months ago #50991

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5325
  • Thank you received: 296
  • Karma: 249
IE often behaves strange but it might also be caused by server settings.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.208 seconds
Donation Image