Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Problem when updating from v1.71+ to 1.90+

Problem when updating from v1.71+ to 1.90+ 4 years 2 weeks ago #50115

  • Feiyue
  • Feiyue's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
I had not been using my survey-tool for a while but was about too again and felt that I should update before going any futher. The installation on the server was version 1.71+ and I tried updating to current version 1.90+ build 9130.

I tried following the update instructions (The thorough way) exactly, but when i get to the final step "Modify the new database tables and finish the installation" and navigate to "/admin/admin.php" the browser starts loading and then i just get the following error message:


The LimeSurvey database is being upgraded (2010-10-06 11:30:08) . Please be patient...

Moving user templates to new location at /home/xxxxxx/public_html/survey/upload/templates...

Executing.....ALTER TABLE `lime_questions` ADD `parent_qid` integer NOT NULL default '0'...Failed! Reason: Duplicate column name 'parent_qid'
Executing.....ALTER TABLE `lime_answers` ADD `scale_id` tinyint NOT NULL default '0'...Failed! Reason: Duplicate column name 'scale_id'
Executing.....ALTER TABLE `lime_questions` ADD `scale_id` tinyint NOT NULL default '0'...Failed! Reason: Duplicate column name 'scale_id'
Executing.....ALTER TABLE `lime_questions` ADD `same_default` tinyint NOT NULL default '0' COMMENT 'Saves if user set to use the same default value across languages in default options dialog'...Failed! Reason: Duplicate column name 'same_default'.
Executing.....CREATE TABLE `lime_defaultvalues` ( `qid` int(11) NOT NULL default '0', `scale_id` int(11) NOT NULL default '0', `sqid` int(11) NOT NULL default '0', `language` varchar(20) NOT NULL, `specialtype` varchar(20) NOT NULL default '', `defaultvalue` text, PRIMARY KEY (`qid` , `scale_id`, `language`, `specialtype`, `sqid` ) ) ENGINE=myISAM CHARACTER SET utf8 COLLATE utf8_unicode_ci...Failed! Reason: Table 'lime_defaultvalues' already exists. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Fatal error: Maximum execution time of 30 seconds exceeded in /home/xxxxxx/public_html/survey/admin/classes/core/sha256.php on line 190


The xxxxxx:s above is my databasename.
Any idea what might have gone wrong and what I could try to do to fix it?
The administrator has disabled public write access.

Re:Problem when updating from v1.71+ to 1.90+ 4 years 2 weeks ago #50122

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5331
  • Thank you received: 296
  • Karma: 249
The update script runs into a time limit. Raise max execution time at php.ini or ask your provider/admin to do so.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re:Problem when updating from v1.71+ to 1.90+ 4 years 2 weeks ago #50140

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6451
  • Thank you received: 844
  • Karma: 249
I don't know, but updating from 1.70 to 1.80 make a lot of step, maybe it's possible to do update 1.0->1.8->1.9

sourceforge.net/projects/limesurvey/files/
The administrator has disabled public write access.

Re:Problem when updating from v1.71+ to 1.90+ 4 years 2 weeks ago #50149

  • Feiyue
  • Feiyue's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
Mazi wrote:
The update script runs into a time limit. Raise max execution time at php.ini or ask your provider/admin to do so.
Yeah i saw that i got a time limit error message but I just got the feeling that the earlier error messages didn't relate to the time limit but something else?

Shnoulle wrote:
I don't know, but updating from 1.70 to 1.80 make a lot of step, maybe it's possible to do update 1.0->1.8->1.9

sourceforge.net/projects/limesurvey/files/
Sure i could try updating in steps I just didn't try it because it didn't say anything in the update instructions about this beeing a problem. In fact the headline of the update instruction is: "Upgrading from version 1.45 or later to the latest 1.xx series".

How many steps do you think are necessary, 1.71 > 1.80 > 1.90?
The administrator has disabled public write access.

Re:Problem when updating from v1.71+ to 1.90+ 4 years 2 weeks ago #50160

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6451
  • Thank you received: 844
  • Karma: 249
I don't know,

If you can up your time script more than 30 s is the best (30s is very cheap)

Maybe just 120s
The administrator has disabled public write access.

Re:Problem when updating from v1.71+ to 1.90+ 4 years 2 weeks ago #50162

  • Feiyue
  • Feiyue's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
I'll up the time limit and be back with results!
The administrator has disabled public write access.

Re:Problem when updating from v1.71+ to 1.90+ 4 years 2 weeks ago #50192

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5331
  • Thank you received: 296
  • Karma: 249
Upading from 1.71 to the latest version should be possible.

Raise limit because lots of SQL queries have to be made. Also make backups.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re:Problem when updating from v1.71+ to 1.90+ 4 years 2 weeks ago #50305

  • Feiyue
  • Feiyue's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
Mazi wrote:
Upading from 1.71 to the latest version should be possible.

Raise limit because lots of SQL queries have to be made. Also make backups.
Backups were made before I started the update so that shouldn't be a problem.

I got my webhost to extend my maximum_execution_time and that seems to have done the trick or at least help me get rid of the final time-out error message.

Now i get the same initial error messages but at least the final message is "Database has been successfully upgraded":

Current error message:
Warning: Spoiler! [ Click to expand ]


I can now log in to limesurvey and when I do a datebase health check I'm told that everyting looks fine.
Should I be worried about the initial error messages that I got?
The administrator has disabled public write access.

Re:Problem when updating from v1.71+ to 1.90+ 4 years 2 weeks ago #50327

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6451
  • Thank you received: 844
  • Karma: 249
Feiyue wrote:
Should I be worried about the initial error messages that I got?
I don't think , it's certainly due to multiple update trye :)
The administrator has disabled public write access.

Re:Problem when updating from v1.71+ to 1.90+ 4 years 2 weeks ago #50334

  • Feiyue
  • Feiyue's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
Shnoulle wrote:
I don't think , it's certainly due to multiple update trye :)
OK then I consider myself updated! :cheer:
Thanks a lot for your help guys!
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.140 seconds
Donation Image