Welcome, Guest
Username: Password: Remember me

TOPIC: Multiple choice questions not working!

Re:Multiple choice questions not working! 4 years 1 week ago #50691

  • normington
  • normington's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 13
  • Karma: 0
Definitely a server issue. I'm running LimeSurvey off my own xampp based server on pc here, rather than off the shared server that I hire. I wouldn't work out on the shared one, so I had to run it myself and it works fine!

Still haven't solved what was making it play up on the shared server, there must be a setting somewhere that's not quite right.

Thanks,
Andrew
The administrator has disabled public write access.

Re:Multiple choice questions not working! 4 years 1 week ago #50705

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5331
  • Thank you received: 296
  • Karma: 249
normington wrote:
Still haven't solved what was making it play up on the shared server, there must be a setting somewhere that's not quite right.
Please upload a phpinfo file so we can take a look at your server configuration. Just put the following code into a file named phpinfo.php and upload it to your webserver:
< ?php phpinfo(); ? >
(Delete the spaces next to </> when copying the code.)
After uploading please post the link to the file.

Is there a "mod_security" module loaded or the "suhosin" extension?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re:Multiple choice questions not working! 4 years 1 week ago #50708

  • normington
  • normington's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 13
  • Karma: 0
survey.andrewnormington.co.uk/phpinfo.php - here's a phpinfo page.

I haven't deliberately installed any extensions etc, but where do I check to make sure?

Thanks,
The administrator has disabled public write access.

Re:Multiple choice questions not working! 4 years 1 week ago #50714

Hi, i gave up as you also provides a webspace for it for free. Thats good, thanks. I hope there is no limitations as i dont understand meaning of "Your remaining responses: 25"
The administrator has disabled public write access.

Re:Multiple choice questions not working! 4 years 1 week ago #50715

  • holch
  • holch's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 2851
  • Thank you received: 359
  • Karma: 124
This means that you have 25 responses left. There is of course a limit to the free LimeService offer (as there are costs involved for the LimeService team).

If you need more than the number of responses that you get for free, you will have to purchase credits for those. Have a look at the website, as far as I recall the prices are quite reasonable.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re:Multiple choice questions not working! 4 years 1 week ago #50729

Does it means that only 25 persons can answer the questions? The one in the cpanel did not have such limits... Other hand it did not work so well.

How much for a credit for 500 responses

Peter
The administrator has disabled public write access.

Re:Multiple choice questions not working! 4 years 1 week ago #50732

  • holch
  • holch's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 2851
  • Thank you received: 359
  • Karma: 124
Well, you can either install Limesurvey on your own server and pay for the server, or you can purchase responses from LimeService. They host for you and keep the installation secure / up to date, so you don't have any hassle.

Have a look here, it is explained pretty well:
www.LimeService.com/en/pricing

Free version:
Run professional surveys for free!
You can run an unlimited number of surveys and collect up to 25 reponses per month for free - with no limits on the number of questions! At the beginning of each month period (starting with your register date) we will stock up your response account balance to 25 reponses again. Please refer to our Terms and conditions for further details.

n=500 responses are $35 according to the link above.

It is up to you. Either you install/update/host on your own server (and pay for the hosting), or you go with Limeservice (they host/update/secure/troubleshoot the installation for you).
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re:Multiple choice questions not working! 4 years 1 week ago #50743

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5331
  • Thank you received: 296
  • Karma: 249
@normington: I don't see any server setup problems but I'm no server expert. It's really hard to solve such issues, maybe using www.LimeService.com is an alternative?!
Or maybe you have another server for testing?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re:Multiple choice questions not working! 4 years 4 days ago #50830

  • peteb
  • peteb's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
Hi

I've just setup a new installation of Lime Survey and have this same problem.

The buttons on the subquestion page do not work. I've tried using ie8 ff3.6 and chrome6 and the "+" "-" and "quick add.." buttons do not function.

The error console in Firefox is showing the following error:

Error: $.cookie is not a function
Source File: survey.mysite.com/new/admin/scripts/surveytoolbar.js
Line: 22

I don't know if this error is realted or not but it does not show on demo site.

The cPanel error log is showing the following errors:
[Mon Oct 18 14:51:20 2010] [error] [client] File does not exist: /home/fr68423/public_html/survey/406.shtml, referer: survey.mysite.com/new/admin/admin.php?ac...id=16574&gid=1&qid=6
[Mon Oct 18 14:51:16 2010] [error] [client] File does not exist: /home/fr68423/public_html/survey/406.shtml, referer: survey.mysite.com/new/admin/admin.php?sid=16574&gid=1&qid=6
[Mon Oct 18 14:51:12 2010] [error] [client] File does not exist: /home/fr68423/public_html/survey/406.shtml, referer: survey.mysite.com/new/admin/admin.php

Also,on the demo site the PLUS and MINUS icons have a light blue background - on my installation they do not.

Any ideas?
Last Edit: 4 years 4 days ago by peteb.
The administrator has disabled public write access.

Re:Multiple choice questions not working! 4 years 4 days ago #50831

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5331
  • Thank you received: 296
  • Karma: 249
"mod_security" seems to be blocking the cokies.jquery file. Disable mod_security and you should be fine.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.191 seconds
Donation Image