Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: ComfortUpdate memory problem when updating from 1.78

ComfortUpdate memory problem when updating from 1.78 3 years 11 months ago #47150

  • andiliebl
  • andiliebl's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 13
  • Karma: 1
Hi all,

I try to run the comfort update, however I receive the following error message:

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 21954126 bytes) in C:\Programme\xampp\htdocs\limesurvey\admin\update\updater.php on line 413

It seems not enough memory size is allocated to the temp storage but where can I change this? Line 413 in updater.php is not about memory size.

Thanks,

Andi
Last Edit: 3 years 1 month ago by c_schmitz.
The administrator has disabled public write access.

Re:comfort update memory problem 3 years 11 months ago #47160

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6222
  • Thank you received: 791
  • Karma: 238
Update need a lot of memory.

You can change the memory allowed for php script in your xamp installation. (see xamp documentation :))
The administrator has disabled public write access.

Re:comfort update memory problem 3 years 11 months ago #47201

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5301
  • Thank you received: 291
  • Karma: 247
This can be changed at the php.ini file which configures your webserver. Restart the server after having changed this setting.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re:comfort update memory problem 3 years 11 months ago #47308

  • chrissmit
  • chrissmit's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 18
  • Karma: -1
Hi all,

I run into the same problem (the exact message is:
"Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 16314223 bytes) in /mounted-storage/home66a/sub001/sc23859-VLLI/culturematters.com/cmsurvey/admin/update/updater.php on line 413").

Updating the php.ini file, can I do that myself? or does my host have to do this?
If I can do this myself, where is that file located?

thx
Chris
Thanks,

Chris

No links in the footer please.
The administrator has disabled public write access.

Re:comfort update memory problem 3 years 11 months ago #47309

  • chrissmit
  • chrissmit's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 18
  • Karma: -1
Hi all,

A quick addition to my previous post.

These lines I can find in my .htaccess file in the root of the folder where LS resides:

php_value memory_limit 64M

php_value upload_max_filesize 128M

This should be enough, no?

would appreciate any help.

thx
Thanks,

Chris

No links in the footer please.
The administrator has disabled public write access.

Re:comfort update memory problem 3 years 11 months ago #47312

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6222
  • Thank you received: 791
  • Karma: 238
Maybe you can put :
php_value memory_limit 256M

?
The administrator has disabled public write access.

Re:comfort update memory problem 3 years 11 months ago #47318

  • chrissmit
  • chrissmit's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 18
  • Karma: -1
Hi all,

I've updated the memory size to 256M, but did not solve the issue...

any other suggestions?
Thanks,

Chris

No links in the footer please.
The administrator has disabled public write access.

Re:comfort update memory problem 3 years 11 months ago #47330

  • andiliebl
  • andiliebl's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 13
  • Karma: 1
Hi,

after changing php.ini and config-defaults.php it works at my computer. Maybe you can check the memory limit in config-defaults. Just search for memorylimit in config-defaults and check the value. If low, increase it.

Good luck
The administrator has disabled public write access.

Re:comfort update memory problem 3 years 11 months ago #47341

  • mdekker
  • mdekker's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 341
  • Thank you received: 68
  • Karma: 38
Probably you are not allowed to change the memory limit or your server does not have more memory available.

Check the phpinfo from the settings page to see if the memory limit was changed. In the limesurvey config-defaults.php is a line that sets the limit to 32mb if I am correct, don't forget to update that line too.
---
Menno Dekker
The administrator has disabled public write access.

Re:comfort update memory problem 3 years 11 months ago #47355

  • c_schmitz
  • c_schmitz's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 746
  • Thank you received: 102
  • Karma: 87
Please have a look at bugs.limesurvey.org/view.php?id=4557 for a solution and tell us if that helped.
Support us, too. Donate to the LimeSurvey project and help keep us going!
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.200 seconds
Donation Image