Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Click on Next and am redirected to main page...

Re:Click on Next and am redirected to main page... 4 years 2 months ago #44971

  • lowprofile
  • lowprofile's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 22
  • Thank you received: 1
  • Karma: 0
i dont think your problem is the same as the original posters
theirs look like a server config issue.
Yours sounds like what users also report to me, sporadic time out problems. I have a feeling they are related to conditions but this is only a guess.
it could be also caused by load, and browser problems.
Do you use apache or IIS?
The administrator has disabled public write access.

Re: Click on Next and am redirected to main page... 3 years 5 months ago #59124

  • eyetech
  • eyetech's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
I'm having the same problem as the original poster, where I will be directed to the Survey List Page when I click "next" or "submit".
However, I was able to have the original copy of the active survey work successfully by notifying me of mandatory questions, redirecting to my defined end page, and sending the results to my email.
It's since been deleted, but until today, the active survey would notify me if I hadn't filled out all of the mandatory questions (I never attempted to send complete answers), so I assumed everything was fine. Today, it started redirecting to the Survey List. I can't recall anything I've done that would cause this to fail since the last time I tested it.




I've followed the steps from this thread:

1. I turned on the debug mode. No errors are reported.

2. Here's the survey URL and $rooturl:
eyetechofgreen.com/survey/
$rooturl            =   "http://{$_SERVER['HTTP_HOST']}/survey";

3. I didn't use any conditions on the survey

4. I created a simple two question survey called "Test" that's currently active. Same problem.

5. My surveys are in two different modes: "all-in-one" and "question-by-question". Same problem.

6. No errors are listed in the server log.

7. I don't have any problems logging into the admin screen.

8. I created a phpinfo.php file. It's located at:
eyetechofgreen.com/survey/phpinfo.php




One thing to note is that the Survey List Page uses the default template. I've created a custom template for my survey, but I've used the default template for the "test" survey.
I've tested on Safari and Firefox with the same results.

Any suggestions?
Thanks in advance for your help.
The administrator has disabled public write access.

Re: Click on Next and am redirected to main page... 3 years 5 months ago #59129

  • c_schmitz
  • c_schmitz's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 789
  • Thank you received: 113
  • Karma: 92
This server is protected with the Suhosin Patch 0.9.7
Copyright (c) 2006 Hardened-PHP Project

Search the forum for the keyword 'Suhosin'
Support us, too. Donate to the LimeSurvey project and help keep us going!
The administrator has disabled public write access.
The following user(s) said Thank You: eyetech

Re: Click on Next and am redirected to main page... 3 years 5 months ago #59147

  • DenisChenu
  • DenisChenu's Avatar
  • NOW ONLINE
  • Moderator Lime
  • Posts: 6359
  • Thank you received: 824
  • Karma: 245
c_schmitz wrote:
This server is protected with the Suhosin Patch 0.9.7
Copyright (c) 2006 Hardened-PHP Project

Search the forum for the keyword 'Suhosin'
I think you have to deactivate suhosin.cookie.encrypt

I had some test to do before put this on documentation ;)
The administrator has disabled public write access.
The following user(s) said Thank You: eyetech

Re: Click on Next and am redirected to main page... 3 years 5 months ago #59350

  • eyetech
  • eyetech's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
I opened a ticket with BlueHost and asked them if/how I could deactivate suhosin.cookie.encrypt. (I also sent them the link to this thread, but I guess he didn't read it.)

Here was BlueHost's response:
Suhosin is built into PHP in our environment, and as a result it does not make changes to incoming requests but only offers logging functionality. If you can provide a description of the issue you are experiencing and detailed steps to duplicate the issue, we may be able to provide more assistance. Additionally, the Limesurvey people may be able to help further after receiving the information provided here.


I don't know if this is helpful information to add here, but I'll keep trying to get more help from them and add anything new that I find here. Please let me know if you have any more suggestions. Thanks!
Last Edit: 3 years 5 months ago by eyetech.
The administrator has disabled public write access.

Re: Click on Next and am redirected to main page... 3 years 5 months ago #59663

  • eyetech
  • eyetech's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
My problem has been resolved. Blue Host helped to find the culprit.

From Blue Host:
Your issue is likely caused by the rewrites that you have established in the root of your account, I've determined this by setting up a .htaccess file in the survey directory of the account that disables the rewrites and with this in place, the surveys function once more.
I suspect that the specific culprit is your rewrite that is removing index.(php|htm|html) from URLs since the survey should be posting to a URL which ends in an index.php and the rewrite is probably destroying the data that should be getting passed on in the POST from the form.
Please let us know if we may be of further assistance.

Hope this can help anyone else who's running into the same issue. It might also be useful to have this in the documentation somewhere if it isn't already. Thanks to everyone for their help!
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.162 seconds
Donation Image