Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Click on Next and am redirected to main page...

Click on Next and am redirected to main page... 3 years 10 months ago #43170

  • predd0
  • predd0's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
I've installed Limesurvey and created a survey on the website with questions and all.

I activated it and then went to the URL. The welcome screen works fine.

Then I clicked on the "Next" button. But I was redirected to the main page (/limesurvey/).

It seems to loop around and not actually go into the survey questions.

Anyone know how to fix? Thanks.
The administrator has disabled public write access.

Re:Click on Next and am redirected to main page... 3 years 10 months ago #43214

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5275
  • Thank you received: 289
  • Karma: 246
I. Please switch on debug mode by adding the following line to your config.php file:
$debug = '1';

Are there any additional errors reported on top of the page?

II. 1. Please post the URL you use to call the admin login.
2. What did you set for $rooturl in config.php?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re:Click on Next and am redirected to main page... 3 years 10 months ago #43274

  • predd0
  • predd0's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Thanks for the reply.

No, no errors are reported upon changing it to debug mode.

Here is the URL for admin:

www.aminoz.com.au/limesurvey/admin/admin.php
$rooturl            =   "http://{$_SERVER['HTTP_HOST']}/limesurvey";
The administrator has disabled public write access.

Re:Click on Next and am redirected to main page... 3 years 10 months ago #43312

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5275
  • Thank you received: 289
  • Karma: 246
1. Do you use conditions at this surevy?

2. Can you test a simple 2 question survey, does the problem show up?

3. Try to switch your survey mode from question-by-question to all-in-one or any other to see if we can break this down to a certain survey mode.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re:Click on Next and am redirected to main page... 3 years 10 months ago #43360

  • predd0
  • predd0's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Thanks again:

1. No conditions.

2. Tried it, no luck - same problem.

3. I changed it to all-in-one. The questions are listed properly. However I click submit and am taken back to the main page with "The following surveys are available:...". The survey results are not submitted...
The administrator has disabled public write access.

Re:Click on Next and am redirected to main page... 3 years 10 months ago #43411

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5275
  • Thank you received: 289
  • Karma: 246
1. Are there any errors listed at the servers error log?

2. Do you also have problems when logging in at the admin screen?

3. Please upload a phpinfo file so we can take a look at your server configuration. Just put the following code into a file named phpinfo.php and upload it to your webserver:
< ?php phpinfo(); ? >
(Delete the spaces next to </> when copying the code.)
After uploading please post the link to the file.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re:Click on Next and am redirected to main page... 3 years 10 months ago #43706

  • lowprofile
  • lowprofile's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 22
  • Thank you received: 1
  • Karma: 0
does you survey have endurl or end message?
you should export the survey and test if it does the same in the demo limesurvey instance
The administrator has disabled public write access.

Re:Click on Next and am redirected to main page... 3 years 10 months ago #43759

  • predd0
  • predd0's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
I have tried installing a second independent version of the script using a separately downloaded file without luck, exactly the same problem occurs. So it seems the server config could likely be the cause here.

I also imported the survey into the test demo - works fine on this site, just not on ours.

No errors on server log.

No problems logging into admin screen.

Public permission errors for the phpinfo(). What variables in particular would be of concern?
Last Edit: 3 years 10 months ago by predd0.
The administrator has disabled public write access.

Re:Click on Next and am redirected to main page... 3 years 10 months ago #43789

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5275
  • Thank you received: 289
  • Karma: 246
Please upload a phpinfo file so we can take a look at your server configuration. Just put the following code into a file named phpinfo.php and upload it to your webserver:
< ?php phpinfo(); ? >
(Delete the spaces next to </> when copying the code.)
After uploading please post the link to the file.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re:Click on Next and am redirected to main page... 3 years 9 months ago #44967

  • tobyrhodes
  • tobyrhodes's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 20
  • Thank you received: 1
  • Karma: 0
Hi - Is there any progress on solving this by anyone?

I have a live survey currently out with 200 targets. I have just had one person report this problem, although 19 incomplete out of 125 responses so far, so I wonder if more than one person has experienced this. As the survey is currently live, I cannot play around with it too much!

I have Version 1.85+ (7191)
The survey has multiple pages, uses conditions, and has the following question types:
- multiple options (2 questions, with 5 and 3 options respectively)
- Long free text
- Array (flexible labels)
- List (dropdown)
- yes/no
- List (radio)
- List with comment

The non completed ones seem to be randomly spread through the responses, and some may well be genuine "non-completers".

Any thoughts?
Thanks in advance
Toby
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.348 seconds
Donation Image