Welcome, Guest
Username: Password: Remember me

TOPIC: Installation problem

Re:Installation problem 4 years 5 months ago #39015

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5324
  • Thank you received: 294
  • Karma: 249
The configuration looks a little strange but I can't see anything that might block Limesurvey from running fine.

I have no idea what else might be wrong. We offer advanced, paid support so if you want me to take a deeper look please drop me a note at marcel.minke(at)limesurvey.org and provide FTP login data and a short problem description so I can check the server config etc.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re:Installation problem 3 years 10 months ago #51078

  • hama
  • hama's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
hi mazi,

did you find a solution via 'paid support' and are you willing to write it down here? For I have the same problem and can't find a (working) solution for it in this forum:
Warning: require(xxxxxxxxxxx/limesurvey/version.php) [function.require]: failed to open stream: No such file or directory in xxxxxxxxxxxx/public_html/limesurvey/common.php on line 22
 
Fatal error: require() [function.require]: Failed opening required 'xxxxxxx/limesurvey/version.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in xxxxxxxxxxx/public_html/limesurvey/common.php on line 22

thanks,
hama
The administrator has disabled public write access.

Re:Installation problem 3 years 10 months ago #51143

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6276
  • Thank you received: 801
  • Karma: 241
Trye to use $rootdir variable u=in config.php, maybe your server don't send the real root dir.

Did you have a file ./version.php in your installation, and what is the web-server user right in this file.

And put a phpinfo file too., use $rootdir = DOCUMENT_ROOT of phpinfo.
The administrator has disabled public write access.

Re:Installation problem 3 years 10 months ago #51399

  • hama
  • hama's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
but the directory in the error message is correct. can the $rootdir be the problem anyway?

i have a version.php, but it is only 3 lines long.
The administrator has disabled public write access.

Re:Installation problem 3 years 10 months ago #51409

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6276
  • Thank you received: 801
  • Karma: 241
I think right in the php file can be bad then.

chmod for GNU/Linux
The administrator has disabled public write access.

Re:Installation problem 3 years 10 months ago #51582

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5324
  • Thank you received: 294
  • Karma: 249
hama wrote:
hi mazi,

did you find a solution via 'paid support' and are you willing to write it down here?
There was no request for paid support.

If you need help please answer the questions in this thread, too and I will try to have a look.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re:Installation problem 3 years 10 months ago #51605

  • hama
  • hama's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
hi mazi & shnoulle,

@shnoulle: what do you mean with "chmod for GNU/Linux"? sorry, but i'm a complete beginner.
@mazi: what questions do you mean?

1. in debug mode the same errors occur
2. my config setting are: $rooturl = "http://{$_SERVER}/limesurvey" & $rootdir = dirname(_FILE_);
3. if you need the phpinfo, here it is.

thanks for your help,

hama
The administrator has disabled public write access.

Re:Installation problem 3 years 10 months ago #51610

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5324
  • Thank you received: 294
  • Karma: 249
hama:

1. Please re-upload all files in binary mode of your FTP program.

2. Please quote all error messages.

3. Check if mod_security is enabled at your system.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re:Installation problem 3 years 10 months ago #51617

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6276
  • Thank you received: 801
  • Karma: 241
http://tuschefueller.com/limesurvey/
Give me an 404 error.

Where is exactly your limesurvey installation, this line :
$rooturl = "http://{$_SERVER['HTTP_HOST']}/limesurvey";
is bad.
The administrator has disabled public write access.

Re:Installation problem 3 years 9 months ago #51701

  • hama
  • hama's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
@mazi:

1. i re-uploaded all files in binary mode

2. the error messages were "admin/listcolumn.php" & "admin/scripts/fckeditor.266/editor/skins/silver/images/toolbar.buttonarrow.gif" already exist (as a 0kB file, I replaced it) --> should be no problem

3. where do i check mod_security? and should it be or not?

@shnoulle:
tuschefueller.com doesn't work because i moved it to another domain for reuploading, server remains the same. what's bad about that line?

[edit] for the record: the error messages are still the same [/edit]
Last Edit: 3 years 9 months ago by hama.
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.295 seconds
Donation Image