Welcome, Guest
Username: Password: Remember me

TOPIC: Passthru

Passthru 7 months 1 week ago #106566

  • ahaehnch
  • ahaehnch's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
Hallo zusammen,

ich arbeite mit folgender Limesurvey Version: 2.05+ Build 140212.

Da meine Umfrage mit Hilfe eines Marktforschungsinstituts durchgeführt werden soll, muss eine ID mitgegeben werden können, die dann nach dem Abschluss der Umfrage wieder dem Marktforschungsinstitut übergeben wird.
Ich habe gelesen, dass dies mit passthru und dem automatischen Aufruf der End-URL möglich sein soll.

Meine End-URL sieht nun folgendermaßen aus: www.blabla.de/complete.aspx?passthru={PASSTHRU:passthru}

Ich habe auch unter Panel-Integration den Parameter passthru definiert.

Wenn ich jetzt allerdings die ID im Hintergrund mitlaufen lassen will, so geht dies nur, wenn ich bei Limesurvey angemeldet bin und die Umfrage dort ausführen lasse. Der Link sieht dann bspw. so aus: www.blabla.de/index.php/survey/index/sid...ng/de?passthru=12345

Wenn ich aber direkt über den Link gehe, welcher dann folgendermaßen aussieht:
www.blabla.de/index.php/111/lang-de?passthru=12345, so wird die Nummer am Ende nicht wieder ausgegeben.

Hat jemand vielleicht eine Idee, woran das liegen kann?
The administrator has disabled public write access.

Passthru 7 months 1 week ago #106567

  • Ben_V
  • Ben_V's Avatar
  • OFFLINE
  • Platinum Lime
  • Posts: 1125
  • Thank you received: 259
  • Karma: 79
hi,

have a look at this previous post .. I hope it solves your problem :)
.
Benoît

goo.gl/Bw5iM => Recherche GG dans le forum français (remplacer "exemple" dans la barre de recherche)
goo.gl/WX8PH => GG search for english forum (Replace "example" in the search bar)
goo.gl/IxiGu => Búsqueda en el foro en español (Cambiar "ejemplo" en la barra de...
The administrator has disabled public write access.

Passthru 7 months 1 week ago #106568

  • ahaehnch
  • ahaehnch's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
Thank you for your quick answer. But unfortunately this does not solve my problem. In the manuel as well the long link is mentioned. But I am wondering why it does work for that link but not for the one limesurvey ascribes to the survey (the shorter link in my previous post).
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.098 seconds
Donation Image