Welcome, Guest
Username: Password: Remember me

TOPIC: Problem nach Import Fragen/ -gruppen bei Kopieren Umfrage Failed to insert data

Problem nach Import Fragen/ -gruppen bei Kopieren Umfrage Failed to insert data 9 months 3 days ago #102549

  • goldfisch
  • goldfisch's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 1
  • Karma: 0
Hallo und Hilfe :( ,

ich habe heute wiedermal eine neue lange Umfrage in Limesurvey (Version 1.92) gemacht, dabei bei den meisten Fragen eine alte Umfrage kopiert und die Fragencodes umgeändert, etliche Fragen + Fragengruppen ganz rausglöscht, und Fragen und teilweise Fragengruppen aus zwei anderen Umfragen importiert. Und natürlich Filter wenn nötig neu gesetzt.
Die neue Umfrage wollte ich nun kopieren. Es kommt folgende Fehlermeldung:

Failed to insert data
INSERT INTO lime_questions ( PARENT_QID, SID, GID, TYPE, TITLE, QUESTION, PREG, HELP, OTHER, MANDATORY, QUESTION_ORDER, LANGUAGE, SCALE_ID, SAME_DEFAULT, RELEVANCE ) VALUES ( 65123, 33218, null, 'Q', '1', 'Name (bei mehreren mit Komma getrennt)', '', '', 'N', '', 6, 'de', 0, 0, '' )
Column 'gid' cannot be null

Wie kann ich diese Fehlermeldung interpretieren? Sind nur einzelne Fragen bzw. Fragengruppen betroffen, und wann ja, welche? Sehe ich das richtig, dass beim Import einiger Fragen möglicherweise mir nicht ersichtliche Informationen nicht automatisch angepasst wurden?

Habe versucht die angegebenen Infos zuzuordnen, kann aber nicht mal die Fragen 65123 oder 33218 finden.
In der Logikdatei sieht alles okay aus. Ansonsten bin ich kein Crack in Limesurvey / Programmierung.

Wäre sehr froh um hilfreiche Infos!
Danke!!
Last Edit: 9 months 3 days ago by goldfisch.
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.094 seconds
Donation Image