Welcome, Guest
Username: Password: Remember me

TOPIC: Bounce Back -> X-Header fehlt!

Bounce Back -> X-Header fehlt! 2 years 11 months ago #64758

  • simon_d
  • simon_d's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 47
  • Karma: 0
Hallo, damit es nicht zu unübersichtlich wird,
habe ich mal einen neuen Thread aufgemacht
(ist ja auch eigentlich ein anderes Problem).

Also - ich versende Emails an an nicht existente Mailadressen (oder Mailkonten) allerdings an existierende Mailserver.

bsp : This email address is being protected from spambots. You need JavaScript enabled to view it. (ich glaub nicht das es den gibt)
dann müsste ja rein theoretisch im Header der Mail die SID als X-Header wert stehen...

Jetzt habe ich den Verdacht gehabt das der Postfix Mailserver einfach mal den Header der BounceBack Mails verändert, habe aber gemerkt das scheinbar LimeSurvey da irgendwie Fehler macht ! ...

eigentlich wollte ich nicht alles posten, aber hier könnte es Hilfreich sein...

(MAIL _1)Also - eine Mail an mich selbst (mailadr. existiert und Mail kommt an und man findet den X-Header.

(MAIL _2)Eine Mail an Web.de, allerdings an ein nichtexistierendes Benutzerkonto,
wird von "meinem" Mailserver an Web.de geschickt, kommt zurück, und mein Mailserver macht den "Fehler" das es nicht an meine Adresse zurückgesandt wird, obwohl ich der Absender bin, sondern an die MailAdr. der Buchhaltung, die auf einer ganz anderen domain gehostet ist. Das ist wohl eher eine Mailserver(Postfix) fehl-konfiguration.

Nichtsdesdotrotz enthält die dort ankommende Mail, die ursprünglich von mir bzw. LimeSurvey versendete EMail im Anhang und somit auch den ursprünglich verwendeten Mail-Header -> wo eben die besagten X-Header einträge fehlen !!

Und jetzt bin ich verwirrt, weil es für mich so aussieht als wenn LimeSurvey die dort "vergessen" hat.

Und solange die fehlen bringt auch eine richtige Konfiguraton von Postfix nix, denn dann kämen die mails zwar zurück zu meinem account, aber die X-Header mit LimeSurvey Informationen würden weiterhin fehlen.

Die Header der Mails habe ich mal hier reinkopiert,
ich danke schon mal für alle die sich mein Problem hier überhaupt durchlesen,
meinen Namen habe ich allerdings in my_Name geändert und die Domain meines Arbeitgebers in my_WorkPlace.

Gruß
Simon


######################### MAIL _1 #############################
Return-Path: <This email address is being protected from spambots. You need JavaScript enabled to view it.>
Delivery-Date: Thu, 18 Aug 2011 12:26:44 +0200
Received: from www39.estugo.de (www39.estugo.de [80.246.58.98])
by mx.kundenserver.de (node=mxbap1) with ESMTP (Nemesis)
id 0Lr0fj-1RYIi72Axn-00eG56 for my_Name@my_WorkPlace.de; Thu, 18 Aug 2011 12:26:44 +0200
Received: by www39.estugo.de (Postfix, from userid 33)
id 602A419591A5; Thu, 18 Aug 2011 12:26:44 +0200 (CEST)
To: testsimon benutzer <my_Name@my_WorkPlace.de>
Subject: =?utf-8?B?WEhlYWRlciB2b3JoYW5kZW4gd2VubiBNYWlsIGFua29tbXQ/?=
Date: Thu, 18 Aug 2011 12:26:44 +0200
From: My_WorkPlace <my_Name@my_WorkPlace.de>
Reply-to: My_WorkPlace <my_Name@my_WorkPlace.de>
Message-ID: <4fdef30e356f7025b25aff33c4de1827@my_WorkPlace-befragung.de>
X-Priority: 3
X-Mailer: PHPMailer 5.1 (phpmailer.sourceforge.net)
X-surveyid: 42592
X-tokenid: 5wtyd3dtemxafuq
X-Surveymailer: My_WorkPlace Befragung Emailer (LimeSurvey.sourceforge.net)
MIME-Version: 1.0
Content-Type: multipart/alternative;
boundary="b1_4fdef30e356f7025b25aff33c4de1827"
X-UI-Junk: AutoMaybeJunk +0 ();
V01:H2dhdvcm:pz8+wzxKeSvSC09u6d+WIHIQW6A57RNxKbm9fiXNldSFvgPAFec
NtLzqIz7GfWMcA1I4AE0JkJe/Gm+aKktvmkjWJFCB2O5qOfjsLhPM5tU0GTOGQ1l
8Ih8fz+LUX7gy6KzniXI3RSUoUtA79Zc2j+hFVHlnHTdZinfyZDv5v70tSTLtygR
goFZ3HDc6bKTPShM4CQ7QQzUPFps2uOv7vQghXd34NL3GtURNzuQ3lu6KKgY9OJk
1cQYfQqVMaIXkhlm7aZ/W4tecP8QZRijegzDV9nfZjbbefE4UWGSjtYo=
Envelope-To: my_Name@my_WorkPlace.de

########################################################################




######################### MAIL _2 #############################
Received: by www39.estugo.de (Postfix, from userid 33)
id E38FC19591A5; Thu, 18 Aug 2011 11:05:37 +0200 (CEST)
Reply-To: "My_WorkPlace" <my_Name@my_WorkPlace.de>
From: "My_WorkPlace" <my_Name@my_WorkPlace.de>
To: "hugo ampahr" <This email address is being protected from spambots. You need JavaScript enabled to view it.>
Subject: Erinnerung an die Teilnahme an einer Umfrage
Date: Thu, 18 Aug 2011 11:05:37 +0200
Message-ID: <1b71d278dd7b51861694d9a76b78f38c@my_WorkPlace-befragung.de>
MIME-Version: 1.0
Content-Type: multipart/alternative;
boundary="----=_NextPart_000_0046_01CC5D9A.5E6B5160"
X-Mailer: PHPMailer 5.1 (phpmailer.sourceforge.net)
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.6109
Thread-Index: Acxdhf6Tym9O6889SFGXJyncYf0KOw==
The administrator has disabled public write access.

Re: Bounce Back -> X-Header fehlt! 2 years 11 months ago #64759

  • c_schmitz
  • c_schmitz's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 748
  • Thank you received: 103
  • Karma: 87
Das zweite ist ein Reminder, warum hier keine Einladung?
Support us, too. Donate to the LimeSurvey project and help keep us going!
The administrator has disabled public write access.

Aw: Re: Bounce Back -> X-Header fehlt! 2 years 11 months ago #64760

  • simon_d
  • simon_d's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 47
  • Karma: 0
oh!
ich habe schon soo viele EMails hin und hergeschickt...
da ist das unentdeckt!!

Sicher liegt es schon daran, das bei einem Reminder die X-Header garnich versendet werden, da man davon ausgehen kann, das die EmailAdr. schon verifiziert ist ...

Danke schonmal - dann test ich das gleich nochmal..

gruß
simon
The administrator has disabled public write access.

Aw: Re: Bounce Back -> X-Header fehlt! 2 years 11 months ago #64908

  • simon_d
  • simon_d's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 47
  • Karma: 0
Hallo, mittlerweile verschicke ich dann auch Einladungen, und nicht bloß "reminder" daher sind die X-Header vorhanden.

Aber ist das Normal?
das in dem Mail-Header den ich hier gleich einfüge ganz oben als erstes (bei Return-Path) der Benutzername von "mir" steht? web39 ist nämlich der Benutzername, und .. wenn der ReturnPath benutzt wird um dorthin die Antwort zu schicken, dann kommt die bei der Kontaktadresse an die bei der Server Hosting Firma hinterlegt wurde -> also.. bei unserer Buchhaltung :)

Soviel zu der Erklärung des seltsamen Verhaltens.

Mail Clients machen das ja richtig, wenn man den Antworten Button bekommt, bekomm ich eine Mail, nur der Mailserver, macht das irgendwie nicht richtig.
Jetzt ist die Frage ob das auch an der Konfiguration des Mailservers liegt,
oder daran, das LimeSurvey dort eben folgendes im Return-Path stehen hat.

Danke fürs Lesen schonmal!

############################################

Return-Path: <This email address is being protected from spambots. You need JavaScript enabled to view it.>
Delivery-Date: Tue, 23 Aug 2011 13:07:16 +0200
Received: from www39.estugo.de (www39.estugo.de [80.246.58.98])
by mx.kundenserver.de (node=mxbap0) with ESMTP (Nemesis)
id 0Mdcx2-1QdCY42Uzk-00PJzl for This email address is being protected from spambots. You need JavaScript enabled to view it.; Tue, 23 Aug 2011 13:07:16 +0200
Received: by www39.estugo.de (Postfix, from userid 33)
id 7119D1958E46; Tue, 23 Aug 2011 13:07:16 +0200 (CEST)
To: test4 s_camino <This email address is being protected from spambots. You need JavaScript enabled to view it.>
Subject: =?utf-8?B?Ym91bmNlIGJpZ2dlZGllIGJvdW5jZSBib3VuY2UgLi4uIGZlaGxlciBlbWFpbHMgPyBoYWxsb29vID8gVGVzdEVtYWlsISE=?=
Date: Tue, 23 Aug 2011 13:07:16 +0200
From: Camino <This email address is being protected from spambots. You need JavaScript enabled to view it.>
Reply-to: Camino <This email address is being protected from spambots. You need JavaScript enabled to view it.>
Message-ID: <This email address is being protected from spambots. You need JavaScript enabled to view it.>
X-Priority: 3
X-Mailer: PHPMailer 5.1 (phpmailer.sourceforge.net)
X-surveyid: 42592
X-tokenid: 5wtyd3dtemxafuq
X-Surveymailer: Camino Befragung Emailer (LimeSurvey.sourceforge.net)
MIME-Version: 1.0
Content-Type: multipart/alternative;
boundary="b1_17b94f2e51e771430720dcd6a8f226e4"
X-UI-Junk: AutoMaybeJunk +26 (SPA);
V01:aPsfI1hY:R8pKJ+adm8OYoqncwsnV1ge+D+WxMwcmiIYhaBz+57RNBkSh+Gd
BySGsNHzKT09hRPGDzfjyZYNYmklFoVCAVjSSAaG3mzhEiGSKVCQr2hF1nfhh1vn
ex9TR1aMph0O/bQIZEY7j/mey26BRKDmj+wOPKPEUe0ZQMPBc69Sdat8H+mcrFQO
krtO0wP+QqBTcXwrugKfz6dhuJqjkcmWl1uuiaVcTMMK5/KbeRSPoScYAn4ytDix
ZoVQKssiIzMS2stBlW4JEP97D6vDTi5HBVnyJgFcaud+TaGCgSnyWLijaQyYwkNK
B8J7OWRCoyat7
Envelope-To: This email address is being protected from spambots. You need JavaScript enabled to view it.

############################################


Gruß
Simon
The administrator has disabled public write access.

Aw: Re: Bounce Back -> X-Header fehlt! 2 years 11 months ago #64945

  • simon_d
  • simon_d's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 47
  • Karma: 0
okay... danke nochmal, hat sich erledigt..
hing mit den "nicht routbaren Mails" zusammen,
also auch den Fehlermails die für die BounceMail funktion genutzt werden.

gruß
simon
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.148 seconds
Donation Image