Welcome, Guest
Username: Password: Remember me

TOPIC: Fehlermeldung session has expired trotz Aktualisierung auf 1.91+

Fehlermeldung session has expired trotz Aktualisierung auf 1.91+ 3 years 5 months ago #61641

  • loewwolf
  • loewwolf's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
Ich wollte eine Umfrage erstellen und beim Testen ist mir aufgefallen, dass ich immer bei einer bestimmten Fragen die Fehlermeldung "ERROR
We are sorry but your session has expired."
Diese Fehlermeldung erhalte ich auch nach der Aktualisierung von LimeSurvey auf 1.91+.

Die (zugegebenermaßen komplexere) Umfrage kann hier getestet werden:
Einfach immer auf Weiter klicken und im Normalfall passiert es bei der Frage 3_10_1.

www.loewi.net/limesurvey/index.php?sid=97521&lang=de

Anbei noch ein paar Details zu meinem Webspace:
PHP Version: 5.2.16
Lime Survey Version: Version 1.91 Build 10120
MYSQL Server Version: 5.1.51
Webserver: Apache/2.2.3 (CentOS)

Die vollständige PHP-Info kann bei Bedarf auch geliefert werden.
Kann mein Provider vielleicht noch an dem einen oder anderen Schäubchen drehen? Oder liegt das Problem im Limesurvey? Wie schaff ich es, dass ich die Umfrage ohne Fehler zum Laufen bringe?

Vielen Dank für eure Hilfe im Voraus!

LG
Löwi
The administrator has disabled public write access.

Aw: Fehlermeldung session has expired trotz Aktualisierung auf 1.91+ 3 years 4 months ago #61647

  • loewwolf
  • loewwolf's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
Hab jetzt die Umfrage noch ein wenig getestet und ein wenig herumexperimentiert.
Wenn ich die Bedingungen rauswerfe, dann tritt die Fehlermeldung mit abgelaufenen Session erst später auf.

Ich bin ratlos...
Vielleicht hat von euch jemand einen guten Hinweis was ich, der Provider oder sonst noch wer machen könnte...

Vielen Dank im Voraus!

LG
Löwi
The administrator has disabled public write access.

Re: Aw: Fehlermeldung session has expired trotz Aktualisierung auf 1.91+ 3 years 4 months ago #61883

Konntest Du das Problem lösen?
ICh habe ein Ähnliches Problem, das ich durch erneute Upgrades nicht in den Griff bekomme. Auch die php-ini einstellungen bewirken nix.
The administrator has disabled public write access.

Aw: Re: Aw: Fehlermeldung session has expired trotz Aktualisierung auf 1.91+ 3 years 4 months ago #62000

Eine Änderung in der config.php löst dieses Problem, das nur auftritt, wenn die limesurvey-Installation im root-verzeichnis eines Webauftritts ist:

in der Zeile 39 muss das abschliessende "/" gelöscht werden:
$rooturl = "http://{$_SERVER}/"

also:
$rooturl = "http://{$_SERVER}"

Dann klappt's auch mit dem Nachbarn ;)
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.107 seconds
Donation Image