Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Update

Update 3 years 9 months ago #53978

  • Bluesky17
  • Bluesky17's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 21
  • Karma: 0
Hallo an Alle,
ich schaffe es nicht mit dem Update. Ich erhalte diese Meldung:
Was muss ich tun, wo muss ich suchen für die Dateiberechtigungen?


""Versionsdatei ist nicht schreibbar (/var/kunden/webs/..../www...../limesurvey/version.php). Bitte setzen Sie entsprechende Dateiberechtigungen.""


Vielen Dank für Hilfe!
The administrator has disabled public write access.

Re:Update 3 years 9 months ago #53983

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2719
  • Thank you received: 331
  • Karma: 121
Du musst per FTP-Programm die Datei version.php schreibbar machen. Normalerweise hat dein FTP-Programm so eine Option (heisst meist chmod).

Einfach mal nachsehen, welche Rechte da im Moment gesetzt sind.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re:Update 3 years 9 months ago #53990

  • Bluesky17
  • Bluesky17's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 21
  • Karma: 0
Ich habe eine datei gefunden, die heißt changelong.txt, in der steht chmod, da kann ich aber überhaupt nichts ändern.
The administrator has disabled public write access.

Re:Update 3 years 9 months ago #54000

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5325
  • Thank you received: 296
  • Karma: 249
Versuch mal in deinem FTP-Programm einen Rechtsklick auf die Datei auf dem Server, meistens kannst du dort dann die Rechte setzen (auf 777).

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re:Update 3 years 9 months ago #54009

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2719
  • Thank you received: 331
  • Karma: 121
Du musst doch für andere Ordner während der Installation auch die Rechte gesetzt haben, sonst funktioniert LS doch normalerweise gar nicht. Genaus setzt du die Rechte für die version.php. Mazi hat es ja ganz gut erklärt. Vermutlich musst du per Rechtsklick das Menü öffnen und da gibt es dann normalerweise sowas wie Rechte, CHMOD, etc., je nach FTP Programm.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re:Update 3 years 9 months ago #54011

  • Bluesky17
  • Bluesky17's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 21
  • Karma: 0
ich habe das programm nicht selber installiert und aufgebaut, ich muss jetzt damit arbeiten und alles herrichten. blicke es aber wenig. Ich habe im FTP programm das chmod gefunden, und auf schreiben "write" gesetzt. jetzt geht bei mir gar nichts mehr.
Brauche dringend Hilfe
The administrator has disabled public write access.

Re:Update 3 years 9 months ago #54012

  • Bluesky17
  • Bluesky17's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 21
  • Karma: 0
Das Brogramm reagiert nicht mehr und für das System selber erhalte ich 403 Forbidden
The administrator has disabled public write access.

Re:Update 3 years 9 months ago #54013

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2719
  • Thank you received: 331
  • Karma: 121
Welches Programm reagiert nicht mehr? Das FTP-Programm??
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re:Update 3 years 9 months ago #54014

  • Bluesky17
  • Bluesky17's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 21
  • Karma: 0
Forbidden

You don't have permission to access /limesurvey/admin/admin.php on this server.

Es sind alle Dateien gesperrt und ich komme nicht mehr in das Programm
The administrator has disabled public write access.

Re:Update 3 years 9 months ago #54015

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2719
  • Thank you received: 331
  • Karma: 121
Dann hast du vermutlich die Permissions nicht für die Datei version.php sondern für die ganze Installation gesetzt. Das sollte man natürlich nicht tun, wenn man nicht genau weiss, was man da macht.

Hast du keinen ITler der sich bei euch um den Server kümmert? Der muss sich mit sowas auskennen.

Bei mir sehen die Rechte für die version.php (unter FileZilla) so aus:

permissions.png


Damit funktioniert das Update ohne Probleme.

Allerdings, wenn du jetzt nicht nur die Rechte für die version.php geändert haben solltest, sondern für andere Dateien auch, dann hilft dir das alleinige ändern der Rechte der version.php natürlich nichts. Aber versuch es doch erstmal mit diesen Einstellungen bei der version.php, vielleicht war es das ja schon.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.131 seconds
Donation Image