Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Deux problèmes: Enregistrement des réponses / Exportation vers SPSS

Deux problèmes: Enregistrement des réponses / Exportation vers SPSS 2 months 1 week ago #110708

Bonjour à tous,

J'en suis rendu aux tests avant d'envoyer mon sondage. Je rencontre toutefois deux problèmes.

J'ai une version francophone et une autre anglophone de mon questionnaire. La version francophone (originale) fonctionne très bien quand je me l'envoie et que j'y réponds. Seul détail, lorsque je clic sur le lien dans le courriel tout juste après l'avoir reçu, j'ai les blocs de texte avec le nom des sections mais les questions sont absentes sur la page. Quand j'y retourne 30-60 minutes plus tard, je peux le remplir... Mais bon. Tout s'enregistre, j'ai la confirmation à la fin et le courriel, tout va bien.

Par contre, la version anglophone ne fonctionne pas. Je peux y répondre mais quand je clic sur ''Send'' à la fin, j'obtiens un message d'erreur (voir l'image attachée, c'est ce que je vois quand je fais ''Send'') et les réponses ne s'enregistrent pas. Je reçois également un courriel en tant qu'administrateur me disant que les réponses d'un répondant n'ont pas pu être enregistrées... Que faire?! C'est exactement le même questionnaire à la seule différence que la version anglaise est la version traduite!

Autre problème. Je veux maintenant tester la base de données SPSS. La procédure affichée ne fonctionne simplement pas pour moi. J'ai demandé à deux collègues qui ne comprennent pas plus. Je télécharge le fichier syntaxe ainsi que le fichier de données. J'ouvre la syntaxe et je vais modifier la ligne où se trouve le nom du fichier de données. La procédure indique de modifier la 4e ligne. En bref, voici le début de mon fichier de syntaxe non-modifié:

*$Rev: 121017 $ all 2.
SET UNICODE=ON.
SHOW LOCALE.
PRESERVE LOCALE.
SET LOCALE='en_UK'.
GET DATA
/TYPE=TXT
/FILE='survey_729255_SPSS_data_file.dat'
/DELCASE=LINE
/DELIMITERS=","
/QUALIFIER="'"
/ARRANGEMENT=DELIMITED
/FIRSTCASE=1
/IMPORTCASE=ALL
/VARIABLES=
V1 A100

Mon fichier se trouve à l'endroit nommé : /Users/Olivier/Downloads

Il faut donc que je modifie la ligne nommée PRESERVE LOCALE pour écrire PRESERVE /Users/Olivier/Downloads?

Peu importe ce que je fais, car j'ai même essayé de modifier la ligne où se trouve le nom du fichier de données, j'obtiens des erreurs. En version Excel j'ai des données mais c'est dans SPSS que je les veux...

Merci infiniment en avance pour votre aide. Je suis découragé ce matin (on est encore le matin au Québec!)!
Attachments:
Last Edit: 2 months 1 week ago by OliverJones. Reason: Ajout d'information (questionnaire franco)
The administrator has disabled public write access.

Deux problèmes: Enregistrement des réponses / Exportation vers SPSS 2 months 1 week ago #110713

  • Ben_V
  • Ben_V's Avatar
  • OFFLINE
  • Platinum Lime
  • Posts: 1079
  • Thank you received: 239
  • Karma: 76
Salut,

je te réponds sur la partie qui concerne SPSS,

1) La seule ligne qu'il faut normalement éditer dans le fichier de syntaxe est:
/FILE='survey_729255_SPSS_data_file.dat'

2) Si tu n'arrives toujours pas à importer tes données, fais un export .csv et importe le dans SPSS qui accepte aussi ce format (ainsi que beaucoup d'autres)
.
Benoît

goo.gl/Bw5iM => Recherche GG dans le forum français (remplacer "exemple" dans la barre de recherche)
goo.gl/WX8PH => GG search for english forum (Replace "example" in the search bar)
goo.gl/IxiGu => Búsqueda en el foro en español (Cambiar "ejemplo" en la barra de...
The administrator has disabled public write access.

Deux problèmes: Enregistrement des réponses / Exportation vers SPSS 2 months 1 week ago #110715

C'est bien cette ligne au départ que je croyais qu'il fallait modifier mais ça ne fonctionnait pas plus. Il générait des messages d'erreur en tentant d'importer les données. Pour être certain que ma modification était correcte, la ligne au complet devrait bien être:

/FILE='/Users/Olivier/Downloads/survey_729255_SPSS_data_file.dat'

Sinon je vais essayer d'exporter le CSV. C'est une bonne idée, merci! Sinon j'ai vu qu'on peut aussi importer un fichier Excel. J'aurais des modifications à faire par après mais bon, tant que je peux avoir une matrice SPSS en bout de ligne...

Le plus urgent pour moi est la partie sur les questionnaires en anglais avec l'erreur qui est générée. Les 2/3 de mes répondants sont anglophones alors ça pose problème ce bug...
The administrator has disabled public write access.

Deux problèmes: Enregistrement des réponses / Exportation vers SPSS 2 months 1 week ago #110716

Je crois avoir une idée d'où provient le bug avec la version anglaise mais je ne comprends pas comment régler tout ça...

Vous pourrez regarder les deux images. La première est la version francophone (ne tenez pas compte du message qui dit que la question est obligatoire, j'ai changé de langue sur la même page pour faire mes images et ce message est apparu). Il y a une section commentaires à la fin du premier bloc de questions.

Limesurvey_CommentairesFR.png


La deuxième est la même section du questionnaire mais dans la version anglophone. On peut noter qu'il y a étrangement deux blocs de texte supplémentaires. Ces blocs ne sont pas dans la version francophone. J'ai tenté de supprimer la question et de la refaire mais ça revient pareil. Même qu'avant de supprimer/refaire la question, je n'avais qu'un seul bloc de texte en trop.

Limesurvey_CommentairesEN.png


Je n'y comprends absolument rien!...
The administrator has disabled public write access.

Deux problèmes: Enregistrement des réponses / Exportation vers SPSS 2 months 1 week ago #110730

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6314
  • Thank you received: 809
  • Karma: 241
Salut,

Comment as tu effectué ta version anglaise ?
Sur quelle version (et build number) de LimeSurvey ?

Denis
The administrator has disabled public write access.

Deux problèmes: Enregistrement des réponses / Exportation vers SPSS 2 months 1 week ago #110745

Pour la création de la version anglaise j'y ai été pour la façon simple. J'ai ajouté une langue dans les paramètres afin que cela ajoute un onglet à chaque section de création du questionnaire. J'avais donc un anglais français et anglais. J'ai simplement tout traduit pour l'inclure dans le même questionnaire mais en version anglaise. Je me dis alors que comme c'est le même questionnaire à la base, ce n'est pas logique que dans la version anglaise, qui est simplement une copie de la version française, quelque chose comme cela diffère tant. Et si le problème venait de la base SQL, je ne devrais pas être en mesure d'enregistrer les questionnaires en français.

J'ai essayé de changer le style du questionnaire, au cas où le problème aurait été dans le CSS mais ça n'a rien changé. Tout comme modifier le style de la réponse (passer de zone de texte long à très long ou court). Les paramètres de la réponse sont les mêmes que pour les autres boîtes de texte du questionnaire (j'ai deux autres questions de type ''commentaires'' avec lesquelles je n'ai aucun problème).

J'ai également essayé d'aller copier une autre question ''commentaires'', de la déplacer à l'endroit de celle qui cause problème et de la modifier afin que le texte soit identique et ensuite supprimer l'originale problématique, mais sans succès. Le problème revient à nouveau.

En ce qui concerne la version et le build number, ça me dit ceci: Version 2.05 et Build 140116.

Merci!
The administrator has disabled public write access.

Deux problèmes: Enregistrement des réponses / Exportation vers SPSS 2 months 1 week ago #110746

Pour la traduction vers l'anglais je n'ai peut-être pas été clair. Je n'ai pas utilisé la traduction offerte par LimeSurvey. J'ai embauché une traductrice (à cause des exigences d'avoir une traduction dite ''officielle'') qui s'est occupé de traduire mes courriels, les textes et les questions. J'ai ensuite copié/collé la traduction dans les onglets ''Anglais'' appropriés.
The administrator has disabled public write access.

Deux problèmes: Enregistrement des réponses / Exportation vers SPSS 2 months 1 week ago #110747

On dirait que le problème ''bouge''. En faisait des tests, je remarque que la boîte de texte est maintenant au milieu des deux qui sortent de nulle part... Sachant cela, peut-être que ça peut aider? Moi ça me laisse réellement très perplexe!

Limesurvey_CommentairesEN_2.jpg
The administrator has disabled public write access.

Deux problèmes: Enregistrement des réponses / Exportation vers SPSS 2 months 1 week ago #110750

Autres informations pouvant être pertinentes à la résolution de ce fastidieux bug.

Quand j'ouvre mon questionnaire en français et que je le change en anglais par la fonction au haut de la page, il semble parfait. Je le ferme, l'ouvre à nouveau mais cette fois en anglais directement et le problème revient. Je le change en français avec l'option et il a l'air beau, sans aucun bug. Je le rechange encore en anglais, encore avec l'option au haut de la page, le bug semble revenu.

J'ai aussi fait une copie de mon questionnaire afin de faire plus de tests. Comme j'avais une 10aine de questions conditionnelles, je les ai toutes supprimées, au cas. Le problème était toujours là. J'ai supprimé la question commentaires ainsi que la question visible dans mes images en exemple (avec l'échelle de mesure en %) vu que c'était la seule à avoir une échelle de mesure de ce type. Même après tout cela, le problème persiste.
The administrator has disabled public write access.

Deux problèmes: Enregistrement des réponses / Exportation vers SPSS 2 months 1 week ago #110755

J'ai décidé que demain j'allais recréer un nouveau questionnaire et recommencer. Je récupérerai les étiquettes de questions et échelles de mesure que j'ai sauvegardées, ce qui me sauvera du temps. J'ai assez cherché pour ça!

En espérant ne pas revivre ce bug avec un questionnaire tout neuf! hehe!
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: Nickko
Time to create page: 0.239 seconds
Donation Image