Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Version 2.00+ : problème avec les questions conditionnelles

Version 2.00+ : problème avec les questions conditionnelles 1 year 2 weeks ago #100502

  • pocquet
  • pocquet's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
Bonjour,
J'ai effectué un upgrade de Limesurvey de 1.71 vers 2.00+, puis créé un nouveau questionnaire.
Les questions conditionnelles ne fonctionnent plus correctement, voici ci-dessous les essais effecués et en pièce jointe le fichier de logique.
Auriez-vous, s'il vous plaît, une idée du problème ?
Je vous remercie d'avance,
Anne-Marie Pocquet

=== 1ère configuration :même groupe ===
* Questions :
- Q-0 : question oui/non
- Q-1 : question à afficher si Q-0 = oui
* Résultat : la question conditionnelle Q-1 s'affiche toujours quelle que soit la valeur de Q-0

=== 2ème configuration : 2 groupes ===
* Questions :
* 1er groupe : Q-0 : question oui/non
* 2ème groupe : Q-2 : une seule question à afficher si la question du groupe précédent = oui
* Résultat : OK

=== 3ème configuration : 2 groupes ===
* On ajoute une question inconditionnelle dans le 2ème groupe.
* Questions :
* 1er groupe : Q-0 : question oui/non
* 2ème groupe :
- Q-2 : question à afficher si Q-0 = oui
- Q-3 : question inconditionnelle
* Résultat : la question conditionnelle Q-2 s'affiche quelle que soit la valeur de Q-0
The administrator has disabled public write access.

Version 2.00+ : problème avec les questions conditionnelles 1 year 2 weeks ago #100514

  • riqcles
  • riqcles's Avatar
  • OFFLINE
  • Expert Lime
  • Posts: 122
  • Thank you received: 7
  • Karma: 2
Bonjour,
tu peux importer ton questionnaire dans la V2 de démo du site de limesurvey ?
Si son fonctionnement est correct, il faudra déterminer ce qui s'est passé dans ta migration.
LimeSurvey version 2.05 build 140520 / 1.92+ build 120909 / 1.85+ (plus pour longtemps ! yes ! )
OS : CentOS 6.5 / PHP 5.3.13/
BDD : PostGresql 9.3 /PostGresql 8.4.11
The administrator has disabled public write access.

Version 2.00+ : problème avec les questions conditionnelles 1 year 1 week ago #100577

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6435
  • Thank you received: 840
  • Karma: 249
Salut,

Et assure toi bien de plusieurs choses:
- Tester avec un modèle par défaut.
- S'assurer que les codes de questions sont différents
The administrator has disabled public write access.

Version 2.00+ : problème avec les questions conditionnelles 1 year 1 day ago #100913

  • pocquet
  • pocquet's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
Bonjour,
Je n'avais pas vu les réponses à mon message, d'où le retard. Je vous remercie pour cette piste, j'ai suivi votre conseil et tout fonctionne sur le site de démo, ce qui est rassurant. Reste maintenant à trouver le problème.
The administrator has disabled public write access.

Version 2.00+ : problème avec les questions conditionnelles 1 year 1 day ago #100914

  • pocquet
  • pocquet's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
Bonjour,
J'ai vérifié, merci pour votre conseil.
The administrator has disabled public write access.

Version 2.00+ : problème avec les questions conditionnelles 1 year 20 hours ago #100929

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6435
  • Thank you received: 840
  • Karma: 249
C'était le modèle ?

Denis
The administrator has disabled public write access.

Version 2.00+ : problème avec les questions conditionnelles + bouton précédent 11 months 3 weeks ago #101152

  • pocquet
  • pocquet's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
Bonjour,

J'ai tout repris à zéro pour ne pas mélanger les problèmes. Cette fois :
- j'installe le package limesurvey200plus-build131022.tar.gz sans aucune base de données.
- je crée un questionnaire avec le modèle par défaut
- un seul groupe avec 2 questions :
-- q1 de type oui/non
-- q2 conditionnelle si q1 est oui

Plus simple, il n'y a pas :O) mais ça ne fonctionne toujours pas, la question conditionnelle s'affiche toujours (voir fichiers attachés)

Autre problème avec cette vetrsion, le bouton "précédent" est inactif.

Je vous remercie d'avance pour votre aide.
Attachments:
The administrator has disabled public write access.

Version 2.00+ : problème avec les questions conditionnelles + bouton précédent 11 months 3 weeks ago #101173

  • pocquet
  • pocquet's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
Rebonjour,

Pour compléter mon précédent message, voilà en pièce jointe les erreurs qui s'affichent sur la console d'erreur lorsque je clique sur le bouton "Précédent".
Auriez-vous une idée, s'il vous plaît ?
Merci d'avance,
Anne-Marie
Attachments:
The administrator has disabled public write access.

Version 2.00+ : problème avec les questions conditionnelles + bouton précédent 11 months 3 weeks ago #101183

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6435
  • Thank you received: 840
  • Karma: 249
Salut,

Avec le modèle par défaut ou le tien en propre ? Pense aussi à vider ton cache navigateur.

Peut tu nous donner un lien pour ce questionnaire d'exemple ?

Denis
The administrator has disabled public write access.

Version 2.00+ : problème avec les questions conditionnelles + bouton précédent 11 months 3 weeks ago #101207

  • pocquet
  • pocquet's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
Bonjour Denis,
Je vous remercie pour votre réponse. J'avais suivi vos conseils précédents et utilisé le modèle par défaut, vidé le cache aussi. Je suis partie d'une base vide que Limesurvey a créée à l'installation.
Voilà l'URL du questionnaire : www.irit.fr/limesurvey2.0.test/index.php/729342/lang-fr
L'environnement est accessible par www.irit.fr/phpinfo.php
Merci d'avance,
Anne-Marie
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: Nickko
Time to create page: 0.126 seconds
Donation Image