Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Insertion de réponse

Insertion de réponse 1 year 4 months ago #95682

  • arnaud21
  • arnaud21's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 19
  • Thank you received: 3
  • Karma: 3
Bonjour à tous,

La situation : j'ai un tableau (textes) où chaque cellule est numérique. J'ai affiché les résultats pour chaque colonne (4 en tout) et cela marche très bien (avec l'option de question "afficher les totaux pour colonnes")

Ce que souhaite faire : reporter ces résultats dans une nouvelle question. A cet effet, j'ai créé une question "multiples zones de texte court" pour remplir les réponses par défaut avec les résultats de mon tableau.

Ce que j'ai tenté de faire : j'ai regardé comment marchait INSERTANS, SQGA... Je n'y arrive pas, les résultats ne se reportent pas automatiquement.

Si quelqu'un peut m'aider, qu'il en soit d'avance remercié.
The administrator has disabled public write access.

Insertion de réponse 1 year 4 months ago #95683

  • Nickko
  • Nickko's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2087
  • Thank you received: 255
  • Karma: 55
Ce que tu souhaites faire me semble effectivement requérir l'utilisation des INSERTRANS, peux-tu nous montrer comment tu as fais, sans doute est-ce qu'il ne manque pas grand chose pour que ça fonctionne.
Nickko
Ergonome / Usability expert
The administrator has disabled public write access.

Insertion de réponse 1 year 4 months ago #95685

  • arnaud21
  • arnaud21's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 19
  • Thank you received: 3
  • Karma: 3
Merci d'avoir pris le temps de répondre.

Dans le champs des réponses par défaut de ma question, j'ai écrit le code suivant :
{INSERTANS:944486X3X31SQ001_SQ003}

conformément à ce qui est indiqué ici : manual.limesurvey.org/SGQA_identifier avec les "coordonnées" de la cellule collées, et l'underscore qui va bien...

Hélas, rien ne s'affiche dans ma cellule quand je réponds à la question à laquelle je me réfère, et, en prime, je fais ce test avec des cellules dont je connais les références. Je dois me louper quelque part, effectivement...

Alors, en plus, avec les références de la ligne "total" dont je ne connais pas le "sqga", c'est l'angoisse ^^
The administrator has disabled public write access.

Insertion de réponse 1 year 4 months ago #95686

  • Nickko
  • Nickko's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2087
  • Thank you received: 255
  • Karma: 55
1. fait le test avec des cellules dont tu connais les coordonnées.
2. es-tu sur que c'est bien SQ001_SQ003 et pas Q001_SQ003 ?

Je ne suis pas fort en INSERTRANS, je l'avoue, mais SQ ça me fait penser à sous-question et donc je pense qu'au dessus d'une sous question tu dois avoir une question (mais je ne suis pas sûr de ce que j'avance, prend ça comme une piste à explorer).
Nickko
Ergonome / Usability expert
The administrator has disabled public write access.

Insertion de réponse 1 year 4 months ago #95687

  • arnaud21
  • arnaud21's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 19
  • Thank you received: 3
  • Karma: 3
Les (SQ001_SQ003) font références aux "coordonnées" de la cellule.

Comme indiqué dans la doc, : "The particular subquestion has code 'ber1'(SQ001 dans mon cas), and the column is identified by the subquestion with code 'lab1'(SQ003 dans mon cas)"

L'exemple de la doc "1X6X12ber1_lab1" devient dans mon cas "944486X3X31SQ001_SQ003".

Mais il y a un loup quelque part...

Edit : je viens de faire un test qui fonctionne !! J'ai changé le format du questionnaire de "groupe par groupe" à question par question".

Ça soulève deux questions :

- Est-on obligé de changer de groupe de questions pour faire du "INSERTANS" ?
- La syntaxe est donc bonne, mais comment connait-on les coordonnées de la ligne "total" ?

On va y arriver :)
Last Edit: 1 year 4 months ago by arnaud21. Reason: erreur de frappe
The administrator has disabled public write access.

Insertion de réponse 1 year 4 months ago #95688

  • Nickko
  • Nickko's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2087
  • Thank you received: 255
  • Karma: 55
Il faudrait utiliser une équation pour le ligne total, mais là on sort de mon champ de compétences. Désolé.
Nickko
Ergonome / Usability expert
The administrator has disabled public write access.

Insertion de réponse 1 year 4 months ago #95689

  • arnaud21
  • arnaud21's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 19
  • Thank you received: 3
  • Karma: 3
Ok, merci pour tout :)

En attendant, je sèche...J'ai beau parcourir les forums, je ne trouve rien de tangible pour solutionner mon problème.
The administrator has disabled public write access.

Insertion de réponse 1 year 4 months ago #95696

  • Ben_V
  • Ben_V's Avatar
  • OFFLINE
  • Platinum Lime
  • Posts: 1081
  • Thank you received: 240
  • Karma: 76
Est-on obligé de changer de groupe de questions pour faire du "INSERTANS"
plus précisément il faut que ce soit sur une autre page, peut importe qu'il s'agisse d'une configuration question par question ou groupe par groupe (logique: la réponse doit être envoyée avant et afin de pouvoir être récupérée; ce n'est pas un simple affichage...)
mais comment connait-on les coordonnées de la ligne "total"
Regarde dans le package original de ton installation il y a un dossier "docs" avec des questionnaires de démo ("demosurveys"); Si tu as un peu de temps, installe-les car il y en a sûrement un qui répond à ta problématique... Au pire tu apprendras beaucoup beaucoup de choses relatives aux nouvelles fonctions de LS
Benoît

goo.gl/Bw5iM => Recherche GG dans le forum français (remplacer "exemple" dans la barre de recherche)
goo.gl/WX8PH => GG search for english forum (Replace "example" in the search bar)
goo.gl/IxiGu => Búsqueda en el foro en español (Cambiar "ejemplo" en la barra de...
The administrator has disabled public write access.

Insertion de réponse 1 year 4 months ago #95698

  • arnaud21
  • arnaud21's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 19
  • Thank you received: 3
  • Karma: 3
plus précisément il faut que ce soit sur une autre page, peut importe qu'il s'agisse d'une configuration question par question ou groupe par groupe (logique: la réponse doit être envoyée avant et afin de pouvoir être récupérée; ce n'est pas un simple affichage...)

Effectivement, cela parait logique, et cela répond effectivement à ma question
Regarde dans le package original de ton installation il y a un dossier "docs" avec des questionnaires de démo ("demosurveys"); Si tu as un peu de temps, installe-les car il y en a sûrement un qui répond à ta problématique... Au pire tu apprendras beaucoup beaucoup de choses relatives aux nouvelles fonctions de LS

C'est effectivement très instructif, merci pour l'info, mais je n'arrive pas à faire ce que je voulais de manière simple (récupérer un résultat et le coller dans une cellule récapitulative).
Il va falloir que je me rabatte vers une autre mise en oeuvre, plus alambiquée.
The administrator has disabled public write access.

Insertion de réponse 1 year 4 months ago #95699

  • Nickko
  • Nickko's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2087
  • Thank you received: 255
  • Karma: 55
Explique nous le problème qui t'as conduit à choisir comme solution d'afficher un résultat dans une cellule récapitulative et nous pourrons peut-être te dire comment bien le faire dans Limesurvey.
Nickko
Ergonome / Usability expert
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: Nickko
Time to create page: 0.119 seconds
Donation Image