Welcome, Guest
Username: Password: Remember me

TOPIC: problème avec checkintegrity

problème avec checkintegrity 1 year 11 months ago #89915

  • gabriel
  • gabriel's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 45
  • Thank you received: 4
  • Karma: 2
Bonjour à tous,

Aujourd'hui, j'ai fait la mise à jour de 1.92 à la version 2 du 9/12/2012. Tous semble correctement fonctionner sauf que lorsque je clique sur la fonction "vérifier l'intégrité des données" (le lien www.MonSiteLimeSurvey.com/index.php/admin/checkintegrity) j'obtiens une page blanche ! En mettant
'debug'=>2,
'debugsql'=>1
Je reçois ce message d'erreur à la place de la page blanche :
Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 46 bytes) in /var/limesurvey/framework/db/ar/CActiveRecord.php on line 1794
Pour contourner ce problème et pouvoir exécuter la fonction "vérifier l'intégrité des données" j'ai modifié le fichier CActiveRecord.php cité ci-dessus en ajoutant la ligne de code suivante à la 2ieme ligne du fichier.
ini_set("memory_limit","256M");
Maintenant la fonction de vérification d'intégrité remarche correctement.
Ma question : y a-t-il une autre méthode plus propre pour augmenter la limite de mémoire pour exécuter le script CActiveRecord.php ?

Merci
Last Edit: 1 year 11 months ago by gabriel.
The administrator has disabled public write access.

Re: problème avec checkintegrity 1 year 11 months ago #89929

  • Ben_V
  • Ben_V's Avatar
  • OFFLINE
  • Platinum Lime
  • Posts: 1155
  • Thank you received: 274
  • Karma: 79
Gabriel,

La solution pour laquelle tu as opté semble correcte (et propre)... En fait je n'avais vu un passer un post traitant de ce problême, donc merci, car ci le cas se représente, on saura déjà comment le traiter.

La seule relation que je peux faire c'est avec la nécessité qui revient assez fréquement chez les utilisateurs d'augmenter la valeur de la variable $memorylimit = '32M'; directement dans le fichier config-default.php.
Le commentaire dans le fichier est:
This sets how much memory LimeSurvey can access. 32M is the minimum (M=mb) recommended - if you are using PDF functions up to 64M may be needed
On reste loin de tes 256M mais la problématique est semblable.
Ben/
Benoît

goo.gl/Bw5iM => Recherche GG dans le forum français (remplacer "exemple" dans la barre de recherche)
goo.gl/WX8PH => GG search for english forum (Replace "example" in the search bar)
goo.gl/IxiGu => Búsqueda en el foro en español (Cambiar "ejemplo" en la barra de...
The administrator has disabled public write access.
The following user(s) said Thank You: gabriel

Re: problème avec checkintegrity 1 year 11 months ago #89966

  • gabriel
  • gabriel's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 45
  • Thank you received: 4
  • Karma: 2
Merci Ben !

J'avais déjà ajouté la ligne
$memorylimit = '256M';
dans mon fichier config.php mais malheureusement sans effet ! Pour cette raison j'ai rajouté la ligne de code
ini_set("memory_limit","256M");
dans le fichier
/var/limesurvey/framework/db/ar/CActiveRecord.php

Bonne journée
The administrator has disabled public write access.
The following user(s) said Thank You: Ben_V

Re: problème avec checkintegrity 1 year 11 months ago #89971

  • Nickko
  • Nickko's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2165
  • Thank you received: 278
  • Karma: 58
J'ai proposé cela : ideas.limesurvey.org/ideatorrent/idea/446/
tu t'invites à voter pour cette idée.
Nickko
Ergonome / Usability expert
The administrator has disabled public write access.

Re: problème avec checkintegrity 1 year 11 months ago #89972

  • mdekker
  • mdekker's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 341
  • Thank you received: 68
  • Karma: 38
sorry for english:

in your local config.php you will find at the end:
'config'=>array(
	// debug: Set this to 1 if you are looking for errors. If you still get no errors after enabling this
	// then please check your error-logs - either in your hosting provider admin panel or in some /logs directory
	// on your webspace.
	// LimeSurvey developers: Set this to 2 to additionally display STRICT PHP error messages and get full access to standard templates
		'debug'=>0,
		'debugsql'=>0 // Set this to 1 to enanble sql logging, only active when debug = 2
	)

modifiy that to read:
'config'=>array(
'memory_limit' => '256',
	// debug: Set this to 1 if you are looking for errors. If you still get no errors after enabling this
	// then please check your error-logs - either in your hosting provider admin panel or in some /logs directory
	// on your webspace.
	// LimeSurvey developers: Set this to 2 to additionally display STRICT PHP error messages and get full access to standard templates
		'debug'=>0,
		'debugsql'=>0 // Set this to 1 to enanble sql logging, only active when debug = 2
	)

So add the line 'memory_limit' => '256',
---
Menno Dekker
Last Edit: 1 year 11 months ago by mdekker.
The administrator has disabled public write access.
The following user(s) said Thank You: gabriel

Re: problème avec checkintegrity 1 year 11 months ago #89973

  • gabriel
  • gabriel's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 45
  • Thank you received: 4
  • Karma: 2
Thank you very much!
During this time, I changed the php.ini file by adding the line
memory_limit = 256M;
but your solution is very useful
Sincerely,
Last Edit: 1 year 11 months ago by gabriel.
The administrator has disabled public write access.
Moderators: Nickko
Time to create page: 0.508 seconds
Donation Image