Welcome, Guest
Username: Password: Remember me

TOPIC: Problème avec les modèles

Problème avec les modèles 1 year 9 months ago #88659

  • graphoced
  • graphoced's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 28
  • Karma: 0
Bonjour

je suis tout nouveau avec LimeSurvey et je ne comprends pas certaines choses. J'ai lu la documentation (en anglais, cette section m'envoie vers l'allemand quand je tente d'y aller à partir de la doc française) à ce sujet mais je ne comprends pas bien si je fais quelque chose de mal :
j'ai dupliqué un des modèles fournis par défaut (duplication et renommage du dossier) et renommé "montheme" ce modèle. Quand je vais dans LimeSurvey, je vois toujours la liste des modèles fournis par défaut mais pas le mien, même en rafraîchissant la page et même en redémarrant le navigateur : le nom de mon modèle n'apparaît pas dans la liste.
J'ai trouvé une option permettant d'importer un modèle mais ça importe un fichier ZIP et je voudrais pouvoir travailler sur le modèle et voir à chaque modif ce que ça donne à l'écran en rafraîchissement le navigateur. Est-ce que je dois à chaque modif zipper mon dossier et réimporter le modèle sous forme de fichier zip par l'interface ? Ou est-ce que je dois une première fois zipper le dossier, importer le thème et ensuite je pourrais travailler sur les CSS et les images ? (je n'ai pas tenté pour le moment, je ne voudrais pas risquer de mettre la pagaille dans mon installation)
merci de vos conseils
The administrator has disabled public write access.

Re: Problème avec les modèles 1 year 9 months ago #88668

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6318
  • Thank you received: 812
  • Karma: 242
Salut,

Les modèles personnalisé sont à mettre dans /upload/templates/. , le /templates est réservés au modèles intégrés.
C'est pour effectuer plus facilement les mises à jours : tout est regroupé dans upload + le fichier de config.

Denis
PS: pour la doc: il semble qu'un documentaliste allemand se soit gourré de langue .... GRUMF
The administrator has disabled public write access.

Re: Problème avec les modèles 1 year 9 months ago #88671

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6318
  • Thank you received: 812
  • Karma: 242
DenisChenu wrote:
PS: pour la doc: il semble qu'un documentaliste allemand se soit gourré de langue .... GRUMF
A propos : la doc est un wiki, donc si tu connais l'anglais, unemise à jour de la partie modèle pour la doc française serait la bienvenue.

Le pire c'est que on l'avais avant, mais pas moyen de remettre la main dessus.
The administrator has disabled public write access.

Re: Problème avec les modèles 1 year 9 months ago #88674

  • graphoced
  • graphoced's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 28
  • Karma: 0
Merci infiniment pour ces indications, c'est parfait, maintenant ça fonctionne, j'ai pu indiquer "mon" modèle comme modèle utilisé. il ne me reste plus qu'à retoucher ce modèle.

Quant à donner un coup de main à la version française de la documentation, pourquoi pas. J'ai déjà participé à des traductions de logiciels et j'aime bien l'esprit participatifs de projets comme LimeSurvey. Mes connaissances linguistiques s'arrêtent au français et à l'anglais mais on en reparlera dans quelques temps : pour le moment, je découvre LimeSurvey et je me vois mal mettre mon grain de sel dans la doc avec aussi peu de connaissance du logiciel (même s'il s'agit juste de traduire, il est important quand même de comprendre un minimum ce qu'on traduit)

Merci encore
The administrator has disabled public write access.

Re: Problème avec les modèles 1 year 9 months ago #88675

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6318
  • Thank you received: 812
  • Karma: 242
graphoced wrote:
(même s'il s'agit juste de traduire, il est important quand même de comprendre un minimum ce qu'on traduit)
C'est pour cela que je parlais de l'éditeur de template :).
Cependant, il me semble préférable d'avoir une page anglais avec des bouts de français que une page en allemand ;).

Mais attend un peu, bug sur la docs si on est français : bugs.limesurvey.org/view.php?id=6906

Denis
The administrator has disabled public write access.

Re: Problème avec les modèles 1 year 9 months ago #88679

  • graphoced
  • graphoced's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 28
  • Karma: 0
Je regarderai ça.
En attendant, j'ai une autre question qui a rapport aux modèles, mais peut-être que c'est un souci lié au navigateur et son cache...
J'ai commencé à modifier un modèle. J'ai changé des images : un fond pour un header, un logo et une image d'arrière-plan. Quand je prévisualise mon questionnaire, il n'y a que le fond de page qui a été pris en compte et du coup je ne peux pas voir ce que je fais et travailler de manière certaine. J'ai bien sur vérifié que les fichiers images que j'ai modifiés apparaissent bien avec les modifs que j'y ai faites et c'est bien le cas (leur nom ou emplacement n'a pas changé non plus). Je précise que je fais le montage du formulaire et de son look en local, avec LimeSurvey et XAMPP, le tout avec Chrome. Est-ce qu'il est connu que le rafraichissement se fait avec du retard ou est-ce que je dois faire une opération particulière ? (j'ai tenté de rafraichir la page, fermer la page de prévisu et relancer la prévisu du formulaire.. rien n'y fait)
The administrator has disabled public write access.

Re: Problème avec les modèles 1 year 9 months ago #88688

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6318
  • Thank you received: 812
  • Karma: 242
Salut,

Force l'actualisation du cache avec Chrome. (F5 ou bouton actualiser).

Denis
The administrator has disabled public write access.

Re: Problème avec les modèles 1 year 9 months ago #88690

  • graphoced
  • graphoced's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 28
  • Karma: 0
Merci. ça doit vraiment venir d'un souci de cache parce que parfois ça met à jour et parfois même en forçant ça ne change rien.
The administrator has disabled public write access.
Moderators: Nickko
Time to create page: 0.103 seconds
Donation Image