Welcome, Guest
Username: Password: Remember me

TOPIC: "Session expirée" pour les répondants

"Session expirée" pour les répondants 2 years 2 weeks ago #87902

  • senturus
  • senturus's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Je tente de faire appel à mes compatriotes, vu que mon sujet sur le forum international ne semble pas attirer les foules (www.limesurvey.org/fr/forum/installation...redq-for-respondents)

Quelqu'un a t'il déjà eu ce problème de "session expirée" pour les répondants ?

J'ai effectué pas loin d'une dizaine d'enquêtes avec des configurations / structures de questionnaire très semblables, sans jamais avoir eu de problèmes de ce type.

Mais dans la dernière, menée avec la version 1.92, de très nombreux répondants sont éjectés du questionnaire avant d'avoir pu aller au bout, les obligeant à tout recommencer depuis le début. Je n'ai pas eu ce problème personnellement (avant ou pendant le déroulement de l'enquête en question), mais les plaintes sont beaucoup trop nombreuses pour être un problème mineur.

Plusieurs pistes peuvent être à priori écartées :
- Les répondants sont de l'ordre du millier au total, plus de la moitié d'entre eux répondant le premier jour, et sans doute 200 ou 300 la première heure. C'est beaucoup mais au moins une de mes précédentes enquêtes avait un "débit" similaire, et il n'y a eu absolument aucun retour de ce type. Aussi, il semble que le problème subsistait toujours après le flot initial des réponses.
- Le questionnaire n'est pas long, une trentaine de questions en gros et moins de 10 minutes pour le remplir.
- Ce n'est à priori pas un problème de navigateur, les retours d'erreur semblant diversifiés à ce niveau.
- D'après mon config.php, je n'ai pas ce module "sushodin" qui visiblement cause des problèmes de ce type.

J'ai bien tenté de fouiller le forums pour des gens ayant rencontré le même problème, mais je n'ai pas trouvé de solution satisfaisante pour l'instant. Ma seule piste réside dans le passage en 2.0, mais je ne suis pas sûr que cela vienne de ça.

Tous les conseils, retours d'expériences ou propositions de correctifs sont les bienvenus !
The administrator has disabled public write access.

Re: "Session expirée" pour les répondants 2 years 2 weeks ago #87908

  • titoun31
  • titoun31's Avatar
  • OFFLINE
  • Expert Lime
  • Posts: 100
  • Thank you received: 12
  • Karma: 6
Bonjour,
2 pistes :

1. Bien vérifier dans ton php.ini la durée de session utilisateur paramétrée de souvenir à 24min (1440 secondes) je crois de base .... Si le questionnaire est long, cela peut être une explication. Checker le $sessionlifetime aussi ...

2. Si c'est une enquête qui est faite dans le réseau d'une entreprise, cela peut venir de la configuration du firewall, qui n'aime pas les sessions php ... Pour me prémunir de ce problème là chez des répondants à mes enquêtes, dans le fichier config-defaults.php je suis passé en session par base de données : $sessionhandler = 'db';
Mais cela suppose de bien calibrer l'espace disque alloué à ta BDD car ça pompe vite pas mal ... Ca dépend du matos derrière !

Bon courage

Thibault
The administrator has disabled public write access.

Re: "Session expirée" pour les répondants 2 years 2 weeks ago #87910

  • senturus
  • senturus's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Merci pour ta réponse.

Dans Limesurvey, j'ai toujours eu 3600 dans le paramètre "Durée de vie de session (secondes)", je suppose que c'est de cela dont il s'agit? Quoi qu'il en soit, le problème peut arriver parfois très tôt dans le déroulement de l'enquête au vu des retours, ce n'est pas arrivé spécifiquement à ceux qui seraient restés très longtemps dessus.

Sinon, l'enquête est effectuée depuis mon ordinateur personnel, sans Firewall particulier. Au passage, c'est un hébergement mutualisé (OVH), je ne sais pas si cela peut être un début d'explication au problème.
The administrator has disabled public write access.

Re: "Session expirée" pour les répondants 2 years 2 weeks ago #87919

  • titoun31
  • titoun31's Avatar
  • OFFLINE
  • Expert Lime
  • Posts: 100
  • Thank you received: 12
  • Karma: 6
Oui dans limesurvey, mais c'est ton php.ini qui est primordial...

Par rapport à OVH et l'hébergement mutualisé, tu ne peux pas je crois toucher au php.ini qui est natif.
The administrator has disabled public write access.

Re: "Session expirée" pour les répondants 2 years 2 weeks ago #87932

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6551
  • Thank you received: 869
  • Karma: 257
Salut,

As tu des "calculs" compliqué sur le gestionnaire d'expression ? Des filtres/conditions complexes avec scenario ?
J'ai déjà vu des questionnaires planter complètement sous certaines conditions (un calcul contradictoire par exemple).

Sinon:
- Les répondants sont de l'ordre du millier au total, plus de la moitié d'entre eux répondant le premier jour, et sans doute 200 ou 300 la première heure. C'est beaucoup mais au moins une de mes précédentes enquêtes avait un "débit" similaire, et il n'y a eu absolument aucun retour de ce type. Aussi, il semble que le problème subsistait toujours après le flot initial des réponses.
c'est un hébergement mutualisé (OVH)
Très intéressant ça, c'est quel hébergement exactement ?

Denis
The administrator has disabled public write access.
Moderators: Nickko
Time to create page: 0.115 seconds
Donation Image