Welcome, Guest
Username: Password: Remember me

TOPIC: rooturl

rooturl 1 year 8 months ago #87893

  • dawnslayer
  • dawnslayer's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 1
Bonjour,

Je viens de migrer ma version actuelle de Limesurvey 1.92 en 2.0.

J'avais modifié dans la version 1.92 le fichier /conf/config.php la variable $rooturl avec la valeur ci-dessous :

$rooturl = "https://". ( $_SERVER ? $_SERVER
: $_SERVER);

Or, depuis la migration vers la version 2.0 cette variable n'existe plus.

Existe-t'il une solution permettant de forcer Limesurvey a utilisé cette directive ?

Merci par avance pour votre aide.
Cordialement.
The administrator has disabled public write access.

Re: rooturl 1 year 8 months ago #87898

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6205
  • Thank you received: 787
  • Karma: 238
C'est un peu plus complexe, notamment sur le rooturl, mais tu peux regarder dans
application/config/config-default.php
The administrator has disabled public write access.
The following user(s) said Thank You: dawnslayer

Re: rooturl 1 year 8 months ago #87905

  • dawnslayer
  • dawnslayer's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 1
Merci pour votre réponse rapide.

Je viens de regarder le contenu du fichier config-defaults.php

Je ne vois pas d'option me permettant de forcer la modification du $rooturl ?

Pouvez-vous m'indiquer quelle directive modifier ?
Merci par avance.
The administrator has disabled public write access.

Re: rooturl 1 year 8 months ago #87906

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6205
  • Thank you received: 787
  • Karma: 238
$config ?

Par contre, il semble que l'on est pas mal utilisé Yii::app()->baseUrl dans le code.
A voir aussi : stackoverflow.com/a/11211440

Denis
The administrator has disabled public write access.

Re: rooturl 1 year 8 months ago #87945

  • dawnslayer
  • dawnslayer's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 1
Je viens de modifier la valeur de publicurl pour le https

En revanche, il semble que ça n'est pas résolu mon problème. En effet, quand je me connecte sur l'interface d'admin et que je sélectionne un sondage, l'url du questionnaire est toujours sondage.toto.fr. Je voudrai mettre par défaut sondage.toto.fr

Je vous remercie encore pour votre aide précieuse
The administrator has disabled public write access.

Re: rooturl 1 year 8 months ago #87987

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6205
  • Thank you received: 787
  • Karma: 238
Salut,

Concernant la connexion SSL, le système est différent, regarde dans les paramètres de ton installation.

Denis
The administrator has disabled public write access.
Moderators: Nickko
Time to create page: 0.125 seconds
Donation Image