Welcome, Guest
Username: Password: Remember me

TOPIC: Message d'erreur sur accueil du questionnaire

Message d'erreur sur accueil du questionnaire 1 year 5 months ago #87197

  • patrickrh
  • patrickrh's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Bonjour,
Je viens d'installer Limesurvey sur mon hébergement free.fr (je sais que c'est pas top comme hébergeur). Pour autant, tout fonctionne à merveille et c'est très bien ainsi. Par contre, en bas de la première page (celle qui présente le texte d'accueil du questionnaire), j'ai ce message qui s'affiche :
Warning: Unknown: Your script possibly relies on a session side-effect which existed until PHP 4.2.3. Please be advised that the session extension does not consider global variables as a source of data, unless register_globals is enabled. You can disable this functionality and this warning by setting session.bug_compat_42 or session.bug_compat_warn to off, respectively. in Unknown on line 0

Je sais que le problème viendrait du php.ini mais je ne peux pas désactiver les deux fonctions car Free ne donne pas accès au php.ini.

N'y a t-il pas une solution (en modifiant un des fichiers de Limesurvey) pour que ce message n’apparaisse plus ? Ce qui est vraiment bizarre, c'est que le message ne s'affiche pas dans le questionnaire, ni dans la liste des questionnaires (index.php). Le message s'affiche uniquement sur la page d'accueil du questionnaire (index.php?sid=identifiant).

Merci d'avance de votre aide.
The administrator has disabled public write access.

Re: Message d'erreur sur accueil du questionnaire 1 year 5 months ago #87216

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 5854
  • Thank you received: 716
  • Karma: 222
patrickrh wrote:
N'y a t-il pas une solution (en modifiant un des fichiers de Limesurvey) pour que ce message n’apparaisse plus ? Ce qui est vraiment bizarre, c'est que le message ne s'affiche pas dans le questionnaire, ni dans la liste des questionnaires (index.php). Le message s'affiche uniquement sur la page d'accueil du questionnaire (index.php?sid=identifiant).
Salut,

J'ai déjà cherché comment corriger ce problème, mais rien à faire. C'est free qui force. Peut être un paramètre dans le .htaccess, mais aucun de ceux que j'ai essayé n'a fonctionné.

Denis
The administrator has disabled public write access.

Re: Message d'erreur sur accueil du questionnaire 4 months 4 weeks ago #101751

  • MVT
  • MVT's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 16
  • Karma: 0
Bonjour,

Un peu tardivement certes, j'ai rencontré le même problème chez free.
Après différentes recherches, il semble que le problème soir résolu en ajoutant, dans le répertoire racine de limesurvey un fichier ini.php contenant les lignes suivantes :

session.bug_compat_42 = 1
session.bug_compat_warn = 0

Cela a-t-il une influence sur le fonctionnement ensuite ?

Lien concernant le bug :Bug php : ...session side-effect which existed until PHP 4.2.3....


D'autre part, en transformant le fichier htaccess.txt en .htaccess, cela déclenche une erreur 500 chez free.

Cordialement
The administrator has disabled public write access.

Re: Message d'erreur sur accueil du questionnaire 4 months 4 weeks ago #101752

  • Nickko
  • Nickko's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 1930
  • Thank you received: 218
  • Karma: 44
Free utilise un format de fichier .htaccess un peu particulier.
Nickko
Ergonome / Usability expert
The administrator has disabled public write access.

Re: Message d'erreur sur accueil du questionnaire 4 months 4 weeks ago #101754

  • MVT
  • MVT's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 16
  • Karma: 0
Bonjour,

par rapport à mon fichier ini.php, faut-il le laiser en l'état, brut de fonderie ! ou ajouter des lignes dans config.php du type :

ini_set('session.bug_compat_42',0);
ini_set('session.bug_compat_warn',0);

Un peu HS, j'ai aussi une question sur LimeService (upgrade)
The administrator has disabled public write access.

Re: Message d'erreur sur accueil du questionnaire 4 months 4 weeks ago #101757

  • Nickko
  • Nickko's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 1930
  • Thank you received: 218
  • Karma: 44
Essaie de les placer tout en haut.
Nickko
Ergonome / Usability expert
The administrator has disabled public write access.

Re: Message d'erreur sur accueil du questionnaire 4 months 4 weeks ago #101758

  • MVT
  • MVT's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 16
  • Karma: 0
je pense que j'ai été un peu optimiste ...
Cela ne fonctionne pas dans config.php, place après <?php

Les erreurs ...side-effect which existed until PHP 4.2.3... sont intermittentes.

le message apparaît essentiellement sur la page d'accueil du questionnaire (template default)
version 1.92+
The administrator has disabled public write access.
Moderators: Nickko
Time to create page: 0.110 seconds
Donation Image